Speed test gives vey good speed but down speed is just 2-3 kb

Page 1 of 2 12 LastLast

  1. Posts : 23
    windows 7 ultimate 32 bit
       #1

    Speed test gives vey good speed but down speed is just 2-3 kb


    guys please help me , it happens when ever i want. i speed test from speedtest.net and i get speed 0.89 mbps ( which is good for me) but if i download something , down speed is 2 kb. if i play a video it buffes so slowly that it takes ahour.

    1 thing more, this happened few days ago on my laptop, so i started using internet on my pc , this this stopped and i got high speed.. but now after some days it has started again
      My Computer


  2. Posts : 784
    Linux Mint 17 Cinnamon | Win 7 Ult x64
       #2

    Hassnain said:
    guys please help me , it happens when ever i want. i speed test from speedtest.net and i get speed 0.89 mbps ( which is good for me) but if i download something , down speed is 2 kb. if i play a video it buffes so slowly that it takes ahour.

    1 thing more, this happened few days ago on my laptop, so i started using internet on my pc , this this stopped and i got high speed.. but now after some days it has started again
    When comparing speeds, remember to divide your speedtest result by 8. 0.89 mbps is around 101KBps.

    Download speeds depend on many factors, inclduing the modem/router, traffic through your ISP at the time, and the type of download, just to name a couple.

    What type of download is it? Are they torrents? These can often be slow.

    Are downloads slow from everywhere?

    You mentioned video buffering; Do you have downloads going at the same time that you are trying to view a video? Are there other people sharing your connection (eg other family members)?

    You didn't say if you had tried rebooting the router/modem, or if you had been in contact with your ISP. These would be among the first things to try.

    As you haven't stated what you have tried, I'm going to assume none of the following have been tried. Apologies if you have tried/tested the following.

    If you plug a phone into the same wall socket at your modem do hear any noise/static or is is sound quality very poor or low volume? These might indicate physical line problems, which your Telco would need to address.

    It's also possible the equipment at your local exchange is in need of a reboot. This is often referred to as a "Port reset". Your ISP can do this for you.

    Other things you can try is replacing the phone and ethernet cable (if you are connected by cable), or replacing the line filter if you have one. If you have multiple devices on your phone line remove everything except your modem/router.

    If you have a DSL connection you know that the speeds will vary dramatically from one hour to the next. But 2KBps is poor in any situation.

    Have you tried doing ping and tracert to various sites? You ISP may want this information to place a fault report with your telco.

    copy and paste results into an email to your ISP

    ping www.google.com -t (Stop it after a minute or so).
    ping www.yahoo.com -t (Stop it after a minute or so).

    tracert www.google.com

    See how you go with the above. Get back to us if you get no joy from your ISP/Telco.

    hth
    Tanya
      My Computer


  3. Posts : 23
    windows 7 ultimate 32 bit
    Thread Starter
       #3

    HI tanya, thanks for helping me out, the thing is that 0.89 mbps is a rather v good speed for my pc, when i download torrents the round about is 90- 110 but , now the speed is 16-17 kb.
    The main thing is why speed test gives me good speed?? Well the last thing i remember is that i changed my ip address of my modem from 192.168.1.1 to 192.168.1.2. first i had manually enterd setting, but now it said that no internet access and unidentified network so i swithed from manull to automatioc ip and dns configuration. Does this things has any part in it???

    Thanks for replying buddy
      My Computer


  4. Posts : 63
    Windows 7 Ultimate x64
       #4

    Why would you change the ip of your modem?

    Let it assign all address's automatically...works best that way

    Have you power cycled or reset your modem?

    I strongly suggest as your were changing settings!

    As for torrenting, is like rolling the dice...sometimes you win sometimes you get crap.

    Have you contacted your ISP? Certain ISP's shape network traffic to slow torrents down to a crawl to discourage the use of p2p software as it severely bogs down a network and lets face facts 90 % + of torrents are illegal.

    Maybe yours has implemented this? Call and ask if they restrict torrents or shape them. Depends on where you are but some governments force the ISP to do this.

    Speedtest gives you a good result due to the type of packets they are testing. They are not little pieces being spread across multiple networks and re assembled upon arrival its straight there...straight back.

    .89 mbps is a very slow transfer rate and I'd expect there to be buffering issue's while streaming vids...specially if you get into HD.
      My Computer


  5. Posts : 784
    Linux Mint 17 Cinnamon | Win 7 Ult x64
       #5

    Hi Hassnain,

    There are two IP addresses in your modem. Your WAN IP (The one assigned by your ISP), and your LAN IP (The one used inside your network). It is ok to change the LAN address provided you keep it on the same network as your PCs. That is, 192.168.1.x. The WAN IP address should not be changed. Otherwise, you will not be able to connect to the Internet.

    Torrents rely on peer to peer networking. By its very nature, speeds are inconsistent and unpredictable. You are dependent on what speeds the other people you are getting parts of the torrent from have.

    It is not uncommon to have low speeds on a torrent, especially if there are very few seeds/peers connected.

    If you can download a file from a website at around 90 - 100 KBps (Eg CNET, Microsoft etc), and speed test shows around 0.89 and your ping times are consistent then you probably don't have a problem. There are several speedtest sites around, Try a couple of different ones and see if you get similar results to speedtest.

    You also have to contend with other traffic in your area, and as you have low bandwidth to begin with your bandwidth will vary from as low as 0 to 110KBps. Unless your download rate is consisntly low your ISP may not take a fault report.

    Here in Australia, I have a typical downstream rate of 24513. (Over 20 mbps), or around 2400 KBps. Unless the rate drops below 0.80 mbps (under 100KBps), and stays there for an extended period of time Tel$tra won't even look at it. The policy seems to be "We promise to provide a service. We don't promise it will work all of the time, and we certainly don't promise it will be reliable or stable".

    One thing you might want to try to speed up DNS searches is to use OpenDNS or Google's public DNS services. These are suggested to provide better DNS services than many (Most) ISPs.

    For OpenDNS you would set your modem's DNS servers to 208.67.220.220 and 208.67.222.222. This won't help with torrent downloads but it might help improve your web surfing experience.

    Good luck.
      My Computer


  6. Posts : 23
    windows 7 ultimate 32 bit
    Thread Starter
       #6

    Thanks i will try to contact my isp
    tanya
      My Computer


  7. Posts : 23
    windows 7 ultimate 32 bit
    Thread Starter
       #7

    and 1 mor thing, when my download speed ( on firefox, idm, or anything) is 2-3 kb, my webpage loades instantly
      My Computer


  8. Posts : 784
    Linux Mint 17 Cinnamon | Win 7 Ult x64
       #8

    Hassnain said:
    and 1 mor thing, when my download speed ( on firefox, idm, or anything) is 2-3 kb, my webpage loades instantly
    That really just suggests that the problem may be related to the torrent seeding, and not an internet problem.

    Remember also that web pages are cached, so this can give a misleading impression.

    How did you go with your ISP?
      My Computer


  9. Posts : 23
    windows 7 ultimate 32 bit
    Thread Starter
       #9

    Well , ( main ne kuch settings cherin aur kam ban giya) tanks tanya and mr. hiab for your responces.

    my problem is solved

    thanks once again
      My Computer


  10. Posts : 784
    Linux Mint 17 Cinnamon | Win 7 Ult x64
       #10

    Good to hear!
      My Computer


 
Page 1 of 2 12 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:42.
Find Us