Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: ""Local Area Connection" Doesn't have a valid ip config

19 Sep 2009   #1

Windows 7 64bit
""Local Area Connection" Doesn't have a valid ip config

This is the error I got, and I couldn't connect to the internet. ""Local Area Connection" Doesn't have a valid ip config.
It also stated that I had an unknown network, and I couldn't get an IP from the DHCP Server for some reason.

I currently have it fixed, somehow. And would really appreciate some input.

Here is what I did most recently that somehow fixed it.
I used the 'netsh int ip reset c:\resetlog.txt' method in the command prompt, and after I restarted, it still didn't work, so then, I remembered about an old computer in the garage with an ethernet card in it! So, I put that old dusty card it, and plugged my cable into it instead of the default on my motherboard. After a min of it trying to find and install a driver, it failed, and I still couldn't connect. So, I decided to plug it back into the motherboard ethernet if the card wasn't going to work, and whala, it worked...

I wonder if maybe it was the process of installing a new ethernet card?

Could somebody explain?

Now, here is what I did before that all failed to work:
*reset router + modem
*rollback driver
*reinstall basic driver
*get new drivers from manufacturer website
*system restore(to a few days ago when it worked)
*many instances of the window troubleshooter/fix not working and giving me the ""Local Area Connection" Doesn't have a valid ip config" response.
*ipconfig /release /renew ...

None of that worked, not to my knowledge.

So, I would appreciate any input on what you think happened. Thanks in advance.

My System SpecsSystem Spec
20 Sep 2009   #2

Windows 7 x86/x64, Server 2008r2, Web Server 2008

To start off I have to say two things.
  1. Welcome to the forums,
  2. Sorry about the length of time before a reply 23 hours.

In you Nic card setting is Tcp/Ip v6 enabled? If yes try to disable it, there are known issues with v6. If its not enabled enable it your router may be handing out Tcp/IP v6 address.
Have you tried to set a dynamic ip address on your machine yet?

If you dont know how to set one up I would be more than happy to help you with it.
My System SpecsSystem Spec
20 Sep 2009   #3

Windows 7 64bit

I have the same problem. I'm using the evaluation copy atm, Its not the first time its done this either..... The network map shows that its a problem with the router yet everything else thats connected to the router works fine.
after disconnecting my ethernet cable and reconnecting, it wont connect to the router and gives the error message in this thread title. Usually it just randomly comes back after a few hours.

Very frustrating.
My System SpecsSystem Spec

23 Sep 2009   #4

Windows 7 64bit

Haven't had the problem since, but I still wanna figure out wtf happened. And seeing what Phuxake said, I wonder if mine didn't just 'come back' as well, and I didn't fix a thing?

When I disable Tcp/IP v6, I lose all connection. And thus far, haven't been able to get it back until I re-enable it.

And no, I have not tired to set up a dynamic IP. and would love to figure out how to do that. Sense tells me that it will help, since it would be the IP that I use, but, sense it worthless in the computer world. (:

So, if you could link me to a quick tutorial, or, anything, I would be grateful. (;

Oh, and here's this:
Log Name:      Microsoft-Windows-Dhcp-Client/Admin
Source:        Microsoft-Windows-Dhcp-Client
Date:          9/19/2009 5:58:52 PM
Event ID:      1002
Task Category: Address Configuration State Event
Level:         Error
User:          LOCAL SERVICE
The IP address lease for the Network Card with network address 0x00044B030FEA has been denied by the DHCP server (The DHCP Server sent a DHCPNACK message).
for reference, I guess.
My System SpecsSystem Spec
23 Sep 2009   #5

Windows 7 x86/x64, Server 2008r2, Web Server 2008

If you could send me the ip address for your router I would me more than happy to create you a video showing you step by step how to setup a dynamic ip address :).
My System SpecsSystem Spec
20 Jan 2010   #6

Windows 7 Home Premium (x64) (build 7600)


In you Nic card setting is Tcp/Ip v6 enabled? If yes try to disable it, there are known issues with v6. If its not enabled enable it your router may be handing out Tcp/IP v6 address.

Many thanks for this suggestion, disabling Tcp/Ip v6 solved the problem for me after days of scratching my head.
My System SpecsSystem Spec
01 Apr 2010   #7

Mac with parrallels and Windows 7
doesn't have a valid IP config - VPN problems

Hope smeone can help.

I have a MAC and am running Windows 7 through Parrallels.

I had a VPN set up which was running ok (appears as Local Area Connection2) it has now stopped working - i don't know what I did.
I get the error message 'LAC2 does not have a valid IP configuration' This is driving me mad - i dod not know what to do - each time a try to connect to the VPN I get the error
Secure VPN Connection terminated locally by the client
Reason 412: The remote peer is no longer responding

Hope someone has experience of this and can help?!

Thank you
My System SpecsSystem Spec
11 Nov 2010   #8

Windows 7

I had the same problem following a clean rebuild of my computer to move from Vista to Windows 7. It would fail to connect to the network after sleeping but was fine if i did a shutdown. I discovered that if I went to device manager, double clicked on my Atheros NIC, when to the power management tab and unclicked the "allow the computer to turn off this device to save power", the problem was resolved.
My System SpecsSystem Spec
07 Mar 2011   #9


Hi guys!

I have had the same problem for a few days now, and have searched numerous forums and gone through hell and high water to fix it. nothing helped until I found the ultimate solution that will help everyone:


During this time you must keep your router/modem turned off, and after the ISP has fixed the problem (in my case it took half an hour) you must restart your machine with the router/modem on and connected. From then on it should be like nothing ever happened.

Just for the fun of it, here's a list of things I have tried without results:

release/renew ipconfig
restarting modem/router and computer about a zillion times
changing LAN card
creating a static IP
resetting winsock in command prompt
reinstalling Win7
reinstalling XP (I had a dual boot and I did both, losing all installations)
manually entering IP address
disabling/enabling local area connection
plugging and unplugging LAN cable
uninstalling and reinstalling LAN card driver
resetting modem/router using the reset button

And after all this, all it took was just a phone call.
This is because your ISP is THE ONLY authority when it comes to configuring your IP address. In this case, it can only be done from the outside. this is also the reason why Microsoft didn't announce any patches or fixes for this problem, because it is not their problem and responsibility.

Only one question remains, WHY is this happening? Noone has been able to answer this, and I have read tons of forum posts about it. Maybe even the guys that made Windows 7 don't know it.

I am going to copy this post on several other forums because I have seen the trouble that people are having with this problem.

If you find out why this is happening, please post it here.
My System SpecsSystem Spec
14 Apr 2011   #10

Windows 7 Home Premium x64

I had this problem, and after finding no forums or anything with the answer I thought I might just post the solution I figured out here for people who it might work for.

This is only for if you have 2 or more network adapters

>go to network and sharing center
>go to change adapter settings
>You should see all of your adapters come up, if not then make sure the drivers are installed
>hold control, then click on all your network adapters
>right click on one of them that you selected, then click "Bridge connections"
>wait a bit for it to all figure itself out
My System SpecsSystem Spec

 ""Local Area Connection" Doesn't have a valid ip config

Thread Tools

Similar help and support threads
Thread Forum
"Local Area Connection" doesn't have a valid IP configuration - Win7
Hi. So I came back to my desktop after a weekend away, and all of a sudden my wired network has changed to "Unidentified Network" with no network access. I have never had a single problem with this before and I've tried several fixes that do not do a thing. I live in a dorm and am plugged directly...
Network & Sharing
"Local Area Connection" doesn't have a valid IP configuration.
Howdy folks. Just moved back onto campus for the year and already running into some problems. I'm able to connect to the wireless internet in my dorm just fine, but it's just god awful, so I've always used a wired connection. When I try that now though, it always comes up as "Unidentified Network"...
Network & Sharing
""Local Area Connection" Doesn't have a valid ip config "
i Recently bought and hp windows 7 computer 64 bit and it was fine but two weeks later it does this it was working few hour ago and now it saids this ""Local Area Connection" Doesn't have a valid ip config" what does that mean? i couldnt fix it, i turned off the router, modem did a pc recovery...
Network & Sharing
"local area connection" doesn't have a valid ip configuration?
Yesterday and today, my computer randomly disconnected to the internet and when I tried to troubleshoot the problem, it fixed the internet connection and told me that: "local area connection" doesn't have a valid ip configuration What does this mean, why is this happening. I know it's not a...
Network & Sharing
"Local Area Connection" doesn't have a valid IP config
I got that message when I did the basic troubleshoot for my connection. The internet was working earlier this morning, and has been working for the past few months, but when I got back home today it just, seemingly randomly, stopped for no reason. Yes, I know there have been lots of people...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:32.
Twitter Facebook Google+