Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Connected to wireless but can't access the internet

24 Sep 2012   #11

Windows 7 Ultimate 64 bit

Question; when you left click your network icon in the notification area, does it show your friends network? If it does, when you click on that network, does it say connected or connect? When you hover the mouse over your friends network does it show the security type....wep, wpa or wpa2-psk. Or does it say unsecured? If it's security protected, do you have the network user name (SSID) and password to log on with?

My System SpecsSystem Spec
24 Sep 2012   #12

Windows 7 Ultimate 32 bit

Yes, ofcourse.
I have password, and it says "Connected", as you may see below.

Here are informations which gives program of my adapter:
My System SpecsSystem Spec
24 Sep 2012   #13

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

Ok, I thought you might be at your friend's house. I see now that your friend allows you to access their wireless network. It's nice to have friends that share - mine do too.

Try this: reconfigure your wireless connection with static values.

O Use the following IP address:
IP address:

If this doesn't give you access to the Internet, you'll have to ask your friend to help you. There are too many settings on a router to try and test each one on a forum.

Someone else might be able to figure it out, but that's about all I can think of.

Good luck and take your friend out for dinner every once in a while

Attached Images
Connected to wireless but can't access the internet-x.png 
My System SpecsSystem Spec

24 Sep 2012   #14

Windows 7 Ultimate 32 bit

Alright, I'll see what I can do, because right now I have to go.
I'll post later results.
Thanks for help, once more.
My System SpecsSystem Spec
24 Sep 2012   #15

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

Here's the manual (PDF) for the router you said you're trying to connect to.

There is something about your friend's router that doesn't seem correct. The manual confirms what I thought re: subnet mask and yet the autoconfig shows that your get - so there's some work to be done.

See if you can match the manual configuration to your friend's router configuration. Make a note of the differences and discuss it with your friend.
My System SpecsSystem Spec
24 Sep 2012   #16

Windows 7 Ult, Windows 8.1 Pro,

Quote   Quote: Originally Posted by kute View Post
Yes ofcourse, I've tried to open any page in a browser, it's loading blank page and then error (like I'm not connected to the internet..).
I can't connect via ethernet cable to his router if u mean that, because it's like 20 meters distance between his and my house.
However, let me tell you what's really intersting with this network.
When I reset adapter or disconnect, and again connect to the same network, for 30s there isn't
white triangle with yellow exclamation mark on it, it shows good/excellent signal and as well in properties shows for IPv4: Internet, but when I try to open page, it's just loading and an error comes out.
From what you are saying it sounds like part of the network stack is messed up, possibly TCP/ip or winsock is corrupted which is fairly common.

Winsock entries tells Windows 7 how to access your network services. Additionally, your TCP/IP protocol can be corrupted. The TCP/IP protocol is a stack of 4 layers that includes several transport layers, but when this stack is corrupt you will constantly have connectivity issues.

If you can please run the following two commands one at a time, type them into an elevated command prompt and hit enter after each one then reboot your machine and test to see if you can get to a web page.
netsh winsock reset catalog (reset winsock entries)

netsh int ip reset reset.log hit (reset TCP/IP stack)
My System SpecsSystem Spec
24 Sep 2012   #17

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

@kute: Chev65 gives a great suggestion - try that first before using the static IP address I provided.

I wish I knew as much about the TCP/IP stack on Windows as you do Rob - Thanks.
My System SpecsSystem Spec
24 Sep 2012   #18

Windows 7 Ultimate 32 bit

Thanks for reply chev65.
So, if I well understand you, I should open two command promts and then run first
netsh winsock reset catalog
then in a second command promt run
netsh int ip reset reset.log hit
and then restart?
In one cmd, write/enter first line u wrote then in a new line write/enter second line, and restart?
Also should I be connected on this wireless network, while I'm doing this commands?
My System SpecsSystem Spec
24 Sep 2012   #19

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

the command prompt must be elevated - right click to run as administrator
you can run them in the same command prompt
run them in the order Chev65 provided
No, you don't need to and should not be connected to the wireless
Sorry for jumping back in, saw this and replied to kute - Back to you Rob
My System SpecsSystem Spec
25 Sep 2012   #20

Windows 7 Ultimate 32 bit

I did this with commands and no changes.
I tried after using this commands, to do what you said with those IP-s, same happens, seem like IP/Subnet mask isn't correct or something, prob what you said, he changed configuration to the router.
Guys, thanks for attempting, I guess there are no any other chances left to try something more.
Best regards!
My System SpecsSystem Spec

 Connected to wireless but can't access the internet

Thread Tools

Similar help and support threads
Thread Forum
Wireless Network Connected but No Internet Access
Hey guys, I've been searching this forum and other resources for days now with no luck. I'm connected to our apartment's wireless network, but about a week ago I found the infamous yellow triangle and "No Internet Access." I was going along fine for about a month and this came out of nowhere. ...
Network & Sharing
LAN and Wireless connected but no internet access
Hi, my Dell dekstop is having problem to access to the internet. Dekstop connection show that LAN and wireless are connected and somehow no internet access. Tried to ping the router but it seem that the link was broken. Renewed IP address, update NIC driver and also tried to use laptop...
Network & Sharing
Wireless router is connected, no internet access, power surge?
This has probably been asked but I couldn't find anything directly relating to my problem. Last week, I lost my internet, called my ISP, and it was a problem with the modem. They replaced the modem and since then my wireless router has not worked. I assume I had a power surge that blew both the...
Network & Sharing
Connected to Wireless Network, But No Internet Access
Hi, As said, I am connected to my Wireless Network but have no Internet access. So far I have looked through the forums and done the following: - unticked the ipv6 box - pulled any Firewalls down - disabled and re-enabled my network adaptors - tried the ipconfig/release and renew - left...
Network & Sharing
Laptop losses internet access, but says "connected" to wireless router
I bought a Cisco Valet M10 wireless router a few days ago and I have been having issues where my laptop says that it is connected to network and it shows maximum strength signal, but underneath the network name it says "No internet access". I have already contacted Cisco several times and also HP,...
Network & Sharing
wireless internet connected but no internet access ?
hi, Am using dell inspiron laptop with windows 7 home premium 64 bit , i have a free wifi in our collage when i give connect it was getting connected but there is no internet access i had tried with trouble shoot it was giving problem regarding DNS pls tel me how to use wifi :)
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:47.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App