Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cannot add network printer, error 0x00000002

27 Sep 2012   #1

Windows 7 Professional x64
Cannot add network printer, error 0x00000002

I have a small problem at work with my new printer.
I have 11 computers in a classroom, the printer is connected to the teacher's computer (mine, named DELL00). However, I am unable to add the printer on any other computer in classroom, usually with error 0x00000002

All computers have admin account named Teacher, and all except the Teacher's computer have one standard account named Student.
Adding the printer on admin account went without single problem on every computer, but the pinter does not show on the Student account.
When I try to add the printer from Student account, I get error 0x00000002

I am adding the printer through Devices & Printers -> Add Printer -> Network Printer -> Not in list -> \\DELL00\LaserJet-P1102. This method worked on the admin account without problem,s but not on the student account.

Any help would be welcome, because collecting all work on flash drive and printing each one by myself is little annoying

My System SpecsSystem Spec
27 Sep 2012   #2

Win7 & Win8 64bit


Log on with Admin privilege to the computer that you wish to add a network printer to, then try adding the printer again. Now, log off then log on as a Student account then try adding the printer again.
My System SpecsSystem Spec
27 Sep 2012   #3

Windows 7 Professional x64

Hi, like I said, all computers have the printer added from admin account, but it does not show up on the Student account, and I cannot add the printer from it (getting error 0x00000002).

Or do you mean something like removing the printer, then re-add it on admin account, and then try to add it again from on the Student account?
My System SpecsSystem Spec

27 Sep 2012   #4

Win7 & Win8 64bit

Have tried restarting the Print Spooler service?

See if this resolutions helps posted by John Dickson, here's the source.
We may have found a resolution to this issue. Starting in Windows Vista and in Windows 7 we introduced Asynchronus RPC which speeds up communcation to a Windows 2008/2008 R2 Server. Windows Server 2003 doesn't support this new protocol and when Windows 7 trys to communicate using Async RPC, this is most like causing the temporary loss of communcation.

The result is the blank driver tab and port tab.

The work around is to disable Async RPC by adding the following registry key on the Windows 7/Vista clients:

HKLM\Software\Policies\Microsoft\Windows NT\Printers\EnabledProtocols
Data: 6
My System SpecsSystem Spec
27 Apr 2016   #5

Windows 7 Ultimate x64

open cmd as admin by selecting the command window , hold shift and right mousebutton;
paste this code in the window
rundll32 printui.dll PrintUIEntry /in /n \\PCRP-PSCAN07\COLOR
My System SpecsSystem Spec
28 Apr 2016   #6

windows 10 x64

Check it.u can find a latest version of driver.
i had same prob before.
My System SpecsSystem Spec

 Cannot add network printer, error 0x00000002

Thread Tools

Similar help and support threads
Thread Forum
It's not the printer, it's the network (Error code 0x80070035)
I'm moving here, simply because the issue is not printer related; it's network-related, and I wanted to get the problem updated under a better title. In a nutshell: Win7...
Network & Sharing
BSOD 0x000000d1 (0x00000030 0x00000002 0x00000000 0x916f08a5) athr.sys
I keep getting this error, please help. using a laptop, all original parts, nothing changed. Acer Aspire 5720-4258 dualcore T2330 1.6ghz 2ggb ddr2, 250gb hdd I was getting these BSOD with my windows vista, so i borrowed my friend's Win 7 ultimate x86 and now I am getting BSOD still. ...
BSOD Help and Support
Can't share printer on local network (0x00000012 error)
Hi all, I have a weird problem. And also complicated, 'cos not even my CISCO Network teacher has been able to give me a solution. I think I need some smart people here :( The thing is that I can't share my printer (connected by USB to my PC) with my laptop on another room, over the local network...
Network & Sharing
Network Printer Driver Error
I have 7 pro 64 bit and when I try to add a network printer I get the message that Windows can't find the drivers, so I locate them manually, but Windows tells me it can't connect to the printer. I have other 64 bit pros that install the network printer fine, but with this one computer I been...
Try connecting to network printer and get error 0x000003e3
I hooked the printer up directly to my laptop, which now has Windows 7, to get the driver, and then back to the original machine, xp pro. When I try to connect to the network printer with my w7 machine I get the 0x000003e3 error. Any ideas?
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:14.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App