Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Wifi has limited access

30 Sep 2012   #1

Windows 7 professional 64 bit
Wifi has limited access

Hi, im having trouble with my wifi. The day before it works fine but then the next day i turned on my Vaio laptop and it says Limited Access to my home wifi. I tried connecting to other wifi but same thing. I tried resetting the router, disabling and enabling the wireless connection but all didnt work. I tried connecting it with the cable directly still cannot connect. Finally i did a system restore to the day before where its working fine, it worked. The next day it says Limited Access again! So im guessing 'something' made my wifi error after that 1 day and i dont know what to do.. Any help would be appreciated.

My System SpecsSystem Spec
30 Sep 2012   #2

Windows 7 professional 64 bit

Something i noticed : after i use system restore, the problem happens on the next startup of windows( since i use my laptop all day the problem happens the next day) and also i tried updating my wireless driver but it worsens the problem from Limited access to unable to detect any wifi nearby.. please help
My System SpecsSystem Spec
30 Sep 2012   #3

Windows 7 professional 64 bit

Any help pls?
My System SpecsSystem Spec

09 Jan 2013   #4

Windows 7 Home premium 64 bit

DESK TOP PC Specification

Board – Asus P5G41T-M LX, serial number MT 7019017000895
Processor - 3.07 ghz Intel Pentium Dual Core
Memory – 4 gb DDR3
HDD – Hitachi 1 terrabyte
Asus TA 21 series case
OS – Win 7 Home Pro
BT Broadband up to 6Mbps

Replaced my mobo 9 months ago but did not set up the Ethernet as I had an Edimax Usb wifi connector which has consistently given me a download speed of 4.5 to 4.7 Mbps until 3 weeks ago when it dropped to 0.64 to 0.78 Mbps.
I moved the router closer to the PC and changed the filter which made no difference. I checked my 2 laptops in different parts of the house and consistently received download speeds of over 4.5 Mbps.
I followed the recent Computer Active Magazine list trying many suggestions which improved the start up time but not the download speeds.
I set up the Lan (Atheros) downloading the drivers from the Asus set up disk and immediately achieved 4.7 – 4.8 Mbps and let the PC update Win 7.
The following day after the Win 7 update the DL speed had dropped to 0.4 to 0.7 Mbps.
I checked device manager and neither Atheros Lan or Edimax USB WiFi connection had a yellow question mark to indicate a problem or in the control panel network check and there were no “unconnected cables” showing.
I have now downloaded and installed the latest drivers (Atheros comms inc (R) AR81family fast Ethernet driver from the Asus website and Atheros with no improvement.
I have removed and re-installed the drivers - no improvement.
I have followed the Asus trouble shooting procedure from their website (MAC address, IP configuration, unplugging and reconnecting the network cables – no improvement. I have followed the Windows network adapter checks enabling and resetting adapters, driver update check, disabling & re-enabling the network adapters.
When trying to connect again I received a Wan miniport error 651.
Correct user name and password inserted and again error 651 received.
Went to internet options/connections tab, selected “never dial a connection “– error 651 again
Web browser, - windows /wp, dame results-content/uploads/2009/05/, downloaded raspppoe.sys , saved to c drive
Went to Start/computer, c:\windows\system32\drivers and deleted the raspppoe sys file. Extracted new file, disabled A/Virus & firewall– same error 651.
NIC check – no conflicting devices shown
PC and router moved adjacent to ISP master plug. Switched off Lan to use WiFi pci card only. Checked download speeds still 0.62 Mbps
Re-eabled Lan and suspended WiFi - same results.
Replaced Edimax USB WiFi with a TP Link 300 Mbps Wireless N PCI Adapter card - with no improvement. Further search engine checks suggested that Win 7 driver options were not up to date.
Downloaded the Atheros driver zip file from the ASUS website, uninstalled to existing drivers & installed new ones – no improvement.

Relocated and set up my PC in a different location with different router, same ISP.
BIOS check prior to updating BIOS –
ROM type EON 25p/f80, version 0902, Date 07/272011
BIOS Image Info –
File name P5G41T-M-LX-Asus-1101, Rom, Model P5G41T-M-LX, version 1101, 06/08/2012, 18.22
Checked the download and upload speeds – no change.
Reconnected & checked the other PC from the second location, download speed of 6.9 Mbps achieved confirming a problem in my PC.
Reconnected my PC to home ISP.
Updated BIOS using Asus built in system
Went into BIOS, disabled the onboard LAN and Atheros cable.
Rechecked download speeds – no improvement.
Win 7 trouble shooting indicated wireless network adapter problem – auto fixed, no improvement.
Inssider check on channels confirmed all local WiFi set ups were using same channel (6), changed to channel 11 – no improvement
I have now run out of ideas & as internet searches suggest the problem may be with Win 7 I am looking for alternative suggestions before I fit a PCI Ethernet card.
My System SpecsSystem Spec

 Wifi has limited access

Thread Tools

Similar help and support threads
Thread Forum
WiFi Limited Access problem
I have an Acer Aspire E1-571G, running Win7 x64, I haven't used the WiFi for a week or two, and 2 days ago when I wanted to connect to a familiar wireless network, it says "connecting to the network is taking longer than usual" then I get "Limited access" and eventually it doesn't connect. I...
Network & Sharing
Limited access wifi
Perodicaly (1-10 mins) i lose my inetrnet conncetion, it comes back (30 seconds-3 minutes, sometimes i even need to troubleshooting it or restart my PC) but it is very very annoing. I have updated my Wifi driver (but it still is from 2009.07.07. isn`t there newer driver? :O). I use dell studio...
Network & Sharing
Limited access on WiFi
can anyone help about my problem? I am using WiFi for my laptop's internet the problems is that the connection says LIMITED ACCESS. Please HElp
Network & Sharing
Limited access to home wifi
Hi, so I came home from college for break and my laptop connected fine to my house WiFi on Thursday but starting last night (I didn't use it on Friday or Saturday) my laptop has "limited access" to my house WiFi. No internet access at all. I went to Starbuck's earlier and it connected...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:24.
Twitter Facebook Google+