Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: bootmgr missing. but no hd is installed

20 Sep 2009   #1

Windows 7 Ultimate 64-bit
bootmgr missing. but no hd is installed

the other day i was trying to set up a home server from a really old computer ive had laying around for a while. i have about 4 hds that i wanted to put into it for storage. since the computer is old and couldnt have boot from a dvd drive( i wanted to put win7 on it but have to settle with xp) and since the hds already had lots of other stuff on it(music pics and a few os's) i had to constantly be switching around hd's between the server and my current computer, and to save some time i sometimes keep the computers running during the switching process. unfortunately while i was switching out a hd between them i pulled out the sata power cable to the main hd on my main comp. that obviously caused it to glitch out and i immediately shut it down.

upon reboot i get the message bootmgr is missing. press crtl alt del to reboot. (which dosnt reboot). so i go and insert the win7 dvd i hadto try and do a boot repair. i get the message that it cant repair because the versions of windows dont match. so i try and do it through the terminal. when i type the command to get it started it tells me that there is no installed version of windows on the hd.

ive crapped my pants by now but finally get over it and decide to just format and reinstall. once i get to the part where i choose the hd and partition to install it on(in which i dont even get the option to format or create a new partition on it) it tells me that it encountered an error and cant install on that hd. i know that the hd still works because when i plug the thing into the server, which is up and running with xp, i am able to see all the information on it.

so i go back the the main computer and boot it up with no hd's plugged into it. and to my surprise it give me the same message: bootmgr missing. i am confused because i thought that the bootmgr for win7 was on the hd(which i know it is). so as of now i cant use another hd for the primary on my main because they are all decently small and ide and very old so i dont even trust it with info in the first place. so now i come here since there is nothing on google about bootmgr missing along with hd's missing. my mobo is a gigabyte p35 ds3l. any help would be worth so much to me

My System SpecsSystem Spec
20 Sep 2009   #2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64

Hello magic,

I can't follow your long post very well.

I assume you tried plugging in the original HD you were using - the one that as working fine before?

You booted the 7 dvd and it was unable to find any operating system, or a suitable drive for installation?

Get a bootable partition manager, like this free one - d/l the iso, burn it to cd with isoburner( don't format the cd) .

Partition Wizard Bootable CD allows user to boot computer directly to manage partition.

Try booting that and see what it says about the HD.
My System SpecsSystem Spec
20 Sep 2009   #3


Sounds to me like he should hve used tape and placed a NUMBER on ea HDD, and then reference.
#1 -Vista clean
#2 - XP - Clean
#3 - Win7 clean.
or what ever so you know which HDD is what.
also you never mentioned if you allowed Win7 to FORMAT a HDD.

Your post is very long - Yes. it also is rather confusing. since the details are jumbled. plus:
i had to constantly be switching around hd's between the server and my current computer, and to save some time i sometimes keep the computers running during the switching process.
that is Very DANGEROUS> as you have just learned.
Also why can you not install Win7
( i wanted to put win7 on it but have to settle with xp)
XP and Win7 do not play very well. It is known that XP has a major problem with Win7. due to when made. and it also DELETES some references to Win7.
I recommend you
1. make a bootable USB and place you Win7 there.
2. Then you can install Win7 (unless of course) you BIOS is so old it simply will not allow WIN 7.

PS: it really would help.
a full set of specs. read mine if your not sure what to include. Win 7 x64 does not say much...
My System SpecsSystem Spec

20 Sep 2009   #4

Windows 7 Ultimate 64-bit

thanks for the quick response guys

sorry for the long post. i either have a tendency to write very long confusing stuff or short and vague. horrible little habit.

i will give the bootable flash drive a go for the server.

the win7 dvd did find the hard drive the got it power d/c'd but it could not reinstall itself for some reason

i didnt allow win7 to completely format the main drive on my main comp(the one with the problems. i had vista on it and i didnt know what all to move over at the time. i decided to just let it install itself, windows 7, and move all vista stuff into the windows.old folder. i took me a while to decide what all to transfer from vista to 7.

i have tried plugging in the original HD, but i still get the missing bootmgr

the full spec of my main comp is as follows:

Gigabyte p35-ds3l mobo
EVGA GT 250 512mb
Seasonic s12 550w
Core2 Duo E6750 2.66GHz
4x Corsair Dominator 1066(4GB total)
WD Cariar Blue 250GB
Samsung 20x DVD/CD Burner
and of course win7 x64

for the server, its an old dell dinension 4600
barley a gig or ram
250 some odd watts or power
P4 at 2.5Ghz
EVGA Geforce 6600 256 MB
CD reader

I call her Bertha. Jamie is my main

Im thinking i may have to flash the mobo, or physically reset it, since it may be the source or the problem. seeing as when there are not even ANY hd's plugged in the missing bootmgr message still comes up. im not even sure there are jumpers to resetting the thing anyway so that may get messy
My System SpecsSystem Spec
21 Sep 2009   #5

Windows 7 Ultimate 64-bit

sorry about the double post... dont know how that happened.

but i have gotten win7 on the server. i have not tried to partition manage jamie though. ill give a go tomorrow after i lower my blood pressure with this garb
My System SpecsSystem Spec
21 Sep 2009   #6

XP_Pro, W7_7201, W7RC.vhd, SciLinux5.3, Fedora12, Fedora9_2x, OpenSolaris_09-06

Quote   Quote: Originally Posted by Magic570 View Post
sorry about the double post...
Why not just delete one or the other ?

Click 'Edit' at bottom Right.

Then 'Delete' at lower Right again.

'Click the Radio-Button' at Left that says 'Delete Message'.

Then 'Delete' bottom Right.

Presto. Deleted. (finally)
My System SpecsSystem Spec
22 Sep 2009   #7

Windows 7 Ultimate x64 (RTM)

1. Put the Windows 7 installation disc in the disc drive, and then start your computer.
2. Press a key when you are prompted.
3. Select a language, a time, a currency, a keyboard or an input method, and then click Next.
4. Click Repair your computer.
5. Click the operating system that you want to repair, and then click Next.
In the System Recovery Options dialog box, click Command Prompt.

Then enter these commands -

Bootrec.exe /FixMbr

Bootrec.exe /FixBoot

Bootrec.exe /RebuildBcd

After done reboot.
If that doesnt work repeat the above but before reboot type -

Bootsect.exe /nt60 all /force
My System SpecsSystem Spec
23 Sep 2009   #8

Windows 7 Ultimate x64 (RTM)

OP: Did you get this problem resolved?

Mods: Anyway to get this moved back to the proper forum?
My System SpecsSystem Spec
29 Sep 2009   #9

Windows 7 Ultimate 64-bit

its been a while. been very busy with other things.

i have burned the partition manager onto a cd and have booted to it. i am able to fully explore the apparently broken hd with win7. but i have no idea what else im suppose to be looking for.

think it may have something to do with the motherboard being weird out some how?

sooo update: its been fixed. i am now able to boot from the hd into the os. hazzah! there were 3 things i did that may have fixed it: i switch the sata cable to a different port. i did partition recovery or what ever its called from the bootable partition disk thing. and i removed the readyboost drive.

im assuming that it was the readyboost one that fixed the problem. since probably when i removed the power from the primary hd while the computer was running it switched over to automatically try booting from the flashdrive. and since the readyboost flashdrive has no boot file thats what was causing the computer to not find it.

i dont know. either way i am happy to have my computer back. i thank all of you who helped so much with the info for many fixes and having the patience to read my long posts.

now i have to fix a new problem with the server(bertha) not being able to boot. its not a missing boot manager. and i have to find out if one of the hds i had in it crashed. i love computers...
My System SpecsSystem Spec

 bootmgr missing. but no hd is installed

Thread Tools

Similar help and support threads
Thread Forum
Installed new hdd and turned on PC get Bootmgr is missing error???
Just replaced a failed hdd on my desktop and received Bootmgr is missing error restart the PC I went into my BIOS to boot from DVD installed my original W7 disc and it didn't load I still received the same Bootmgr is missing error. Any help in addressing this problem would be greatly...
Hardware & Devices
Bootmgr.exe missing... mpio.sys missing or corrupted. Unable to boot
I just got a computer for free, a Dell Studio 1555. When I got it, it would try to boot, then come to a screen that said that bootmgr.exe was missing. Sometimes I got a message that said something like mpio.sys was corrupted or missing. I have a Win 7 disk, so I put it in and tried to repair the...
General Discussion
Bootmgr is missing and Error Code: 0x80070017 (No OS is installed)
Ok, I'm still needing more help. I made the HDD formatted and it's in NTFS format. The disk for some reason says Bootmgr is missing. Also when I try to install Windows 7, it says error code: 0x80070017. I don't have any OS installed. I've tried the repair disk thing. Also my BIOS is PhoenixBIOS (or...
Installation & Setup
bootmgr missing error, became bootmgr MISSING.
I compressed my entire C drive. When I rebooted I got the error "Bootmgr is compressed" I don't have a optical drive, so I made a bootable USB drive using YUMI 0.2.3 and added the windows 7 recovery ISO. The USB drive boots and I can enter the recovery console, etc. It couldn't auto-repair...
General Discussion
bootmgr is missing (i dont hav any OS installed)
hey i had vista ultimate i got formated as i was installing windows 7 . an error occured sayin some file was missin or corrupt . now i hav no OS n my laptop wont start . now when i put vista or windows 7 dvd it says bootmgr is missing . how do i fix this problem and install an OS . pls help...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:37.
Twitter Facebook Google+