Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to connect through D-link router WBR-1510

02 Nov 2012   #1

Windows 7 Home premium 32bit
Unable to connect through D-link router WBR-1510


I have a Lenovo, Windows 7 Home premium 32bit. McAfee controlling my firewall.
Unable to connect to internet. Connects to my wireless network. Timewarner has given up since my other HP xp computer works. Router has problems but works OK with my HP and vonage devices.

The router is D-Link WBR-1510. Could somebody help in finding if this router is compatible to Win 7?

How do I "blow out the NIC"? How do I identify devices from drivers to uninstall?

Any help would be appreciated.


My System SpecsSystem Spec
02 Nov 2012   #2

Microsoft Community Contributor Award Recipient

Windows 7 enterprise 64 bit, Windows 7 Pro 64 bit ,Windows 8 64bit

Have you looked at the Settings for your fire wall? it could be a problem with McAfee I know I have had troubles with them not plaing very nice with any program in the past and sometimes they will simply lock down all the prots on a computer and not let any traffic through so I would check the settings on your fire wall first before doing anything else.
My System SpecsSystem Spec
03 Nov 2012   #3

Windows 7 Home premium 32bit

Thanks Dsprague. I turned off all firewalls (private, public). Figured enuf to uninstall wireless/wi-fi adapters. Restarted.

Worked on the first browser connection. And drops right after. TWarner advised to call Windows now.
Any ideas?
My System SpecsSystem Spec

03 Nov 2012   #4

Windows 7 Home premium 32bit

For those interested, I uninstalled McAfee software entirely. Internet now flows flawlessly through my computer walls.

Also, I installed the free Avast Internet security suite, until I decide on a paid anti-virus software. I guess I should have activated the McAfee program or un-installed it when it was screaming through emails to subscribe.
My System SpecsSystem Spec
04 Nov 2012   #5

Windows 7 Professional 64 Bit

No need to go to a paid antivirus, Microsoft Security Essentials scores pretty highly on threats that it'll stop, and is free from Microsoft. I tried most of the antivirus programs and typically they slowed down the computer and stopped me from doing things that I need to do, while MSE just works and never gets in my way.
My System SpecsSystem Spec

 Unable to connect through D-link router WBR-1510

Thread Tools

Similar help and support threads
Thread Forum
Win 7 unable to connect to wireless network(router)
Hi all, i have some problem with my wireless connectivity, When i try to connect to a wireless network, it keep saying "Unable to Connect to X" (let's assume the network name is X) When using network troubleshooter, it recommend me to turn off the router, keep it for 10 secs, and turn it back...
Network & Sharing
Win 7 unable to connect of win xp through router
Hi everybody i had created a work group of five to six computer through a wirless and wired router provided by the isp but the problem is when ever i try to connect my windows 7 pc to win xp pc it say enter network password which i have tried ..............what was mentioned in every forum but the...
Network & Sharing
Unable to connect a wired router
Hey, I've recently reinstalled my Windows 7 Home Premium and I since my PC does not detect the router. I've tried using a SKY recovery disk, but that failed and nothing happened. Do I need to download a specific driver so the PC can detect the router? If so, does anybody know where I could...
Unable to connect through router after W7 x86 install
Hello, new to the forums, stumbled here after trying to google up a solution to my recent network problems. I've recently made a clean install of W7 Home Premium 64-bit on my PC, and now I can't access my internet connection through my router. I'm currently connected directly through the...
Network & Sharing
ThomsonGT585 wireless router Unable to connect
Hi, I am using ubuntu lucid and am able to connect to my ThomsonTG585 wireless router, but my mother who uses win7 is unable to connect, except by Ethernet cable, which is not convenient, how can I get her connected. When I try to connect, It it says "limited connectivity" and does not let...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:44.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App