Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: limited access but adapter claims to be connected

24 Nov 2012   #1

Windows 7 professional
limited access but adapter claims to be connected

Hi all :)

My laptop has been playing up for the past two weeks, it keeps displaying 'limited access' despite my adapter claiming to be connected.
I have a Toshiba Satellite Pro c650 and the adapter is the Atheros AR9285.
I have system restored multiple times after which the internet works fine, its when I turn my laptop back on the problem seems to reoccur.
Wireless Network Connection status says that my laptop is not connected to IPv4 or IPv6. I have no idea what any of this means and have been going out of my mind trying to decipher computer language.

Please help

My System SpecsSystem Spec
24 Nov 2012   #2

Windows 7 & 8 64-bit, Mac OSX 10.8.2

Limited Access usually means that the adapter hasn't managed to get its IP address from the router and Windows has allocated a 169.254.x.x APIPA address (Automatic Private IP Addressing). This won't let you access either the router or the internet. Try deleting the existing "profile" and then go through the procedure to "Connect" again:

Go to "Control Panel > Network and Sharing Center", then click the link at the left to Manage wireless networks. Click on your network to highlight it and then select "Remove".

Now go back to the network icon beside the clock, click it to show the Available Wireless Networks, select yours and "Connect" to it, when you'll be prompted to enter the encryption key again. See if that resolves the problems.
My System SpecsSystem Spec

 limited access but adapter claims to be connected

Thread Tools

Similar help and support threads
Thread Forum
It sometimes says connected or limited access but no Internet access.
I'm using Windows 7 Home Premium 32-bit on a Dell Inspiron 1545 laptop and for some reason, the Internet has stopped working sometime during the evening on the 20th of July in 2016 after I unsuccessfully tried to fix Just Cause 2 by changing a setting for Data Execution Prevention from "turn on DEP...
Network & Sharing
Limited Access and no adapter is in the state permissible for this op.
I am running windows 7 and just recently my internet connection is no longer working. I have tried to disable and enable the adapters. I have run virus and spyware cleaners and cleaned the computer and no luck. I Reset TCP/IP stack to installation default: netsh int ip reset reset.log then I ran...
Network & Sharing
Network wireless adapter problems - Limited Access
Hi can anyone help my new Samsung laptop has just stopped allowing me access to the internet. Its not a problem with the router as I have a wired connection to a desktop that is fine. My laptop has been working ok but now I just get 'Limited Access' from the status bar. All the other checks...
Network & Sharing
Connected but says limited access
I recently just got a laptop for college.Today I tried to connect to the internet and it's connected but its says Limited access. I have been looking online to fix this problem and they say to go online. But when I open a browser I can't connect. I was wondering how I fix this? I have a cable that...
Network & Sharing
connected but with limited access
Hey guys, I just recently got a new notebook that comes with Windows 7. I'm still using my old desktop that has Vista, and that's where I'm posting from right now. Anyway, while I love my notebook I've been having some trouble lately on trying to connect with our wireless network. It would...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:06.
Twitter Facebook Google+