Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: General HomeGroup problems

25 Nov 2012   #1
Persons Can Wai

Windows 7 x64
HomeGroup Problems + Network Map doesn't display

I haven't been much into network file sharing, printer, etc, but I recently looked at my networking window and realized I can't create a HomeGroup or even view the network map (I believe the two problems are related).

1. A while ago, I removed the HomeGroup button from the navigation panel and I thought that maybe had something to do with it. I tried restoring it using the tutorial right here on this site, but it hasn't worked at all. It still is not showing.

2. In Networking, one homegroup sections is missing, and when clicking on homegroup I get various errors ("This computer can't connect to a homegroup." "HomeGroup is not ready yet. Please try again in a few minutes. If this message continues to appear, click the link to start the HomeGroup troubleshooter.")Here's an image.

3. I can't start either one of the two HomeGroup services. Upon trying to start it says "The operation could not be completed. The service cannot be started, either because it is disabled or because it has no enabled devices associated with it."

4. Another problem, slightly different but I think it is related, is that clicking "Full map" in the networking window results in "Windows cannot create the network map. Responses from other devices on the network are delayed or there is an incompatible router on the network."

I'm on Windows 7 64 bit, using a TP-Link WR841ND via ethernet.

UPDATE: I have solved everything! Check this post below.

My System SpecsSystem Spec
25 Nov 2012   #2

7 x64

No need for the use of the Homegroup. It is a Bogus function MS created for some unknown reason and it only works with Win 7 or 8 computers. If you have XP or Vista computers they can not join the homegroup.

Best is to just enable File Sharing, Share something on each computer and put them all in the Same Workgroup (Which is supported by all versions of Windows and Mac OS X). You set the Workgroup name from the Advanced section of System Properties on the Computer Name Tab. the Second button "Change".
My System SpecsSystem Spec
25 Nov 2012   #3
Persons Can Wai

Windows 7 x64

What do you think about the Network Map though? Wanted to try to get that to work.

Of course I don't need these things, but I'd like see them not broken.
My System SpecsSystem Spec

25 Nov 2012   #4

7 x64

I have no idea why your Network Map isn't showing up. It is not because of the lack of the Homegroup. I have the Homegroup feature disable, as much as I can, and still have a full NW Map.
My System SpecsSystem Spec
25 Nov 2012   #5
Persons Can Wai

Windows 7 x64

Update 1: I COMPLETELY solved the HomeGroup issue. I am dumping my entire experience here in case anybody else has the same problem - my fix may work for you too!

Did some internet searches and came up with some new leads.

First, into command line to run "/sfc scannow". It checks the integrity of Windows components to see if they are the correct, but in my case, it came back with no errors.

Then I saw to delete any files contained in "C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking". I noticed idstore.sst and with a date last modified of about 5 days ago, and then two another .sst and, but with a huge string of numbers, and last modified in 2010. Deleted them all and restarted. No change. There weren't even any new files in there as I poked around.

I then decided to turn my attetion BACK to the two services. Usually I try to start services via the Task Manager, but this time i went to the Services window that gives you more options. I noticed that both HomeGroup services had their startup type on disabled. I changed them both to automatic, and then tried manually starting them. HomeGroup Provider worked! However when I went to start HomeGroup Listener, I received the following error: "Windows could not start the HomeGroup Listener on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code -2147023143."

Even though there was an error, I checked the Network and Sharing Center again to see if anything changed. Yes! Now it says "HomeGroup: Ready to create", the section that was originally missing under "Access type: Internet". When I click on choose homegroup, it doesn't give me the yellow error and ask that I run the troubleshooter.

I then did a restart to see if that was the final thing needed to solve HomeGroup Listener. Nope. Same error when trying to start it. HomeGroup Provider was still working though. I then noticed that HomeGroup was now in the navigation panel too though, and I confirmed that HomeGroup Provider controls the navigation panel show up by turning it off/on again.

I checked my C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking\ folder, but it was still empty. Somewhere along the way it automatically created new .sst files (no idea why or how or when), but HomeGroup Listener STILL not working.

I did some more research and found the following link with people with similar problems: Cannot Join/Create HomeGroup. First person suggests "When you open administrative tools>Services, right click the 2 services pertaining to Homegroups and select properties and on the dependencies tab ensure that all of those other services are running as well. The Homegroup listener and manager have a large list of dependant services which will not allow Homegroup to run if they are disabled." I didn't notice this the first time reading ths (only in hindsight did I notice this post), but I checked the dependecies for HomeGroup listener and they were already on. My account is already administrator too.

Then I noticed somebody said to turn on the Windows Firewall service. I had mine on disable, because I use a 3rd party firewall. Turned the service on (the Windows firewall was still off though) and then HomeGroup Listener was working! I haven't tested if HomeGroups actually work in use, but for now, the two services needed for it are functional. One person said they needed to also enable "Credential Manager". Mine is on manual and at this point I don't care. If I ever one day try HomeGroups, and they dont' work, I'll turn that on myself. I also saw to enable Peer Networking Identity Manager, Peer Name Resolution Protocol, and Peer Networking Grouping. Supposedly they are needed too or could help, but like I said, I'm not going any further down the rabbit hole. Same thing as before, if it doesn't work in actual use, I'll turn them on then (mine were stopped, in manual mode).

UPDATE 2: I fixed the missing Network Map too! 100% unexpected because I was sure I was not going to solve this at all! In case anybody wonders as well, details below.

I went back to services, turning on some of the ones suggested for HomeGroups. None of them helped. Back to internet searches for help.

First topic I found was: Network Map wont load in Windows 7. Suggests to disable anti-virus and firewall. Tried, no help. Double check if router supports LLTD. It does, no help again. One person says that putting his router into non-mixed mode worked (from B/G/N to G-only to B/G), but it did nothing for me. Checked for newer drivers. Nothing.

At this point, I had no idea what to try. I knew that my Grandpa's computer can successfully create a network map, so I took a list of all his enabled services and compared them against mine, checking to see if he had something enabled that I didn't. Nothing.

I decided to just go through the entire service list myself, turning things on that I thought would work, one by one. If it didn't, I turned it back off. The first thing I turned on (from manual) was "Wired AutoConfig" and OMG, the network map is now WORKING NOW. Holy ****, I just fixed it myself! There's a big blue "?" in it, which usually is interpreted as an error, but in my case, I know it's supposed to be there. It's represents a pre-Vista modem (it doesn't display any info because it's so old it doesn't support that feature). I think everything everything is solved now. The only thing that looks weird is I thought the internet connected to the modem first, then router. Mine is showing my computer to ? to router to internet. I also I put the WLAN AutoConfig service on automatic as well. And odd, somehow my Grandpa's computer doesn't even have either service but generates a network map either way.

And to whoever is incharge of the "manual" startup type for services, and/or troubleshooters at Microsoft: you suck! I am pretty shocked that multiple problems were solved as "easily" as manually starting services. Why didn't the troubleshooter check this!? And if calls to services were actually intecepted in the first place while in manual startup, then I wouldln't have as many problems since they would just start when needed. Manual isn't supposed to mean disable (that's what disable is for), it's supposed to mean start when called to - but it was just functioning as disabled the entire time! I don't have Windows 8, but I really hope they implemented changes in these areas.
My System SpecsSystem Spec
25 Nov 2012   #6

7 x64

Glad you got it working.
My System SpecsSystem Spec
26 Nov 2012   #7

Windows 7 Ult, Windows 8.1 Pro,

The only way those services could have been disabled is if somebody disabled them or they were disabled by an installed security software because all those services are certainly enabled by default.

I've set up a Homegroup on many machines and never once needed to enable any services because they were already enabled by default. You should always set up your network first then install any A/V software after the network is all set up.

All those disabled services are sometimes caused when people follow those power saving tips by people like Black Viper which tells everyone to disable those services that aren't in use. It's too bad that eventually all those services will be needed at a later date and people always forget they turned them off in the first place.

And by the way, as you found out nothing will work with the Windows firewall disabled. Just about any third party A/V software which were User installed is in fact the most likely cause for every last problem described here.

I would think that simply posting the link below would suffice to fix most Homegroup related problems other than the Idstore.set problem.
My System SpecsSystem Spec
16 Dec 2012   #8
Persons Can Wai

Windows 7 x64

[Not to revive an old thread but I had tons of tabs open and was clearing them out and saw the above message] Actually, they were probably disabled when I got a variant of Win64/Patched.B.Gen not too long ago. Several other network services were removed in the process, it was all 100% cleaned up and such, but maybe it just turned off the rest too. The Windows firewall is crap though. I'd rather have problems to fix and use a product with a better GUI if given the choice.
My System SpecsSystem Spec
09 Nov 2017   #9

Windows 7 Ultimate 32 bit

This homegroup issue is giving me a headache. I've been trying to fix it for a day and a half now.

I have a PC connected via Ethernet cable and a laptop connected wirelessly. I am trying to join a homegroup I created today on the laptop. However, I previously (years ago) created a homegroup on my PC.

MY PC WILL NOT LET ME CONNECT TO A HOMEGROUP. I've tried everything I've found over the internet. This is a good summary of everything I've tried and it still does not work: Ultimate Troubleshooting Guide for Windows 7 HomeGroup Connection Issues

But, I can not get passed this error message preventing me from joining the homegroup. "This computer can't connect to a homegroup."

! Homegroup is not ready yet. Please try again in a few minutes. If this message continues to appear, click the link to start the HomeGroup troubleshooter.

I did the troubleshooter and it said that the windows firewall is not configured properly but then it didn't fix the issue for me.

So, I turned off my windows firewall and AVG just incase it was that and it changed nothing. I've tried everything suggested in the above tutorial and I'm running out of ideas. Please help me.

My goal is to share the files from my PC to my PS4 but at the moment the PS4 only sees the laptop. I'm guessing that's because media streaming is not turned on. I click to turn it on but it just turns grey for a second with an egg timer pop up and then returns to a deselected state.

If anyone can help it will be greatly appreciated.

Thank you very much in advance. I hope someone can help
My System SpecsSystem Spec

 General HomeGroup problems

Thread Tools

Similar help and support threads
Thread Forum
USB Driver - General Fix for Problems
General Fix for USB Driver Problems I recommend using a wired mouse and keyboard, removing all USB devices and in the section where it says Uninstall all the faded entries. take that as reading uninstall everything USB, if you cannot get hold of a wired mouse then you will have to follow the...
Installations Problems and General Questions
I am trying to set up a number of computers with either 7 Professional or 8.1 for some family members. I don't know whether to advise them to stick with 7 and wait for 10 or go to 8.1 at this time. Any recommendations as to what i should do for them? I have noted that application Data in my...
Installation & Setup
Homegroup problems - Homegroup detected, can't join. @wit's end
I have a desktop that is connected to my Belkin router via wire. I have 3 laptops that are all connected to the router wirelessly. All computers have Windows 7 64bit and synched clocks. All are connected to a Home network. All 3 laptops detect that a Homegroup has been created on the wired...
Network & Sharing
General Help with a few problems.
Hello guys, Im new here and have found your lovely community to be really helpfull but Im still stuck on a handfull of problems with My Windows 7 run PC. If anyone could try and help run me through the following Id be very greatfull. But please bare with me as Im not 100% literate with PC's...
General Discussion
Help - RAM Diagnostic Tool and General Win7 Problems
I wasn't sure whether to put this in the hardware forum so forgive me and please move if appropriate! I purchased 4GB of RAm a few mnths ago and also got a copy of Vista HP64. From the get go I had all sort of issues in Vista - games would not run, the OS seemed to crash a lot, would get...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:12.
Twitter Facebook Google+