Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Not able to send WOL Magic Packets from W7HP64bit.

12 Dec 2012   #1

Windows 7 Home Premium 64bit
Not able to send WOL Magic Packets from W7HP64bit.

Wake-on-LAN has apparently been a major headache for many, and I've tried to search all sorts of forums for similar problem as mine.
Usually the problem is that one can't wake computer X either inside or outside LAN. Well this isn't my problem, since my computer X (old Acer 1692WLMi laptop with Windows 8 Pro as mediabox in livingroom) DOES wake up. I can wake it using iPad/iPhone (Remoter VNC app) inside my LAN.

The problem is, that I can't wake this computer X from my primary home computer Y (Gigabyte GA-EP35-DS4 MOBO, Integrated Realtek gigabit network adapter, Windows 7 Home Premium 64bit). This USED TO WORK for a long time, and then just suddenly Y stopped waking. I normally used mc-wol to wake X from Y with simple batch command line file. I've tried mc-wol and cmdwol, and I'd like to do this with a simple DOS command.

I've tried to disable firewall and to downgrade LAN adapter driver to the one that Gigabyte offers on their website for my MOBO, with no result.

I thought this must be somehow tied to my LAN adapter. But I found out a strange thing: I'm ALSO able to wake up the computer X with computer Y, if I run the same command line tool (cmdwol) with the same parameters from Windows 8 Pro 64 bit, that is installed a on virtual machine (VirtualBox) on Y. This virtual machine has a bridged adapter to my "real" LAN adapter and has it's own IP inside my LAN.

So, it seems, my computer Y is swallowing all the magic packets, but only if they're sent from the primary Windows 7 installation.

Any ideas? And please don't suggest Win 7 re-install, I've got far too many programs installed on this machine to do it for a minor glitch like this.

My System SpecsSystem Spec
13 Dec 2012   #2

Windows 7 Home Premium 64bit

Fiddled a while with LAN driver (removed entirely, booted, updated from, then I decided to test wolcmd with different settings. I found the combination of MAC address, LAN with mask and subnet mask (and default port 7) WORKED after all with my setup. Hard to say, if my fiddling had anything to do with it, but wolcmd with correct parameters work for me now, X wakes up as hoped from Y.
My System SpecsSystem Spec

 Not able to send WOL Magic Packets from W7HP64bit.

Thread Tools

Similar help and support threads
Thread Forum
Bizarre packets being sent
What is this i'm not even searching on the net or doing anything and these are being sent also i just did a factory format so there is no virus stuff,
Network & Sharing
Not receiving Packets, Internet problems
Ok, so i will start with the problem at hand. From 23 October my Internet dropped suddenly, until that day from August when i first got my Internet till 22 October it worked fine. I have found out that the problems are from Packets Received. When i connect to the Internet it works for like 5...
Network & Sharing
TCP/IP packets and wireshare
windows 7, 64 bit, Visual Studio 2008, C++ I am writing a TCP/IP application to send data to vendor software on another computer. In order to check my data I need to use Wireshare. I am practicting on my home computer. It is connected to a Belkin router than a cable modem. when I...
Network & Sharing
UPD packets
All, I am on Windows 7, HP PC.... cable modem.. I keep getting messages on my Norton AV that read, "Inbound UDP Packet Allowed". I traced the ISP these packets are coming from... and it is my ISP.VIA port 53. I see that one of the ISPs, however, is in another state on the other side of the...
Network & Sharing
Not getting as much packets as in Windows 7
Hi, this is probably more of a Windows XP problem but because I'm comparing it with Windows 7, I post it here. Here's actually a copy&paste of what I've written in other forums, but still got no answer to it. I have a Windows XP Home Edition SP3 running on an Intel QuadCore (Core2Quad) machine...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:45.
Twitter Facebook Google+