Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Deleted registry entry to fix code 31, network adapters won't work

12 Jan 2013   #1

Windows 7 32bit
Deleted registry entry to fix code 31, network adapters won't work

The comp started BSOD'ing out of nowhere, a new adapter I think called ISATAP or something like that shows up under network adapters in device manager which had a yellow exclamation icon. (Code: 31). Disabling or uninstalling its drivers resulted in BSOD's. Googled around and found the only way to fix it was to delete some registry entries, so without backing up the registry I deleted some keys. I don't remember which keys but the image above is the result. I got Ubuntu live booted up and using it to post this because my Win 7 installation obviously can't connect to the Internet.

*I tried reinstalling drivers (Marvel Yukon & Belkin), disabling and enabling stuff but nothing seems to be happening.
*Got some registry fixing tools or whatever, still the same.

Any idea how to fix this, guys ? Thanks for any help.

My System SpecsSystem Spec
12 Jan 2013   #2

Microsoft Community Contributor Award Recipient


Hello tjacob and welcome to Seven Forums.

See if you can roll back your computer to an earlier date/time (prior to editing the registry) using system restore.

System Restore
My System SpecsSystem Spec
12 Jan 2013   #3

Windows 7 32bit

Nop, no system restore either, this a month old installation. I don't have any backups.
My System SpecsSystem Spec

12 Jan 2013   #4

Microsoft Community Contributor Award Recipient


System Restore is on by default (as part of System Protection) and automatically creates restore points at least once every 7 days; more often under certain circumstances like when installing programs, some Windows Updates, drivers, etc. Are you saying you turned System Restore/System Protection off?

What is System Restore?

What is system protection?
My System SpecsSystem Spec
12 Jan 2013   #5

Windows 7 32bit

System restore is active but didn't have any restore points. I'd have happily restored to a previous date if there was one.

Any other remedies ?
My System SpecsSystem Spec
12 Jan 2013   #6

Microsoft Community Contributor Award Recipient


It's a long shot but maybe the registry editing damaged some system files. You could try running a system file checker scan from an elevated command prompt (option two.) If problems are found run the scan 3 times and reboot the computer after each scan.

SFC /SCANNOW Command - System File Checker

Also, one of the Forum experts prepared a troubleshooting guide with some additional suggestions that may help.

Troubleshooting Steps for Windows 7

One other possibility is to use a free driver scanning utility such as DriverMax. Let it run its scan and then make note of whatever drivers it says are out of date or missing. You could then visit the manufacturers' websites to see if those drivers are available. (If DriverMax says drivers are needed I think it's safer to go to the manufacturer.)

Driver update - Use DriverMax to update all your Windows PC drivers
My System SpecsSystem Spec
14 Jan 2013   #7

Windows 7 32bit

SFC didn't find anything wrong with the files and driver max needs to connect to go online to check if there the internet is working or not! anything else that can be done ?
My System SpecsSystem Spec
20 Oct 2014   #8

Windows 7 Home Premium 64-bit
It could be a Registry Issue

I had Code 31 errors across all network adapters, and finally found a solution (uninstall/reinstall of drivers didn't work, buying and adding a new wireless adapter didn't work, sfc /verifyonly didn't find anything, etc). Although the following KB article ( is for a different problem, it worked for me. My steps (slightly different/abbreviated from the KB article):

1. Download and copy latest version of the network adapter driver to the machine (I used another machine to download onto USB thumb drive)

2. Run regedit. Remember, editing the registry is dangerous, and you could make things worse! Be paranoid and back things up before you do this.

3. Locate and then export the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network. Use File/Export... menu item to backup the key in case something goes wrong)

4. Delete the registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\Config. The type of this subkey is REG_BINARY. It is the only subkey you need to delete. Don't delete the entire Network key, but if you do, you have a backup from step 3.

5. Run Device Manager, expand Network Adapters, right-click the network adapter that you want, and then click Uninstall. I chose to delete the driver also, but I don't think it was strictly necessary.

6. Restart the computer. If you deleted the driver in step 5, Windows will tell you that it failed to install the driver. This is ok (you'll install it in the next step).

7. Install the drivers that you copied to the machine in step 1. If you didn't delete the driver in step 5, then this shouldn't be necessary.
My System SpecsSystem Spec

 Deleted registry entry to fix code 31, network adapters won't work

Thread Tools

Similar help and support threads
Thread Forum
Can you copy a WinXP Pro registry entry into Win 7 registry
Hello, Background: 1. I have a program I use always, I have the install disks and can install it on Win 7 Pro x64. It is a 32 bit program. However, this program had a critical patch issued as a download way back when and this patch cannot be installed on the 7 system, because the installer is...
General Discussion
An entry in registry missing
I want gain an access to com ports and require changed in registry entry of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PNP0501 but it seems the folder is not there. I have tried regcleaner and reg fix did not help. thanks
Deleted Registry Entry, Now Users Messed Up
I have Windows 7, 64 bit, Home. I was trying to uninstall a program and deleted a registry entry that appeared related to the program, but clearly was not. The registry entry, if it matters, was at: HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Windows NT > Current Version > ProfileList > S-14...
General Discussion
Cannot delete Registry entry
After trying to recover from severe malware infection, I ran Spybot S&D. It removed several Registry entries but one it could not. I tried manually but it could not be removed. It is located at Hkey-users\S-1-5-21-200258984-2800820833-1255355968\Software\DataMngr. It has subdirectories "Files",...
System Security
No network adapters work!!! (argh)
Hello, I have a Netgear g (the WN111) and have been using it for 3 years, this has worked fine on Windows 7 x64, now I decided it was time for an upgrade to a n adapter, I have bought 2 different adapters since that decision was made, both of them have been x64 compatible however both of them,...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:48.
Twitter Facebook Google+