Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: D-Link DWA 160 extremely slow

02 Feb 2013   #1
JacksonR

Windows 7
 
 
D-Link DWA 160 extremely slow

My download speed on another laptop on the network is 10 megabits, with this adapter I can barely get one. Is this just a bad adapter or is there a possible fix?


My System SpecsSystem Spec
.
03 Feb 2013   #2
ydylan77

Windows 7 Home Premium 64bit
 
 

I don't have a whole lot to go on, but have you checked your wireless router to see if there might be any limits set for your 2.4 or 5Ghz band?
My System SpecsSystem Spec
03 Feb 2013   #3
JacksonR

Windows 7
 
 

How would I go about checking that?

Right now it is plugged into the router through ethernet, and it is getting 2.5 megabits, compared to the laptop's 10.
My System SpecsSystem Spec
.

07 Feb 2013   #4
shenryhennos

Windows 7 Professional 64bit
 
 

hi guys, this is my first time on this forum

same thing here,
I bought the dwa 160 xtreme like last year, and then a few months later, it stopped working altogether, although I got a replacement because of the warranty

now its really slow, using it on a windows 7 pc, averages like 1 or 2 Mb/s (tested through speed test.net), and it only gets like 2 bars of wireless connectivity (down the bottom on the taskbar), whereas other laptop has full bars

Also, my mac gets like around 35 Mb/s at its slowest, according to speedtest.net as well,

Does anyone happen to have a solution?
My System SpecsSystem Spec
07 Feb 2013   #5
JacksonR

Windows 7
 
 

Yep, I found the problem. After performing windows updates, the internet speed was fine.
My System SpecsSystem Spec
07 Feb 2013   #6
ydylan77

Windows 7 Home Premium 64bit
 
 

Any chance you know which update fixed the issue? Would be good info for me in the future perhaps.
My System SpecsSystem Spec
Reply

 D-Link DWA 160 extremely slow




Thread Tools




Similar help and support threads
Thread Forum
Extremely slow internet?
Hi, I just reinstalled windows 7 a few days ago. My internet became really really slow after that, with download speed of <1 Mbpsd. Before it was 70 Mbps. Does anyone know how to fix this?
Network & Sharing
Web Browser extremely slow
Has anyone else experienced problems with IE9? All of the sudden, my browser is extremely slow in uploading web pages and I can no longer download streaming videos.
Browsers & Mail
Internet Being *EXTREMELY* Slow
My internet is being really slow, it's not just slow but it's almost unusable. Pages take around a minute to load (which is a long time for me) and when they finally load, they're in text version (images don't load). I tried to play Battlefield 3 on my Xbox and it was unplayable. I'm not...
Network & Sharing
extremely slow shutdown
Hi i have windows 7 ultimate, I am now facing some wierd problem from last week when my expansion drive 500gb Seagate is connected computer takes too long time to shutdown. But i don't why my drive to be disconnected during shutdown is there any that i can try to figure out the problem what had...
Performance & Maintenance
Extremely slow boot up
Hello, new to the forums and I have a really big problem that has been with me for a year. I've learned to just ignore it but recently it almost caused me to miss turning in some homework. My laptop has been having extremely slow boot up mainly at the "Starting Windows" screen. I did some...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:11.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App