Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Red 'X' Network - 'The dependency service or group failed to start'

07 Feb 2013   #1

Windows 7 Home Premium 64bit
Red 'X' Network - 'The dependency service or group failed to start'

Hi there,

This morning I turned on my PC, which was functioning perfectly fine the day before, and saw it had a red 'X' on the network connection. The Network & Sharing center said 'The dependency service or group failed to start'".

At this point I uninstalled the last program I installed, bitcasa, especially since it was network attached storage in the cloud, so I assumed it could be causing problems. After a reboot, that didn't help.

I went into services.msc and tried to manually start the 'Network List Service', but it threw up the same error, with the code 1068. I tried to start some of the services that it depends on, I think it was the DHCP something, but it said "Error 5: Access Denied".
Furthermore, I did some basic troubleshooting stuff which I will cover below and was hit with the error message "The diagnostics policy service is not running'.

Here's stuff I tried:
Malwarebytes scan (was clean)
Basic troubleshooting (was useless)
Uninstalled bitcasa
SFC Scan (came back fine)

So, have you any idea what I can do to fix this? Here's a list of things I have compiled that I will attempt when I get home:

-Safe mode with networking
-Uninstall one other suspect program
-Turn on all services related to networking (or at least attempt to)
-Re-install motherboard network adaptors / drivers

Thanks in advance. I really need to solve this as quick as possible so unless you superstars have any awesome tricks that can fix this, I may just do a fresh install of Windows.

EDIT:I must add:
System restore is not enabled (I have an SSD)
My internet connection works fine for all other PC's in the house


My System SpecsSystem Spec
07 Feb 2013   #2

Windows 7 Home Premium 64bit

Hi everyone,

I believe the issue is fixed. I did two things:

1) Typed the commands:
net localgroup administrators localservice /add
net localgroup administrators networkservice /add

Then my internet was restored but the Firewall had been suspiciously disabled, and unable to start.

I ran ComboFix as suggested by other users. And voila, it would appear the internet works and the firewall is running.

Is there anyone that thinks all is not well still, and I should do something else?

My System SpecsSystem Spec

 Red 'X' Network - 'The dependency service or group failed to start'

Thread Tools

Similar help and support threads
Thread Forum
Dependency service or group failed to start: Network connections empty
Hello, I started my desktop and attempted to connected to the internet but it is not allowing me to. I no longer see my wifi signal bars instead there is a box with a red X. When I try to view my network connections the folder is empty. The connections have disappeared. Please help :confused:...
Network & Sharing
the dependency service or group failed to start
Hi, i am facing this problem for a couple of weeks :confused:. when i try to connect to the internet using wi-fi, it says limited access. on opening network and sharing center, under the "View your basic network information and set up connections" heading, it says "unknown", where it used to show...
Network & Sharing
The dependency service or group failed to start
I'm going to start off by apologizing for typos and sloppy grammar because I'm on a phone so I just cannot be bothered. yesterday my computer blue screened. nothing out of the ordinary. a month ago I reinstalled my os because my laptop would crash every few hours. reinstall foxed the provlem but...
Network & Sharing
The Dependency service or group failed to start.
I am having this problem and it started one day when I booted up my PC. I tried resetting the router, modem, a new cable, using netsh winsock reset catalog (reset winsock entries), netsh int ip reset reset.log hit (reset TCP/IP stack) and none of it has helped. I have updated all the drivers for...
Network & Sharing
Network Problem: The Dependency service or group failed to start.
Hi I have recently found a computer in a skip :) SCORE! It works and all but I want to get internet and when I open the network and sharing center it says "The dependency service or group has failed to start" I found this post...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:17.
Twitter Facebook Google+