Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: WIFI only connects after running troubleshooter....

12 Feb 2013   #61
Ongkanon

Windows 7 Home Premium x64
 
 

Looks like its a Realtek. I cannot find any reference to Nvidia software.


My System SpecsSystem Spec
.
12 Feb 2013   #62
Ongkanon

Windows 7 Home Premium x64
 
 

WIFI only connects after running troubleshooter....-ethernet.png


My System SpecsSystem Spec
12 Feb 2013   #63
boohbah

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

ok ,sorry for delay , sidetracked by child

the reason i asked about the Nvidea was i found a thread here that tackled the problem and worked. shame as it may have provided a solution...

Quote:
I.a. Disable Device sleep on disconnect
Some newer Nvidia Ethernet drivers have a feature called Device sleep on disconnect. This is the culprit. Normally, it should only put the Ethernet adapter to sleep when the cable is disconnected, but it's buggy and thus kills the wireless connection as well.
Follow these steps to disable this feature on your Nvidia Ethernet Adapter:

1. Open the Windows Device Manager by hitting Win+Pause, then click on Device Manager on the left side.
2. Double-click on Network adapters.
3. Double-click on NVIDIA nForce Networking Controller (yes, that's the wired Ethernet adapter indeed).
4. Click on the Advanced tab.
5. Select Device sleep on disconnect.
6. Set the Value to Disabled.
7. Click OK and wireless should work again (might require a reboot afterwards, but probably not).


Broadcom 802.11n Network Adapter not working on Windows 7 64bit
My System SpecsSystem Spec
.

12 Feb 2013   #64
boohbah

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

just had a look at the realtek family controller on my desktop and there is no Device sleep on disconnect.
so no option to change there.
sorry.
im about out of ideas,

My System SpecsSystem Spec
12 Feb 2013   #65
Ongkanon

Windows 7 Home Premium x64
 
 

Thanks for your help.

I am at a loss. I may try a repair or clean install.

Just reading through event logs to see if anything jumps out that may help.
My System SpecsSystem Spec
12 Feb 2013   #66
UsernameIssues

W7 Pro SP1 64bit
 
 

Quote   Quote: Originally Posted by Ongkanon View Post
Files are:

C:\Windows\System32\Drivers\BCMWL664.SYS

and

C:\Windows\System32\drivers\vwifibus.sys
Do you still have the file named BCMWL664.SYS on your computer?

If so, please right click on it from within the Windows (file) Explorer
...select Properties from the context menu
...select the tab named Details

Please post a screenshot of that tab.
My System SpecsSystem Spec
12 Feb 2013   #67
Ongkanon

Windows 7 Home Premium x64
 
 

WIFI only connects after running troubleshooter....-details.png


My System SpecsSystem Spec
12 Feb 2013   #68
UsernameIssues

W7 Pro SP1 64bit
 
 

When you tried to install the Lenovo drivers that were for Windows 8, it should have unpacked the 177+KB file into a folder named C:\drivers

If you still have that folder, look in:
C:\drivers\6. Wireless LAN Driver (CyberTan, Liteon)\Broadcom\inf

If the driver files are newer - or if you just want to try them - you can use the device manager method of updating the driver and browse to that "inf" folder.

WIFI only connects after running troubleshooter....-driver.png


My System SpecsSystem Spec
12 Feb 2013   #69
Ongkanon

Windows 7 Home Premium x64
 
 

I don't have the file c:\drivers\6. Wireless LAN Driver (CyberTan, Liteon)\Broadcom\inf.

I click on c: then onto drivers then a file called Wifi Driver (Broadcom, Liteon).

I click into the Broadcom file, setup, INF driver only and this is the result (I hope this is what you mean?)

WIFI only connects after running troubleshooter....-driver1.png


My System SpecsSystem Spec
12 Feb 2013   #70
Ongkanon

Windows 7 Home Premium x64
 
 

I tried to update from device manager as you suggested.

Windows won't let me as the most recent driver is already installed.
My System SpecsSystem Spec
Reply

 WIFI only connects after running troubleshooter....




Thread Tools




Similar help and support threads
Thread Forum
Wifi disconnects when another device connects to the router
Hi guys been experiencing an issue where my acer laptop disconnects from the router, a AZTECH wireless extender, when another device connects to the same extender. otherwise the main modem is CISCO. my laptop runs on windows 7 professional x64 i also attached a screenshot of the xirrus...
Network & Sharing
WiFi connects but no data is transferred
I'm having an unusual problem where I can connect to WiFi but there does not seem to be any data transferring. I have a PCI card which does not work, and a USB WiFi adapter which does work. Only using Microsoft Security Essentials for security software. Things I've tried to resolve the...
Network & Sharing
WIFI connects but unable to open Internet
Hello, I konw this subject has been introduced to the boards many times, but having read through the threads I am still unable to connect. At home everythgin works fine. WIFI connects every time. In hotels I locate the WIFI, connect no problem and immediately Skype clicks in, showing that...
Network & Sharing
At a hotel, wifi connects for a few minutes and then disconnects.
I've entered in the password on the hotels website, so I have access. It stays up for a couple of minutes, and then drops completely. There is more than one open, so it's not that it goes out of range. After a few minutes, my computer just stops searching. The only way I can get it to work(for...
Network & Sharing
New PC Windows 7 64 bit, connects to wifi router but not to internet
Hi All, I hope someone can help me as i am pulling my hair out here! I have a new laptop with Windows 7 64 bit pre-installed. The symptoms are that it won't connect wirelessly to my router at home, but will connect with a wire to the same router, and furthermore it will also connect either...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:18.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App