Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: W7 x-64 print problem (printer on Linux)

07 Oct 2009   #1

Linux CENTOS 7 / various Windows OS'es and servers
W7 x-64 print problem (printer on Linux)

Hi all

I was messing around re-arranging hardware. Since I rarely if ever TOUCH my Linux server I decided to connect 2 printers to it rather than a Windows box - I've been messing around with all sorts of hardware and software mods lately on W7 to get the optimum mix.

So Printers are now on Linux server. Samba works 100% OK etc.

Now XP SP3 / XP 64 bit edition prints just fine from the Linux box.

Print of course works just fine on Native Linux server.

W7 RTM x-64 just won't print -- gives all the correct indications - can even see print preview but nothing ever gets sent to the Linux queue. For BOTH printers.

I reverted back to RC version (only takes 10 - 15 mins to restore with decent imaging package like Acronis / Ghost etc).

Worked a treat.

W7 RTM x-86 works as well but X-64 just vanishes in cyberspace accross the network somewhere.

Incidentally printers work natively on W7 RTM x-64 so not a driver problem per se.

Any idea of where to look -- not sure if this is a SAMBA (3.05) or Windows problem. I'm running SUSE 11.1 64 bit version. - normally has no probs with networking whatsoever.

XP works (even a VM XP running on a W7 X-64 host) - but it's a bit stupid to fire up a VM whenever I need to print.

(We have other computers users in the house sharing printers - but they still are on XP for the moment. I need to get this issue fixed before upgrading their machines).



My System SpecsSystem Spec
07 Oct 2009   #2


Hello Jimbo. Can you generate a packet trace of the failed W7RTMx64-->Linux print attempt? A wireshark trace ( would reveal whether the W7 box is actually communicating at all, or whether it completely fails to initiate a session, in which case further investigation should focus on the spoolsv process.
My System SpecsSystem Spec
07 Oct 2009   #3

Linux CENTOS 7 / various Windows OS'es and servers

Hi there
I went one better - I downloaded SUSE 11.2 Milestone 8 64 bit version (Final will be released in Nov).

Guess what -- everything worked a treat.
If you use Linux and like KDE the KDE 4.3 in SUSE 11.2 is terrific BTW.

Anyway thanks for the quick response.

My System SpecsSystem Spec


 W7 x-64 print problem (printer on Linux)

Thread Tools

Similar help and support threads
Thread Forum
Printer on Linux cups server - can't print from Windows 7
Printer (brother HL-5150D) is connected to Ubuntu 10.04 Linux desktop. I'm unable to print to it from my new hp dm4t running Windows 7 Home Premium 64 bit. The printer is installed on, and works fine from, a laptop running Windows XT and a desktop running Windows 2000 Professional, and of...
Network & Sharing
Cannot communicate with scanner, printer won't print, new problem
Windows 7 64-bit, Epson WF3520. Printer/scanner worked very well for 10 months, until about 10 days ago. Have uninstalled, reinstalled. Printer makes copies. Print jobs appear in que.
Hardware & Devices
USB Printer Problem - spooler empties but no print
I have a USB printer on my Windows 7 Pro 64 bit desk top. It has worked fine for almost three years. Last the first two print jobs after boot up printed fine. The third, fourth etc. hung up in the queue which I manually emptied. Today the queue no longer stalls - rather it appears to empty...
Hardware & Devices
Problem Deleting Print job with Lexmark x7350 printer
When I'm printing my printer will print one job fine and then the next time will stop in the middle. Lexmark said that it might be because of my firewall settings. I went into my firewall settings to try to change what programs are allowed etc... but when it says click on change settings to change...
Hardware & Devices
Printer problems print button grayed out - test print page fails
Hi, I just purchased an used computer with Windows 7Home Premium x64, this is an HP Slimline s5610f. The problem that I have is with a Brother HL 2040 series printer. It gave me a really hard time to install the drivers that I downloaded from the Brother website I kept getting a "0x00000057" error...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 22:43.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App