Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Home Prem WOL works, Shutdown doesn't. How's Shutdown meant to work?

22 Feb 2013   #1

Windows 7 Home Premium x64
Home Prem WOL works, Shutdown doesn't. How's Shutdown meant to work?

Hi, My apologies for asking something which has been asked and answered in many variations, but none of which has helped much.

I have three Win7 Home Premium x64 PCs called BoyToy (my main PC), Salsa, and Polka, all of which are wired to a D-Link DIR-655 router. I want to wake and shutdown Salsa and Polka from BoyToy using Aquila’s WakeOnLan utility (which can also control non-Windows PCs) or something similar.

After enabling the BIOS and Win7 settings, I’m able to “Wake On LAN” both computers from BoyToy (yeah!) but I’m stuck on the Shutdown side—and I’ve tried many different combinations of utilities and settings.

Most recently, I’ve run Aquila’s Listener (part of their WOL utility) on Salsa with its Win7 firewall turned off and no AV running. Listener detects WOL messages sent from BoyToy (not surprising since WOL works) but it doesn’t detect Shutdown messages. From BoyToy, I’ve sent the shutdown message to different router addresses (,,, and Salsa’s address) and the results are always the same: WOL detected; shutdown not.

I’m stuck because I don’t even understand how Shutdown is supposed to work in Win7. I’ve found lots of WOL documentation but not for Shutdown. I assume it’s totally different than WOL since the computer to be shutdown is awake so it has an IP address, the Shutdown message contains timer info, warning text, etc.

I’d really appreciate it if someone could explain to me how Shutdown is supposed to work and, if possible, what I should do to diagnose and/or get it to work. I’m running everything as an administrator so that “shouldn’t” be a problem--or have I run into a brick wall having Home Premium rather than Ultimate?


My System SpecsSystem Spec
22 Feb 2013   #2

W7 Pro SP1 64bit

Welcome to the Seven Forums.

Let's try the software that is built into Windows.

Click Start, click All Programs, click Accessories, and click Command Prompt.

Type shutdown /i to display the Remote Shutdown dialog box (Shutdown.exe).

Under Computers, click Add to enter computer names, or click Browse to open the Find Computers dialog box.

Under What do you want these computers to do, click Restart or Shut down.

Source: Restart or Shut Down a Remote Computer and Document the Reason
My System SpecsSystem Spec
22 Feb 2013   #3

Windows 7 Home Premium x64

Thanks for the speedy reply!

Unfortunately, I only get as far as running the Remote Shutdown Dialog. When I press "Browse..." to add a computer, I get "The Active Directory Domain Services is currently unavailable." If I enter Salsa as the name of the target PC using the "Add" button and some "Comment" text at the bottom, I can press the Ok button but I get the error "salsa: Access is denied.(5)" in the Command Prompt window. If I try the same thing using Salsa's IP address instead of its name, I get the same error but with the IP before the colon in the error message.

This is actually pretty good news--it's the first time anything has responded at all to one of my shutdown commands!

To simplify matters (by eliminating the GUI), I tried running Command Prompt (as administrator, of course) and entered:
shutdown /s /f /m \\salsa /t 1 /d p:1:1 /c "hello"
and I got the same error: "salsa: Access is denied.(5)".

So, now I'm stuck again. Two questions: How do I get Active Directory Domain Services running (if I really need to) and why is access denied if I'm running shutdown as administrator?

Thanks for the help!
My System SpecsSystem Spec

22 Feb 2013   #4

W7 Pro SP1 64bit

You don't need Active Directory.

I'm not in a place where I can test - so I might be wasting your time...
...but here is what I think that you need:
You are sitting at BigToy and you are logged on to an account that has a password. On the computer named salsa, you need an account that has the exact same name and the exact same password. That account on salsa must also be a member of the admin group on salsa (I think). You do not need to log onto salsa with this account, but it has to be there.

...again, all of the above is just a guess. It has been a long time since I messed with this. I typically use PsTools for stuff like this.
My System SpecsSystem Spec
22 Feb 2013   #5

Windows 7 Home Premium x64

I have the exact same admin name and password on BoyToy and Salsa. Plan B?

It appears that Salsa is receiving the shutdown message but it doesn't trust me. Do you know what bit of software on Salsa is handling my request to shutdown, or how to find out? I've looked quite a bit but I haven't been able to find out what Win7 service/process/program handles shutdown messages.

My System SpecsSystem Spec
23 Feb 2013   #6

W7 Pro SP1 64bit

>> I've looked quite a bit but I haven't been able to find out what Windows 7 service/process/program handles shutdown messages.

According to event viewer on the remote computer:
The process wininit.exe <snipped> has initiated the restart of computer W7PRO64 on behalf of user W7pro64\username for the following reason: No title for this reason could be found

Resource monitor on the remote computer shows a connection to the process named System and the computer issuing the shutdown command.

To get this to work, I have to enable the admin share.
You can: the zip attached to this post the text file in notepad
...Google LocalAccountTokenFilterPolicy to find out more about it
...then merge the reg file on the remote computer
edit: log off and back on or restart the remote computer

The computer being "filmed" in the video below is a virtual machine. The tan strip on the right is part of the desktop of the host computer. The command prompt window in the upper right is running on the host computer. The host is telling the virtual machine to restart.

Attached Files
File Type: zip (381 Bytes, 113 views)
My System SpecsSystem Spec
23 Feb 2013   #7

Windows 7 Home Premium x64

Thanks so much! I'm now able to shutdown my computers.

Even better, Aquila's Wake On Lan (v.2.06.4) utility works now for both wake and shutdown! It is a lot "prettier" than Command Prompt and has some very handy features.

One note for anyone who stumbles upon this thread later: I had to reboot Salsa (my remote PC) after merging the reg edit file, a step missing after "...then merge the reg file on the remote computer" below.

I didn't reboot because the video shows you can just change the LocalAccountTokenFilterPolicy value without rebooting; my best guess is the PC in the video works as shown because the registry entry was already present and only its value is being changed. Merging the reg file generously provided by UsernameIssues adds a new entry, i.e. LocalAccountTokenFilterPolicy.

Thanks again!
My System SpecsSystem Spec
23 Feb 2013   #8

W7 Pro SP1 64bit

You are welcome and correct about a missing step. I had to assign the VM user a password - then I logged off and back on. That seems to be the minimum action required to enable the admin share for the first time. Once enabled, it can then be toggled as shown in the video. (As you noted

My System SpecsSystem Spec

 Home Prem WOL works, Shutdown doesn't. How's Shutdown meant to work?

Thread Tools

Similar help and support threads
Thread Forum
Win 7 Home Prem DVD driver missing - replugging USB does not work
The System is Toshiba laptop Win 7 home prem 64 bit. The installation is on USB, it was used on to install once before on an MSI motherboard. The system does not have USB 3 that I can see from the specs so that should not be an issue. The installation quits on the "a required CD/ DVD driver...
Installation & Setup
XBox 360 controller doesn't work when connected, and prevents shutdown
TL;DR version: XBox 360 controller, when connected makes sound, but doesn't function, and further connection/disconnection doesn't makes system sound, and also prevents shutting down. How can I solve this. In the mean time, I will uninstall the driver the best I can. Long winded version When I...
Hardware & Devices
BSOD at varying stages in Win 7 Home Prem bootup and shutdown
Hi, I've had several issues with my HP m8247c. I've had professional diagnostic completed indicating possibly failing HD as well as bad mobo. I'm not necessarily convinced after trying several HDs and getting to this point running in safe mode. So I've got it up and running and getting various...
BSOD Help and Support
shutdown.exe doesn't work
Hey guys, I've been seeing a problem with my system's shutdown file. This file, C:\Windows\System32\Shutdown.exe appears to never work whenever I try running it. I need this because during a scan or backup overnight, I like to be able to set a task to turn off the computer at a certain time so it...
General Discussion
Spontaneous shutdown; now only works in Safe Mode
Morning! The Specs Fujitsu Siemens Amilo XI 2528 - all components default: Around three/four years old Intel Core Duo CPU T8100 @ 2.1GHz nVidia GeForce 8600M GS Graphics Card 512MB OEM OS: Windows Vista Home Premium - 32 bit
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 00:27.
Twitter Facebook Google+