Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 does not "use" Intel wireless adapter. How do I fix it?

23 Feb 2013   #1

Windows 7 Home Premium 64bit
Windows 7 does not "use" Intel wireless adapter. How do I fix it?

Yesterday, my WiFi was working great, as usual. But then all of a sudden, the Wifi literally stopped working by itself. The Windows 7 taskbar utility thing (where you can see networks), lagged up and was unresponsive.

I rebooted and when I tried to connect there was a red "X" next to the little set of bars in the taskbar. The adapter was ON, however. I checked device manager - the adapter, Intel Centrino N6230, was there, enabled, and listed as working properly. No excelmation marks or anything like that.

The software for it, Intel MyWifi, states the adapter is not present. All of its functions are greyed out. I tried re-installing drivers - nothing changed.

I tried it in Safe Mode, no joy.

I tried to do a System Restore but it does not work because of an error: "Could not access a file. This may be because of an antivirus program. Disable it and try again." It was something like that. I tried disabling but it STILL gave the same error.

I know my hardware is fine, because when I try to use it under a different OS, Ubuntu-Linux, it runs perfectly fine.

Please help? This is extremely frustrating.

My System SpecsSystem Spec
24 Feb 2013   #2

Win7 & Win8 64bit

Welcome to Seven Forums,

Why not uninstall the 3rd party wireless manager and let the native Windows wireless do the work? Have you tried this? Click on Start and type Services then locate WLAN Auto Config, see attached image.

If the above suggestion didn't work, boot into Safe Mode with Networking (restart your computer and continue tapping F8 and select this option), locate Device Manager, uninstall the Wi-Fi adapter, download the updated driver from Intel Site, install the new driver. Please do not install the wireless utility manager for right now.

An update will be appreciated.

Attached Thumbnails
Windows 7 does not "use" Intel wireless adapter. How do I fix it?-wlan-auto-config.png  
My System SpecsSystem Spec
24 Feb 2013   #3

Windows 7 Home Premium 64bit


Thanks for the reply.

The strange thing is that I've never seen the IntelMyWifi software before. This is the first time. I've always had Windows do the network operations for me. The funny thing is, this has happened to me a few months ago. That incident ended badly, as somehow I got The Blue Screen of Death and therefore resorted to a fresh install.

I wasn't going to let that happen this time.

Turns out, two critical Windows Updates took place a couple of days before this problem showed its ugly face. Maybe it had an effect, maybe not. But a similar scenario occurred the previous time.

I uninstalled all third party programs related to wireless functions. Rebooted, and nothing occurred. WLAN AutoConfig was already on automatic, and started.

Safe Mode driver re-installation did nothing.

I showed Windows who's the boss here and did something new. System Restore, the one Windows set when it did the initial (first of the two) critical updates. I rebooted and it instantly connected to my home network, no problems in sight.

Looks like the problem was easier to solve than I thought. I've seen threads like this all over the interwebs, with the solutions revolving around restore points, driver re-installs, or extreme things like wiping it clean.

This was clearly a config problem - I suppose something in the updates caused a confusion between the third party services and the native Windows side of things.

Thanks for the insight.
My System SpecsSystem Spec

24 Feb 2013   #4

Win7 & Win8 64bit

Good for you! Thanks for the update.
My System SpecsSystem Spec

 Windows 7 does not "use" Intel wireless adapter. How do I fix it?

Thread Tools

Similar help and support threads
Thread Forum
"Problem with the driver for Wireless Adapter"
I have an ASUS G51VX with Windows 7 64-bit. All has been fine with my internet connection, except for a few drops here and there, but all in all it has been tolerable. When I went to bed last night it worked, when I woke up, it didn't. When I troubleshoot I get the message, "There might be a...
Network & Sharing
"Problem with wireless adapter or access point" I cant connect to wifi
Ok, first off I would just like to say that this is my first thread post on this forum so sorry if I have done something wrong or am missing vital information. My problem is that I am trying to connect to my college campus's wireless internet. I will give more specific details in a bit. Basically,...
Network & Sharing
Wireless Network Connection "adapter is not connected"
Hello, After functioning properly for a long time, my wireless internet has stopped functioning. I was watching youtube while installing the user software for a new wireless printer (Canon imageCLASS MF4800 Series) from a CD. I accidently hit the CD eject which interrupted the installation. I...
Network & Sharing
Ralink 802.11BGN 1T1R Wireless Adapter "N" Connection
Perhaps it's just not doable; but, I am going to ask some of you wonderful experts. I am hopefull to get some resolution on this one way or the other :) I have an Alienware Auroa R3 machine that has an onboard Ralink 802.11BGN 1T1R networking card. Yesterday, I purchased a Netgear router (Model...
Network & Sharing
"Problem with the driver for the Wireless Network Connection adapter"
Hi all, so I have gotten the above message when trying to connect to my wireless, and it's saying I have limited access to the connection. I know it's not a router/modem issue as all other computers in the house are connecting without trouble. This all happened after I attempted to uninstall...
Network & Sharing
"Wireless Adapter Not Found!" - Internet Adapter Problem
Hi, I bought the D-Link Xtreme N Dual Band USB Adapter (Model: DWA-160) and installed the drivers and such, and my computer detects the actual USB Adapter fine, but the software that came with the device doesn't, and gives me the message "Wireless Adapter Not Found!"... It does say that it's...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:54.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App