Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't view HomeGroup shares, asking for password, plus more.

22 Mar 2013   #1

Windows 7 64-bit
Can't view HomeGroup shares, asking for password, plus more.

OK, So I have searched and searched for a resolution for this problem. There are literally hundreds of threads with same/similar problems and just about every solution is guided towards the wrong computer. Seems a lot of helpers are not quite understanding the problem. I have tried many of the solutions to no avail. Also, please note, this setup all worked fine for about a year. This problem developed sometime over the last month. I have tried system restore on #1 as well.

Have 3 computers on network:
#1 Asus Laptop, Win 7 Professional 64-bit
#2 HP desktop, Win 7 Professional 64-bit
#3 Dell Minibook, Win 7 Starter 32-bit

Homegroup is setup on all computers, all with same password. My problem is that #1 can not view any shared folders from the other 2 units without it asking me for a username and password. Yes, I have tried using my local username/password, remote username/password and even my Homegroup password. I have tried my username and homegroupuser$ as username. I can view the different folders in the Homegroup window using Win Explorer but can not open them without the dreaded password request. If I browse the Network folder, I can see the other computers themselves, but if I try to expand them I get the password request.

Also, another couple problems that I think are related. First, on #1, in the Control Panel/Homegroup window, I get a message saying "Homegroup found a new shared printer on your home network" with an Install button. I click the button like on #3 and nothing. (Printer is on #2 and installed fine on #3). Also, I can not connect, using Remote Desktop, to either #2 or #3 using their network names, only by using their IP addresses. (And remember, I can connect, with RD, FROM #2 to #1 just fine with it's network name) It's this last problem, I think, that sets my problem apart from the rest of my searched fixes.

What I have tried:
Time/Date is in sync
Folder sharing and security permissions are all identical.
I have left the Homegroup from all computers, setting up a new one and rejoining all the computers.
I have tried regular workgroup sharing with the same results. Yes, all set to same "WORKGROUP".
Have tried, in Advanced Sharing Settings, Password Protected Sharing both on and off, setting all computers the same each time.
I have uninstalled AVG, using their removal tool on all 3.
I have tried 2 different routers, with all connecting to the same one.
Firewalls disabled.
IPv6 enable, netbios enabled.
I'm sure there is more I tried, just can't recall them all. I have been working on this now for three days and ANY help would be greatly appreciated.

My System SpecsSystem Spec
24 Mar 2013   #2

Windows 7 64-bit

Stayed up all night, with tons of coffee, and figured it out.
It had nothing at all to do with any of the computers. Found out it was a port forwarding issue in the router. I had a few ports forwarding to this laptop including the port for Remote Desktop. Not sure yet if that one is the offender, but just to eliminate everything, I deleted all forwards in the router. Bam! Immediately solved all issues. Now, I gotta figure out why this all of a sudden changed. These forwards have been in this router since last October.

If anyone has any ideas on this part of it, I would like to hear them.....
My System SpecsSystem Spec
26 Mar 2013   #3

Windows 7 64-bit

Hmmm, made no changes and now am unable to connect using RD again.

My System SpecsSystem Spec


 Can't view HomeGroup shares, asking for password, plus more.

Thread Tools

Similar help and support threads
Thread Forum
Homegroup Password - View or Print
How to View or Print Your Homegroup Password in Windows 7 If you have forgot your Windows 7 homegroup password, then this will show you how to view or print it to see what it is again. You must have this password to be able to join a computer to your homegroup.HomeGroup makes it easy to share...
New HD Shares Require Password But Not Existing Ones?
I already have a successful network setup between two Windows 7 PCs. I can access folders and share files between three different drives/partitions. I have just purchased a new HDD, created three new partitions, set the sharing settings identical to the already existing successful shares, but when...
Network & Sharing
cannot delete orphaned HomeGroup shares in Win 7
I have three Windows 7 computers, one a laptop and the other two are desktops. The laptop and one desktop are Win 7 Prof. and the remaining desktop is Win 7 Ultimate. All computers are part of my HomeGroup and share is set up for all default libraries, My Documents, My Pictures, My Music and My...
Network & Sharing
Cannot access shared folders or HomeGroup shares on this computer
The HomeGroup shares have been a recurring issue that I haven't been able to solve, but the really perplexing one is the shared folder issue which just cropped up. Some of my shared folders still work, but e, g and h (music and video respectively) for some reason spit back "Access Denied" on all of...
Network & Sharing
Windows 7 Control Panel Homegroup not revealing Homegroup Password
I installed Windows 7 on my laptop, and I also have a desktop running Windows 7. I am trying to connect my laptop to my homegroup with the password for my homegroup, but my desktop will not reveal it. Is there any other place that I can find it? Thanks in advance for your help. theAdmiral
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:05.
Twitter Facebook Google+