Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't open ports.

11 Oct 2009   #1

Windows 7 Professional
Can't open ports.

I just installed Windows 7 tonight and thus have moved from the Vista forums to here

But of course if everything were going smoothly I wouldn't be here. Now here's my problem, I'm trying to open ports for some of my programs but I havn't been able to. I've done it many times before in Vista with no trouble. I've tried disabling the firewall to see if that worked but it didn't.
Now here's where it gets weird. When I was in Vista I'd use Open Port Check Tool to check if my ports were opened correctly, it always worked. But now when I try it it tells me that my ports are closed, even basic ports like 80 and 21 keep getting:
Error: I could not see your service on on port (80)
Reason: Connection timed out

Any help will be greatly appreciated

My System SpecsSystem Spec
11 Oct 2009   #2

Win 8 Release candidate 8400


I assume you can connect to router>internet etc? Not connectivity.? what AV and firewall?

My System SpecsSystem Spec
11 Oct 2009   #3

Windows 7 Professional

I'm using NOD 32 as my AV and just Windows firewall as my firewall. And yes, other than this problem my internet is working the way it should be.
My System SpecsSystem Spec

11 Oct 2009   #4

Windows 10 Pro (x64)

If disabling the Windows Firewall didn't work, then it is not the one blocking the ports.
My System SpecsSystem Spec
11 Oct 2009   #5

Windows 7 (x64), Windows XP (x86), Backtrack 3

Are you using a router? You may have to port forward through it.
My System SpecsSystem Spec
12 Oct 2009   #6

Linux CENTOS 7 / various Windows OS'es and servers

Hi there

Typical routers have a web interface where you can configure them.

1) logon - its usually the Gateway address you assigned when you installed the router

on mine its

2) Now configure service / firewall -- its called different things on different routers but here you can open / close ports and "port forward" to specific machines on your LOCAL LAN.


Attached Thumbnails
Can't open ports.-router2.png  
Attached Images
Can't open ports.-router1.png 
My System SpecsSystem Spec
01 May 2014   #7

Windows 7

It is not the router. As I said in the OP, if I turn of the Windows Firewall, it works fine, so the router must be set up correctly. It has to the Windows Firewall not letting it through.
My System SpecsSystem Spec

 Can't open ports.

Thread Tools

Similar help and support threads
Thread Forum
Ports are no longer open
I've been hosting servers on various videogames over the year to play with my friends online, recently I tried a game which worked about a month or so ago (mount and blade: warband, I also tried a few others afterwards) but nobody could connect, I checked everything and it should have been working...
Network & Sharing
Cannot open ports
I am trying to open port 119 as my newsreader is reporting "497 setGroupDir". Tried opening ports in Windows firewall and AVG but using "canyouseeme"it says it cannot find system using port 119. I hope I am in right forum as I do not know what to do.Thanks for any help
Network & Sharing
New PC Default Open Ports
I just bought a new Lenovo W520. I was testing the Norton Firewall and running port scans against the machine. I noticed some open ports so I did a recovery to factory condition. I ran the port scan again and see a number of ports (25, 80, 110, 8080 - if memory serves correct). I telnet to the...
System Security
Why can't I open my ports?
I cant open my ports. My router has DMZ enabled and I have disabled windows 7 firewall and disabled the firewall in ESET Smart Security 4. PORTS STILL WONT OPEN!! help.... Im trying to open 55550-55560
Network & Sharing
Need to Open Ports for BC2
I contacted EA Support because each time I try to connect to EA Servers in Battlefield Bad Company 2, my internet resets and then I can play. This is definitely annoying. Here is the link they gave me My Notification Requests I'm using Comodo Firewall, plus my Router has a built in Firewall if...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 23:16.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App