Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: IPv6 is on, but can't join homegroup!

21 Oct 2009   #11

Windows 7

have had this problem and the only way out was to create homegroup with a temporary user and then share libraries of your main account. You can delete the temp. user later on.
I can consistently reproduce this problem by placing my user profile folder to a different partition,
C:\ for Windows etc.
D:\Username (ProfilesDirectory="D:\" in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList)

Definite bug

My System SpecsSystem Spec
21 Oct 2009   #12

Windows 7

My System SpecsSystem Spec
23 Oct 2009   #13

Windows 7

shawn10's Solution Worked for me.

I had Vista x64 preinstalled on my laptop and I upgraded to Win7 Ultimate.
Could not connect to HomeGroup due to lacking IPV6. I did what shawn10 recommended, rebooted and then I could immediately connect to the HomeGroup (with password since I created the HomeGroup on my stationary some time ago)

My System SpecsSystem Spec

26 Nov 2009   #14

Windows 7 Home Premium x64

Quote   Quote: Originally Posted by shawn10 View Post
Thanks Ken! But I found a solution to my problem. Apparently, not sure why, but Windows did not change the settings in the registry after enabling IPv6. I found a solution over here.

For anyone else having this problem:

1. Click Start. Search for run and press enter. In the field, type regedit and press OK.

2. In the registry, navigate to the following [COLOR=#7DA7D9 ! important][COLOR=#7DA7D9 ! important]registry [COLOR=#7DA7D9 ! important]key[/COLOR][/COLOR][/COLOR]
3. In the right pane, right-click on DisabledComponents and select modify. In the value data field, type 0″ (without quotations) and press OK.
4. Reboot your computer and it should work. It did for me.
Thought i would bump this thread rather than start a new one.

i was having the same problem as Shawn10, gettting the ipv6 is disabled message when trying to set up homegroup. its the first time i have had this problem, and i have been using homegroup since the pre beta stage.

This is the first time i have tried to set up a homegroup with windows 7 build 7600 x64 on both my laptop and desktop. i have had no issue with any of the pre beta builds, RC, or even with my desktop running the RC & laptop Build 7600, but now that i have retail on both i am getting nowhere fast.

To start with I was completely unable to create a homegroup on either. I was getting the IPV6 error

When i followed the instructions in Shawn10's post, and i set Disabled Components to 0, I am able to create a homegroup and have the laptop join it with out issue, but neither recognises each other after this point. When I go back to the registry i notice that Disabled Components has reset itself from "0" to "ff"

Is there anyway to stop this resetting itself?

I will be very grateful for any help in resolving this matter.
My System SpecsSystem Spec
01 Dec 2009   #15

Windows 7

Do you have to do this on all computer's?
My System SpecsSystem Spec
01 Dec 2009   #16

See this thread for instructions


Crazily, Win7 sees IPv6 as disabled unless there is a disableditems key that says nothing is disabled.
My System SpecsSystem Spec
02 Dec 2009   #17

Windows 7 Home Premium x64

Thanks for the replies Guys, but i decided to set up a network workgroup instead, which i was able to do without any issues whatsoever. TBH it was my own stubborness that led to me persisiting with the homegroup

I thought the idea of homegroup was so that even the least knowledgable of users could share files across a network?

Quote   Quote: Originally Posted by latherton View Post
Do you have to do this on all computer's?
TBH it was inconsistent, one minute i would be able to create a homegroup, and even on occasion join it, and i would get the user icon, but nothing happened when i clicked on it.

then i would leave it and try again, and it wouldn't even recognise the same computer it had done minutes previously

Then i would get the ipv6 is disabled error message

Quote   Quote: Originally Posted by tbernstein View Post

Crazily, Win7 sees IPv6 as disabled unless there is a disableditems key that says nothing is disabled.
i set the disabled components from ff that it was showing to 0, then restart. i would then get the option to set up the homegroup, but still could not join them. When i looked in the registry again, the disabled components value had reset itself to ff.

it was at this point i gave up on the hoimegroup, and had a workgroup set up in a couple of minutes, and 2 days later it is still working perfectly

I have been using 7 since build 6801, and have never had issue with the homegroup, it always found itself without much intervention from myself. It worked when both PC's were pre beta, when they were both beta, when they were both RC, when they were a combo of RC & Retail, but not when they were both retail

thanks very much for taking the time to reply guys
My System SpecsSystem Spec
22 Jan 2010   #18

Windows 7

Thanks Shawn10, fixed all my computers! Going to use your fix on my friends computers too!
My System SpecsSystem Spec
22 Jan 2010   #19

Windows 7 Ultimate 64Bit

From memory the registry disablement of IPv6 is not a default feature from fresh build. I'm sure it was done manually post build. Anyway good to see issue solved.
My System SpecsSystem Spec
06 Mar 2010   #20

win7 / win7 / win7 / win7 / vista / xp


Thank you Shawn10

I've been trying to find a fix for this forever!
Just found your log and its worked a treat.
Been using Win7 beta and RC for about 12 months, just upgraded with a family pack and you've helped sort this problem

Well done
My System SpecsSystem Spec

 IPv6 is on, but can't join homegroup!

Thread Tools

Similar help and support threads
Thread Forum
Unable to join homegroup, homegroup creating computer is no more
The computer that originally created the homegroup on my network is no more. It seems that because of this that my new computer is unavailable to join the homegroup that already exists. Other computers that were part of the homegroup before the "host" computer died are still part of the homegroup...
Network & Sharing
IPv6 and Homegroup
When I try to join a homegroup with my second Win 7 to the first, I get a message that IPv6 needs to be enabled. IPv6 shows enabled on both machines. What is causing this message?
Network & Sharing
Homegroup problems - Homegroup detected, can't join. @wit's end
I have a desktop that is connected to my Belkin router via wire. I have 3 laptops that are all connected to the router wirelessly. All computers have Windows 7 64bit and synched clocks. All are connected to a Home network. All 3 laptops detect that a Homegroup has been created on the wired...
Network & Sharing
Homegroup encountered an error / This computer cannot join a homegroup
I get a "Homegroup encountered an error" message when I try to join my laptop and desktop to a homegroup. It does not matter which one sets it up and which one tries to join. It errors in either direction. I have tried leaving and creating, no use. The desktop is wired to a Belkin 300N router and...
Network & Sharing
Homegroup & IPv6
i have just installed windows 7 onto my netbook, it has joined a homegroup with my main PC (win 7 pro) with no problem, but i have a HTPC (win 7 HP) that i still cannot get to join the homegroup i have updated the realtech drivers today, but it's still the same. any ideas?
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:56.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App