Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Using bridged mode works but pppoe doesn't work

02 Jul 2013   #1
Boss Dragon

Windows 7 Ultimate x64
Using bridged mode works but pppoe doesn't work

First of all, I am new to the forums, and really don't know if i can ask this question because it might not be related to W7.( I posted it here becase at anytime this forum is visited by over 10000 people) Anyways:
I have a router tp link td 8840t.
It is a small modem which i got from my isp and is good enough for my needs. When i use bridged mode and connect using broadband connection of W7 internet is awesome.
However if I use pppoeInternet becomes very choppy.
Now I was wandering why could this be? I experimented with various dns' from google ublic to opendns to my isp's dns but no matter what I try it's always choppy. So I was wondering if any of you guys or gals from this forum could help me?

My System SpecsSystem Spec
02 Jul 2013   #2

7 x64

To my knowledge ADSL 2 (+ or whatever) does not use PPPoE for authentication. The authentication for connecting to your ISPs network, allowing you internet access, is done by the modem/router serial # or the MAC address. So trying to use PPPoE is why you aren't getting any INet access. Reset the modem/router box back to factory specs. The reason you are getting good INet access with it set to Bridge Mode is it is then authenticating with your ISP but your Win 7 computer is now getting a Public IP address, not a good thing to do. Bridge mode basically make is just a modem so you can install your own router and the add on router would be set to Dynamic IP Address, Again No PPPoE. So set the modem router to Dynamic and see what happens.
My System SpecsSystem Spec
02 Jul 2013   #3
Boss Dragon

Windows 7 Ultimate x64

It's not that I don't get any Inet at all. I get it a lot speed is fine but it is choppy. Downloading using IDM works perfectly.
Flash, Javascript and other stuff doesn't work and it often doesn't load the page. PPPoE worked fine on my previous router. It sometimes tells me it's a DNS problem but changing DNS or even changing TCP MTU or TCP MSS doesn't work.
Should i put ipconfig /all log or something?
Also flush dns doesn't work.
Setting it to Dynamic can't work because to connect you need some kind of authentication.
My System SpecsSystem Spec


 Using bridged mode works but pppoe doesn't work

Thread Tools

Similar help and support threads
Thread Forum
Wireless Internet Works, Wired Connection Doesn't Work
Hi. I formatted both my laptop and desktop computer. When i did with my laptop, everything was great. Wireless still worked. Of course i have my linksys router connected to get the wireless. I then formatted my desktop. Its a dell. When i did this, everything seemed great. However, i...
Network & Sharing
External HDD: Works in WIN7, Doesn't work in XP
I was hoping for some help. I have a seagate 2 TB external HDD. It has 1 FAT32 partition. Everything works as expected in Windows Vista/7 and even in Ubuntu. When connecting the external HDD to any XP machine (tested 3 computers with XP), the device will not show up under My Computer. ...
Hardware & Devices
LIBusb, USB ports doesn't work. Safe mode also no work
After I install LIBusb I could work futher. But after I put him off en reboot an hour later my wired mouse en keyboard didn't work anymore. When I restart in safe mode both still doesnt work. OS: W7 Home Premium 64b Computer: HP Pavilion p6250 Please Help!!
Wireless doesn't work in my room in my new computer but works on my ip
I purchased a dell 15r (N5010), and have had it for about 3 days. It is a core i3 2.27Ghz, 4Gb RAM. I did a clean install of the OS to get rid of all the bloatware. I then downloaded the respective drivers from the dell website and the resource CD that came with the laptop. After the clean OS...
Network & Sharing
Downloaded W7 now Microsoft Works Doesn't Work
Downloaded W7 now Microsoft Works Doesn't Work :( MESSAGE RECEIVED: Microsoft works cannot access one or more files it needs to run. The files may have been renamed, deleted, or moved. If anyone can help i'd appreciate. Thanks
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:04.
Twitter Facebook Google+