Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't connect to an NAS on my server...

19 Oct 2009   #1

Windows 7 RTC 7100
Can't connect to an NAS on my server...


I have a few computers here in my office which are running the Windows 7 7100 RTC and we are all able to see each other perfectly. There are a few issues which I will note with seeing other computers running Windows XP Pro and seeing our NAS server attached to the network.

First I have read many of the forums on here and I setup my network connection to include every possible protocol for the Wireless NIC available.
We are all DHCP and the server is a Windows Server 2000. We can see and access the Windows Server 2000 with no problems. When we try to access our NAS (Dell Powervault 725) we are prompted for our usual login credentials. After we successfully enter them and press OK we are asked to re-enter them like we typed it incorrectly. So we do and then after 3 attempts we are given an error message saying "You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions." I am the server administrator and yes i do have full R/W control over the server.

I have updated all drivers and BIOS and firmware on the NAS and I still am not able to successfully connect. I have verified that the Login Credentials are good by using them from an XP Box which has no trouble connecting. HELP! I do not know why it is failing to use these Login credentials.

I am currently using the Windows 7 OS On my laptop and I have seen it show all of the computers on the workgroup without problems and then shortly later having changed nothing when I refresh the network I can't see any of the XP Boxes, only the Windows 7 and Vista ones. Under the
"Network and Sharing Center" screen I clicked on "Advanced sharing settings" and here are the items I have selected for my Home/Work Profile.

Turn ON network discovery
Turn ON file and print sharing
Turn ON sharing so anyone with access to the network can read and write files in the Public folders
Enable file sharing for devices that use 40- or 56-bit encryption
Turn ON password protected sharing
User user accounts and passwords to connect to other computers

So these are my settings and it Occasionally works... I have included a Screen Shot of my Protocols installed for the network adapter (Wireless).
Any help would be VERY appreciated.

Side Notes: We do not have additional Firewalls in our network, each computer is only using the windows firewall. Each computer is using the Microsoft Security Essentials for the virus/malware/spam protection.

Attached Images
Can't connect to an NAS on my server...-error.jpg Can't connect to an NAS on my server...-nic_protocols.jpg 
My System SpecsSystem Spec
19 Oct 2009   #2

Windows 7

Hey timryder, welcome. There are a lot of variables here as I am sure you know from your reading. Couple of things to try...

Part One: Sounds like you have different users names for NAS access. If this is true and your nas is called \\mack try entering your user name for the nas as mack\username just to see if the results change.

Part Two: Something I noticed over the weekend is that when my w7 laptop has "User user accounts and passwords to connect to other computers" enabled I only see my w7 computers. When I have "Allow windows to manage connections" I can see my XP boxes too. Sounds crazy because I am using workgroups and not homegroups. Not exactly sure what's going on there but you might give it a try to see your results.

Just some ideas.
My System SpecsSystem Spec
20 Oct 2009   #3

Windows 7 RTC 7100

Yeah... good idea to try but it didn't work

I typed User: Mack\timryder as it should be and still nothing...

Here is what I'm seeing.

Your comment about letting Windows manage the user worked in addition to having the TCP/IP 6 protocol.. I noticed on of my colleagues laptops that he did not have this and it made the difference.

Attached Images
Can't connect to an NAS on my server...-login_error.jpg 
My System SpecsSystem Spec

20 Oct 2009   #4

Windows 7

Are the user names and passwords the same on the nas and w7?
My System SpecsSystem Spec
20 Oct 2009   #5

Windows 7 RTC 7100

Yes they are... I verified that many times, I have also gone as far as to create a new USER on the NAS which is exactly the same login credentials as my W7 machine. No luck still
My System SpecsSystem Spec
20 Oct 2009   #6

Windows 7

That's crazy. Everything else connects except w7? How about a new user on the NAS that has nothing to do with your w7 user?
My System SpecsSystem Spec
20 Oct 2009   #7


Quote   Quote: Originally Posted by timryder View Post
Yes they are... I verified that many times, I have also gone as far as to create a new USER on the NAS which is exactly the same login credentials as my W7 machine. No luck still
The NAS box probably doesn't do NTLMv2. Try setting the Win7 machines to allow both NTLMv1 and NTLMv2.

Samba network share issue with Windows 7
My System SpecsSystem Spec
21 Oct 2009   #8

Windows 7 RTC 7100


That was it, i would have never thought of it but you nailed it on the head!

For anyone else who is having trouble connecting to remote servers and or Network Storage devices this is KEY.

GO to your control panel.

Then click on the header for "System and Security" Category

Then click on the "Administrative Tools" Category

Then Double click to open up the Local Security Policy.

Now expand the "Local Policies" group then click on the Security Options section and scroll down till you see...

"Network Security: LAN Manager authentication level" double click it and change its setting to
"Send LM & NTLM - use NTLMv2 session security if negotiated"

Close the windows and you're set!

Thanks so much guys this worked perfectly!!!
My System SpecsSystem Spec
20 Nov 2009   #9

Windows 7 home premium X64
Not on all windows 7..

Good work!

HOWEVER! - it only works on ultimate or professional, the normal "home, home premium dosn't have that option avaible... mine....
My System SpecsSystem Spec
06 Mar 2010   #10

Windows 7 64bit Ultimate

H2SO4, timryder Thanks so much! Was tearing my hair out. Could see my NAS coming up as "other device" and get into the admin side but couldn't see it's share/files.

Followed this advice and it allowed me to log in and see the files.

Have to say, as a very new Win 7 user (2 days and counting) coming from being an XP user since day one, I've found setting up a simple home network in 7 incredibly frustrating with lots of fixes being buried menus deep like this.

It's fine for MS to try and protect people who want plug and play but surely setting up devices connected via one router into one group and sharing stuff could be easier!!!

XP was far simpler to set up.

My System SpecsSystem Spec

 Can't connect to an NAS on my server...

Thread Tools

Similar help and support threads
Thread Forum
Steam can not connect to server
I have tried reinstalling Steam from disk and downloading it from Steam and I still get the error "Steam can not connect to server". I check the services and found that Steam is in manual start and if you try and put it in automatic it gives an error message, unknown at this time until restart. (I...
One PC Cannot connect to server
Dear, Server: windows 7; C shared with Everyone full access Laptop: Windows 7; PC: windows XP Laptop and WinXP PC can ping Server; Laptop can connect to Server through View workgroup Computers, mapping, etc. WinXP PC: I can't map to Server; I see it in View workgroup Computers but can't...
Network & Sharing
How to connect to server?
I have win 7 home premium 64X and I need to connect to server (Windows Server 2012) located in different building not part of the same network. I need to connect over the internet, how to establish connection to the server?
Network & Sharing
Others can't connect to my TS Server
I have a TeamSpeak 3 server that my friends and I use sometimes (Because I hate Skype). The thing is, today I wanted to start it up. I have a dynamic IP, so I had to re-forward the necessary ports for TS3. If you watch the tutorial on the basic setup of a TeamSpeak 3 Server from their support, you...
Network & Sharing
cant connect to my server
I have a server set up in my office for 10 years and it is networked in within the office. Also it is set up for me to be able to connect to it by webmail and also to connect to see files and all I have on it. It has worked always, I was able to get in when out of town, till last week and on the...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:42.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App