Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Downloads and Uploads slow

21 Oct 2009   #11
H2SO4

Win7x64
 
 

Quote   Quote: Originally Posted by Madog View Post
Normal downloading, say downloading from rapidshare or fileplanet. Its even like this when im just browsing the internet. I have tried firefox and IE.
Have you installed any "network optimisers" or anything which claims to "Increase Your Internet Speeds and Improve Your Multimedia Experience"?

Have you perhaps changed any of the default IP or TCP configuration?

If not, I'd suggest you uninstall (disabling is not a valid test) all anti-virus and 3rd-party firewall utilities, reboot, and then test again.


My System SpecsSystem Spec
.
21 Oct 2009   #12
Madog

Windows 7 64-Bit
 
 

No, i have not installed any network optimizers. Un-installed NOD32 and the problem was still there.
This was even happening right after a fresh install of Window 7, even before i installed any drivers.
My System SpecsSystem Spec
21 Oct 2009   #13
H2SO4

Win7x64
 
 

Quote   Quote: Originally Posted by Madog View Post
No, i have not installed any network optimizers. Un-installed NOD32 and the problem was still there.
This was even happening right after a fresh install of Window 7, even before i installed any drivers.
Obviously, if you're experiencing unequivocally different throughput from two machines on the same network, there is indeed something different about the one with the problem.

If updating the NIC driver hasn't helped, and you're quite sure it happens on a "vanilla" install, you might want to test what happens with an entirely different make and model of NIC.
My System SpecsSystem Spec
.

21 Oct 2009   #14
Madog

Windows 7 64-Bit
 
 

Okay, i will try to get my hands on another NIC. The one I'm using is built into my mobo.

But the thing i don't get is that it worked fine until a couple of days ago. Would damage to the CAT5 cause anything like this?
My System SpecsSystem Spec
21 Oct 2009   #15
Tews

64-bit Windows 8.1 Pro
 
 

Another thing you may want to try is go to msconfig/startup and disable all.. reboot.. if speeds increase, then start enabling each entry one at a time .. test... until your speed drops out ... I know this takes time, but I had the exact problem and found that it was an anti virus that was giving me fits... as soon as I removed it from the startup entries my speed returned to normal... Good Luck...
My System SpecsSystem Spec
21 Oct 2009   #16
H2SO4

Win7x64
 
 

Quote   Quote: Originally Posted by Madog View Post
Okay, i will try to get my hands on another NIC. The one I'm using is built into my mobo.

But the thing i don't get is that it worked fine until a couple of days ago. Would damage to the CAT5 cause anything like this?
Unlikely. The cable pairs used for the Rx and Tx circuits are highly unsophisticated bits of copper wire. Cable "damage" tends to manifest itself as outright lack of connectivity, although you could in theory get weird 'n' wonderful effects from using an under-specced cable (cat3 on a gigabit network... that sort of thing).

If it is a hardware-layer thing, its more likely that the NIC itself or the router/switch port into which that machine is plugged in has somehow developed a fault. You may want to try moving it to a different switch port - perhaps the one currently used by the "good" machine - if you haven't tried that already.

My gut feeling is that you've got yourself a software issue, but it's best to keep an open mind.
My System SpecsSystem Spec
21 Oct 2009   #17
Madog

Windows 7 64-Bit
 
 

The only thing in the startup is NOD32, O&O Defrag, Java Environment and CTxfiHlp(i think it has something to do with my sound card, but idk for sure, lol).

I don't think it is the NIC on the mobo bc i RMA'd the mobo about a week ago because the chipset fried itself. So if the NIC was faulty then it would have been fixed aswell when they fixed the chipset. Just saying...

Would getting this help? CLICK HERE

I have tried all the ports and nothing changed.

btw, Thank You for all the help so far. I appreciate it ^_^
My System SpecsSystem Spec
Reply

 Downloads and Uploads slow




Thread Tools




Similar help and support threads
Thread Forum
Downloads/Uploads speeds - what do they mean please?
I just did a test on Speedtest.net by Ookla - The Global Broadband Speed Test My results were .... Download 14.68Mbps and Upload 0.95Mbps Could someone please explain to know-nothimg me if that is good, bad or average please
Performance & Maintenance
My computer constantly uploads and downloads.
Hello to all, my laptop constantly uploads and downloads. It has uploaded 21mb in past 24 hrs and downloaded 43mb in past 24 hrs. I Have run Malwarebytes anti-malware(free), Iobit malware fighter(free), Kaspersky tdss rootkit removing tool and Norton & Norton power eraser, All clear, computer still...
General Discussion
Long delay from downloads/uploads
Hi to all, Regulars here will probably have seen this problem before, but I read through the first several pages and didn't see it addressed there. I just got a Win7 computer (Toshiba portege r700-s1310) and when I try to download a file or upload anything, either, I get a 30 second (or so)...
Network & Sharing
Downloads/Uploads stop repeatedly
I'm running Windows 7 Home Premium on a Dell Studio XPS 1645 laptop. Recently, I have had downloads and uploads fail and I am wondering whether this is likely a Windows setting, or possibly a hardware problem. I first experienced this two days ago when I was trying to upload a 626MB file via...
Network & Sharing
very slow ftp uploads when they work
Hi all. I've looked at other ftp posts on here and this problem doesn't seem to have been found by anyone else. I'm on a new system with windows 7 home and my ftp uploads are stupidly slow when they work and half the time they don't work. I've tried using filezilla, core ftp, the command...
Network & Sharing
Usage Meter For Uploads And Downloads ?
Hello, Just got a surprise call from Comcast telling me that I am running around 900 GB/month of uploads & Downloads. Their limit for home usage is 250. Guess there's no real surprise, as my kid just loves downloading movies, music, MP3, etc all night. Also, I guess he's obligated to...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:42.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App