Problem with the driver for Wireless Adapter

  1. Posts : 2
    Windows 7 Pro x64

    Problem with the driver for Wireless Adapter

    My problem is 2fold:
    1. I recently moved to a new city. Prior to moving my desktop wireless nic(Realtek 8190 802.11N) was operating flawlessly in the N spectrum. I unplugged the PC, boxed it, shipped it to new address, unboxed it, plugged it in(once the new cable/internet connection was installed in the new apartment(different company)). The PC is just 10 feet away from the Wifi router, a ASUS RT-N66U, and I'm only getting 72Mbs speeds. This is completely inadequate to game online as all my games either can't authenticate due to timeouts or timeout immediately after authenticating. My laptop is getting 144Mbs at any location in the apartment. I have gone through all settings and don't see why it's so slow as it was working just fine.

    2. Because I have not been able to fix my original Wifi nic, I bought a TP-WDN4800 450Mbs nic and installed it.
    I loaded the driver for this nic, the system recognizes the card, however, using this nic the system does not see any networks. The driver is the most current, however windows is reporting there is a problem with the driver even though the system recognizes the card and the card itself is indicating successful driver install with a slow flashing LED as per the manual.

    Please help...
    Attached Thumbnails Attached Thumbnails Problem with the driver for Wireless Adapter-realtek.jpg   Problem with the driver for Wireless Adapter-realtek-driver.jpg   Problem with the driver for Wireless Adapter-tplink.jpg   Problem with the driver for Wireless Adapter-tplink-driver.jpg  
      My Computer

  2. Posts : 196
    Windows 7 Professional / Windows 8 Pro

    have you contacted your ISP asking them to test the line?
      My Computer

  3. Posts : 8,870
    Windows 7 Ult, Windows 8.1 Pro,

    Hello Lank, it's required to update the firmware to the latest version on the Asus AC66U to fix compatibility problems with many different wireless devices. Just go into the routers settings, click Administrator tab then the firmware tab at the top, install latest firmware from the link below. :)

    ASUSTeK Computer Inc. -Support- Drivers and Download RT-AC66U
      My Computer

  4. Posts : 2
    Windows 7 Pro x64
    Thread Starter

    PARTIAL SOLUTION: I attempted to update the router firmware with no change in symptoms. I finally solved this issue by deleting the driver and software utility that came with the TP-Link card on CD and installing both driver and software utility downloaded from TP-Link website. I also had to stop Windows from overwriting the driver. This still doesn't answer the question as to why my original card is still only connecting at 72Mbs.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:01.
Find Us