Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: W7 to NAS access hangs unpredictably

27 Sep 2013   #1
CDatGNP

Windows 7 Professional 64bit
 
 
W7 to NAS access hangs unpredictably

About six months ago, we bought a D-Link DNS-320 ShareCentre, installed two 1TB Seagate HDs, and began using it for our fileshare. Access and speed was OK, but not great.

Since about two weeks ago, our access to the fileshare has been intermittently very slow. Files (any size, 1 KB up to megabytes) load after a long hang-time, or don't load at all. The delay is far, far beyond the difference between 10/100/1000 bps connections. Navigating between folders, saving, moving, copying, and deleting files also have this intermittent hanging.

Our network:
[#] description
[1] TP-Link TL-WR841N, operating LAN only
[2] D-Link DNS-320, firmware v 2.03
[3] computer running Windows 7 Professional 64bit, on-board Ethernet connected to router
[4] computer running Windows XP

Trials with network configurations:
A) [1] connecting [2], [3], and [4]: both [3] and [4] experience problems connecting to [2]
B) [1] connecting [2] and [3] only ([4] disconnected): [3] still experiences problems
C) [1] connecting [2] and [4] only ([3] disconnected): no problems
D) [2] directly connected to [3] via Ethernet: [3] still experiences problems
E) [2] directly connected to [4] via Ethernet: no problems

Further trials with configuration (A):
i) Configuration (A) above, booting [3] in Windows XP (from separate HD): no problems
ii) Configuration (A), booting [3] in Windows 7 Safe Mode with Networking: no problems

More trials:
- I'm running Comodo Firewall on [3]. The problem persists when I disable it.
- Both [1] and [2] were on old (2010) firmware, and are now running on up-to-date firmware from the respective manufacturers.
- Ran Malwarebytes scan on my computer, nothing found.
- Ran SpyBot and let it have its way with all the things it found. Still have problems.
- Booting and NOT running MS Outlook just now, no problems...
- Opened MS Outlook, problems start.
- Closed MS Outlook... problems persist... end the Outlook task in task manager, no problems... could this be it?

It's hard to say "no problems" definitively, because the problem itself is intermittent. This is headaches.

Do you have any ideas? Potential root causes, or next-steps in troubleshooting? I'm loathe to format and reinstall my programs, but it might have to come to that.

Thank you for taking the time to read my plea.


My System SpecsSystem Spec
.
28 Sep 2013   #2
ascomputers

Windows 7 Professional / Windows 8 Pro
 
 

you tried changing over the ethernet cable?

I had an issue with my nas drive and it turned out to be a faulty ethernet cable?

worth a try...

also what router you using please?
My System SpecsSystem Spec
03 Oct 2013   #3
CDatGNP

Windows 7 Professional 64bit
 
 

ascomputers, thanks for the tip. The problem persists when I swap out the ethernet cable.
The router is a TP-Link TL-WR841N.
My System SpecsSystem Spec
.

03 Oct 2013   #4
CDatGNP

Windows 7 Professional 64bit
 
 

It seems like Outlook is correlated to the problem. When either of OUTLOOK.EXE *32 or WINWORD.EXE *32 were running, problems. When neither of those processes were running, no problems.

I've moved a copy of all my .pst archive files to my local disk. So far, so good...
My System SpecsSystem Spec
Reply

 W7 to NAS access hangs unpredictably




Thread Tools




Similar help and support threads
Thread Forum
Can't access wireless adapter (shows disabled) but can access internet
This just started this morning. My wireless icon keeps having the loading circle, which changes to an x when I click it. I am unable to load my network options, also. But internet connects fine and I am able to surf (and come here, begging for help). Also, other devices like my tablet and phone...
Network & Sharing
Asus Laptop keeps getting random limited access. No internet Access
When I am on my computer at random times my asus laptop would drop my internet. I am using a wireless connection and my connection is not bad. Just wondering if there is a quick fix to this. I am not the most knowledgeable computer guy but I could follow directions if you guys need addition info of...
Network & Sharing
Dial Up ICS Error:Access Type No Internet Access With Yellow Triangle
Hi, i am a newbie when it comes to Windows networking particularly Internet Connection Sharing (ICS). A week ago i turned my Win 7 HP Laptop into wireless router which is on EVDO 3G dial up using the windows (ICS) to connect my second Win 7 Dell laptop which was successful. Unfortunately, i...
Network & Sharing
FireFOX 3.5.5 hangs also IE8 hangs
i really didnt know where to put this software debugging or what.. So i put it here ima sorry guys if this is the wrong spot. On my AMD turion II m500 laptop my IE8 and Firefox both hang constantly Same ie8 build and firefox build as well as win7 build on my desktop and laptop. But my desktop is...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:23.
Twitter Facebook Google+