Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: OT - Problem connection a NAS device to my home LAN

20 Oct 2013   #1

Windows 7 x64 Pro
OT - Problem connection a NAS device to my home LAN

This isn't exactly a Windows7 problem, but I don't know where else to ask it.

I've purchased a small (single 2TB) network assessable storage unit - a Western Digital MyBookLive. I'm having trouble connecting the MBL device to the LAN. My LAN config is consists of an Actiontec GT701-WG router/DSL modem/ WiFi access point, a LinkSys 5-port ethernet switch, a Win7 desktop PC ethernet-connected to the router through the switch, a wireless-connected XP desktop PC, and a wireless-connected Vista laptop.

The NAS device supports UPnP so I can connect it directly to the router or any of 3 computers on the LAN - a Win7 desktop, a Vista laptop, and an XP desktop. The device is visible (but not necessarily usable) in each of thse cases. However, if I connect the NAS device to the switch nothing sees it. I've tried multiple ports on the switch (including ports that work for the PC) and multiple ethernet cables. Nothing works.

The NAS device supports 10M/100M/GB ethernet. The router and switch switch support 10/100MB (although the router reports it has a 10MB connection to my PC so maybe one of these devices doesn't actually support 100MB). When directly connected a PC or laptop the NAS device's ethernet status LED is green. When directly connected to the router it shows yellow. (I may have those colors reversed.) When connected to the switch the status LED is off. I suspect the color is an indication of the connection speed, and no speed has been determined when it is plugged into the switch.

This looks like a switch problem but I'm reluctant to blindly get a replacement since it seem to work fine with my PC (except maybe for the speed). Any suggestions for a solution or for further debugging?

Since originally posting this I bypassed the switch and directly connected my PC to the router. The router now reports a 100MB connection with the PC. But this doesn't explain why the NAS device cannot talk through the switch to the router - just why it might talk slowly. So I'm still at a loss.

My System SpecsSystem Spec
20 Oct 2013   #2

Windows 7 x64 Pro

Never mind. Bad ethernet switch. I got a new one and all is fixed.
My System SpecsSystem Spec

 OT - Problem connection a NAS device to my home LAN

Thread Tools

Similar help and support threads
Thread Forum
Wind 7 Home Pre 64 bit Internet Connection Problem
I have a friend that bought a new computer less than a year ago and the internet was working perfectly. One day the internet stopped. It says it can connect to her home network but not the internet. I brought to work to see if it was her home access or the computer. Here at our office. It gets a...
Network & Sharing
Home wireless network connection problem
Hi guys, If you have time to help me solve this problem I would really appreciate it. First off, I have a Samsung NP350V4C notebook with an Atheros AR9485WB-EG Wireless Network Adapter (currently up-to-date), the system I'm running on is a Windows 7 Ultimate x64, and my router is a TP-Link...
Network & Sharing
XP Home SP3 "Unknown Device" Problem
Installed VHS to DVD software with a Diamond VC600 Converter. Uninstalled with Revo. Installed driver only and another program. Uninstalled both again with Revo. I can't get rid of the device. Tried to delete, uninstall, update driver, etc. Even deleted the hub, then the USB controller to...
Chillout Room
Home Network Connection Problem.
Hi, I'm new to Windows 7 and just installed in on my PC this morning. When I first installed it I kept getting an "unidentified Public Network" as my only network. I am connected through a hardline that goes to a router that is connected to DSL. If I restart the computer SOMETIMES the Unidentified...
Network & Sharing
Local Device Name Problem, Looses connection to Shared.
Running Win 7 Professional 64-bit and trying to connect to a shared RAID-5 array on my HomeServer (running Vista Ultimate 64-bit) over my LAN. On start up, my HomeServer shows up as part of the network and it allows me to connect to it. I can access the shared drive just as before and log into my...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:21.
Twitter Facebook Google+