Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No Local Access only Internet

23 Oct 2009   #1
skullking123

Windows 7 RC and Windows Vista Home Premium 64-Bit
 
 
No Local Access only Internet

Okay I have spent countless hours on this problem and I am about to give up.

I do not have any Local Network Access only Internet. If you don't know what I mean when you go into Network and Sharing under Access type it only says Internet. This problem exists on my desktop that runs a paid version of Win 7 Home Premium 64-bit and on the Win 7 Ultimate RTM 32-bit. What I can't seem to understand is that on the RC this problem never existed. Also when I log onto Vista Home Premium 64-bit i get both Local and Internet.

I have read countless threads on problems that similar to this. I can't access Homegroups and I believe that not having a Local Access is the problem.

I have seen threads with this problem but not sure if anyone found a solution. Please help I really did enjoy the Homegroup in RC.


My System SpecsSystem Spec
.
23 Oct 2009   #2
torrentg

7600.20510 x86
 
 

Make sure that Apple's Bonjour service is not on your machine and running. You can look in task manager for something called mdnsresponder.exe to tell you it is.

Or look for this service at the top when you run services.msc.

##Id_String2.6844F930_1628_4223_B5CC_5BB94B879762##

Make sure IPv6 is enabled. The "internet" for access type is normal and well.

Post a screenshot of command prompt when you type ipconfig /all and hit enter if you require further diagnosis.
Also post one of the net view command.
My System SpecsSystem Spec
23 Oct 2009   #3
skullking123

Windows 7 RC and Windows Vista Home Premium 64-Bit
 
 

So you wanted me to disable it like so. Ok, but still no local access


Attached Thumbnails
No Local Access only Internet-capture.png  
My System SpecsSystem Spec
.

23 Oct 2009   #4
torrentg

7600.20510 x86
 
 

Disabling it should be good enough but I simply hate having it on my system

Here's the easy way to get rid of it with least chance of harming your networking stack.

Download a free trial copy of Dameware NT utilities. Install.

Welcome to DameWare Development. Home of the DameWare NT Utilities & Mini Remote Control remote systems management software for Windows. Now Featuring Smart Card Login & Authentication

Run C:\Program Files\DameWare Development\DameWare NT Utilities\DNTU.exe

Right click favorite machines and choose add if you don't see yours. Type your computer's name and hit enter. It will show up.

So double click on it now. Double click services. Then double click remove service.

Hit next. Check the box for include device drivers. Remove Bonjour service. If there's this at the top, do the same for it too. ##Id_String2.6844F930_1628_4223_B5CC_5BB94B879762##

Reboot. Delete C:\Program Files\Bonjour folder.

Good luck. You've have found your problem!

If for some reason you still are not having success doing whatever it is you're trying to do, run ipconfig /flushdns from an elevated command prompt. Check other machines on your network for Bonour too.
My System SpecsSystem Spec
23 Oct 2009   #5
skullking123

Windows 7 RC and Windows Vista Home Premium 64-Bit
 
 

Okay when I hit next after entering machine name, i get a box that says to enter UserId and Password. What UserId and Password would this be since I have tried various combinations and I keep getting error codes
My System SpecsSystem Spec
23 Oct 2009   #6
torrentg

7600.20510 x86
 
 

Instead of machine name, use 127.0.0.1

It's unusual for it to ask for user/pass on a local machine. Perhaps it's just some config difference between how I run and you do.

Use the current user/pass that you are logged into Windows with if it asks.

Run Dameware with admin privilege if you are not.
My System SpecsSystem Spec
23 Oct 2009   #7
skullking123

Windows 7 RC and Windows Vista Home Premium 64-Bit
 
 

I am getting

Failed to connect to selected Machine
System error: 5
System message:
Access is denied
My System SpecsSystem Spec
23 Oct 2009   #8
torrentg

7600.20510 x86
 
 

Alright. Forget Dameware then.

Open an elevated command prompt. Copy and paste this, hit enter:

"%PROGRAMFILES%\Bonjour\mDNSResponder.exe" -remove

When that is done, copy and paste this line, hit enter.

regsvr32 /u "%PROGRAMFILES%\Bonjour\mdnsNSP.dll"

Reboot. Delete C:\Program Files\Bonjour
My System SpecsSystem Spec
24 Oct 2009   #9
skullking123

Windows 7 RC and Windows Vista Home Premium 64-Bit
 
 

okay removed bonjour and flushed dns.

But still I am only getting Internet access.

Didn't really understand why Bonjour would've caused this problem since I had Bonjour on RC and have it on Vista and it works perfectly fine.
My System SpecsSystem Spec
24 Oct 2009   #10
skullking123

Windows 7 RC and Windows Vista Home Premium 64-Bit
 
 

well i got the homegroup to work finally. What I did is that I went to my network on the laptop and established a connection with the desktop manually. Then after entering User Name and Password the laptop finally recognized the Homegroup.

Though it still says that I do not have Local Access my goal has been achieved.
My System SpecsSystem Spec
Reply

 No Local Access only Internet




Thread Tools




Similar help and support threads
Thread Forum
Cannot get internet access on wireless nor local area, "unidentified"
I just moved to Peru for my study abroad. When I first connected to the wi-fi in my homestay I was successful. Suddenly, I cannot get internet access and it says it is an "unidentified network". I have tried manually inputting IP addresses, DNS, etc. I have tried forgetting the network and...
General Discussion
local area connection unidentified network no internet access Xbox
Hey i am having problems connecting to Xbox live because it has no internet access and i have tried lots of things and nothing is working. here is the story behind it.... i had tried connecting many times before but it wouldn't work but one day i tried and i changed sharing on something (IDK what i...
Network & Sharing
Internet Access = Can't browse / No Internet Access = Nice Browsing ??
When my computer says Internet Access, I am having trouble browsing. Most pages do not load. Right now, It says no internet access for over 15 minutes and I am able to brose so much better and still going on downloading around 400 kb/s. How can this be? Why would it be? (I am on a wired...
Network & Sharing
internet access but no local
I have 2 computers both running windows 7 ... both have internet access through a dlink dir-615 wirelessly ... Niether of them is showing local access and no matter what i try running diagnostics etc i cannot see or access the other computer .... when i ping the other computer ... I get ...
Network & Sharing
No Local Network Access
I havent been able to get Network access working, The internet work fine. In the Network Status window it lists my access type as Internet and not Local and Internet like i think it should. Any ideas?
Network & Sharing
Only Local access No Internet
Hello, i have searched the forums for solution . I have Lenovo T400 with Intel 5300AGN adapter and DLink DIR 655 wireless router. I was running Win Vista Business 64 bit. I upgraded to Win7 ultimate, I can connect to The router and access my local network NAS drives BUT cannot connect to...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:02.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App