Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cannot Add Service to Network Adapter

03 Dec 2013   #1
MTS52

Windows 7 Home Premium 32bit
 
 
Cannot Add Service to Network Adapter

I am using Windows 7 Home Premium 32bit.

I am trying to add a service to my primary broadband modem's Network adapter.
Right click connection then select properties.

When I select Install then select Service then press ADD the resulting dialogue box is empty.
The same thing happens if I select Client or Protocol. There a no entries to choose from. Weird!
I tried going to Control Panel Programs and Features to check if I could turn Windows Features on or off but there is nothing there to do with Networking. From memory in XP there was but that seems to have changed in Windows 7.

If anyone has a clue why this box is empty I would really appreciate it.

Google search for "add service to network adapter" returns millions of results, all of which are not vaguely relevant to my problem. There are results for actually adding the said service but they all presume the resulting dialogue box is not empty.

Thanks for any replies.


My System SpecsSystem Spec
.
04 Dec 2013   #2
carwiz

Windows 7 Pro-x64
 
 

How many services (filters) are listed now? Windows has default maximum of eight with a hard limit of 14. If all of them are required, you would need to mod the Registry.


Attached Thumbnails
Cannot Add Service to Network Adapter-network-filters-2.jpg  
My System SpecsSystem Spec
04 Dec 2013   #3
MTS52

Windows 7 Home Premium 32bit
 
 

Hi Wiz,

Thanks for the tip. I changed the registry as you suggested but that didn't make any difference.
This has me totally stumped. I have done a lot of google searches but nothing is helping at all.

Thanks for your reply.
My System SpecsSystem Spec
.

04 Dec 2013   #4
carwiz

Windows 7 Pro-x64
 
 

Did you reboot after changing the Registry?
My System SpecsSystem Spec
04 Dec 2013   #5
MTS52

Windows 7 Home Premium 32bit
 
 

Yes I have rebooted since the registry change and the problem still remains.
My System SpecsSystem Spec
04 Dec 2013   #6
carwiz

Windows 7 Pro-x64
 
 

Can you post a snip of Hardware Manager with the adaptor(s) expanded. Also one of your filters screen for each adaptor.
My System SpecsSystem Spec
04 Dec 2013   #7
MTS52

Windows 7 Home Premium 32bit
 
 

Hi Wiz,

I hope this is what you asked for.

Presuming Hardware Manager meant Device Manager.


Attached Images
Cannot Add Service to Network Adapter-device-manager.png Cannot Add Service to Network Adapter-ethernet.png Cannot Add Service to Network Adapter-mobile-broadband.png Cannot Add Service to Network Adapter-vpn-adapter.png 
My System SpecsSystem Spec
04 Dec 2013   #8
carwiz

Windows 7 Pro-x64
 
 

Ok, just to verify. What did you enter as the value for MaxNumFilters? If you just clicked on "Modify" and entered 14, you set the limit at 20 and I think Windows will ignore it and assume 8. The data is hex. If you want 14, ender "e" or change to decimal and enter 14.

What service are you trying to add and to what adapter?
My System SpecsSystem Spec
05 Dec 2013   #9
MTS52

Windows 7 Home Premium 32bit
 
 

Hi Wiz,

I just double checked. It is set at Decimal 14 or hex e

I am trying to add OA Helper driver to my mobile broadband adapter. This is my usb 4G Modem.
OA Helper driver is for Online Armor Firewall.
As you can see from the screenshots it is there in the ethernet adapter and also in the VPN connection.

I re-installed Online Armor Firewall with the latest version on the website and it made no difference.

I am just confused as to why it is in the other two adapters but not my mobile broadband one.

Also QoS packet scheduler cannot be added as when i press add there is nothing there to add.
This is the same no matter which adapter I try to install/add anything to. It is just blank. Very Frustrating.

Thanks again for your continued help.
My System SpecsSystem Spec
05 Dec 2013   #10
MTS52

Windows 7 Home Premium 32bit
 
 

Hi Wiz,

Here is another pic which may explain why I am having problems.


Cannot Add Service to Network Adapter-add-network-feature.png


My System SpecsSystem Spec
Reply

 Cannot Add Service to Network Adapter




Thread Tools




Similar help and support threads
Thread Forum
Wifi adapter could not bind IP protocol stack to network adapter
Hello! I registered to forums to get help to solve wireless adapter issue I am having. I have been looking for help in Lenovo forums and AV provider: problem is still on. Background I changed AV software from Symantec to F-Secure. I uninstalled Symantec software and installed F-Secure...
Hardware & Devices
Cannot Add Service to Network Adapter
Hello, I'm using Windows 7 Home Premium 64bit SP1 There is similar question for Windows 7 Home Premium 32bit. posted by MTS52 but suggestions didn't help me :( I need to add manually service since is not automatically installed when I install SW and I can't do it, please see screen shots...
Network & Sharing
AWUS036H adapter can't find specific network but inbuilt adapter can
Hello I have my AWUS036H for a few months now and it worked perfect until now. My landlord has a router in his appartment and I need to connect to that router to get access to the internet. I bought this adapter for a better signal but this week I got a very weird problem. My adapter can find...
Network & Sharing
Problems with wireless network adapter and network connection driver
Hi, So recently I have removed a nasty zeroaccess rootkit virus(es) from my laptop. My Windows Firewall, Defender and Updates would not work (still won't), my browser kept redirecting to unrelated websites, and I was just overall having a TON of irritating issues. I installed MalwareBytes and...
Network & Sharing
Network Adapter Not Shown in Network and Sharing Center
I have windows 7 Ultimate installed (was originally installed as a clean install) and have ever since it was RTM. Everything has been running flawlessly and still is except for one thing. My network cards don't show up under Network and Sharing Center, but they do show normally under device...
Network & Sharing
Network Adapter Not Shown in Network and Sharing Center
I have a linksys usb600n (v2) using the Win7 driver from linksys. It installs and is displayed correctly in Device Manger - BUT it doesn't appear in the Network and Sharing Center as an adapter. This same device and driver were previously working just fine in this system - but I rebuilt the OS...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:44.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App