Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB internet connection works, Ethernet internet connection does not

24 Jan 2014   #11

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

Perhaps I should take another look at what you want to accomplish.

What I think I know:
You want to use Ethernet instead of wireless for faster connections.
Wireless works
Ethernet returns error 651, WAN miniport

Comcast ???? cable modem
Linksys E4200 Wireless router
Linksys WUMC710 (Wireless-ac universal media connector) A replacement for the E4200?
>> Cabled to Dell

Linksys AE2500 USB Network Adapter (Dual Band N)
Intel(R) 82566DM-2 Gigabit Network Connection (NIC adapter download link)

Ok, if I got all of that right, there are some things you should know.

The faster speeds expected from the LinkSys WUMC710 refers to wireless - it is the latest 802.11 protocol (AC). Your Linksys AE2500 USB adapter is 802.11 protocol (N), so you're only going to get N speeds using wireless.

Both routers have 4 ports (Gigabit Ethernet) so there's no improvement on Ethernet.

Before moving forward, let's catch up.
You have the prowin32 exe from the Intel download page, but have not installed it.
>> you have some questions about the way to install it (modify or remove options)
>> which features to install (you show what is on the system now)
--> that was brilliant, there's a record of how it was.
--> could you also post the version of the current Intel Network Connection? Thanks

Britton30 pointed out the OEM disclaimer on the Intel site and suggested getting the driver from Dell.
>> Dell only offers XP and Vista drivers
>> Vista would be closest to Win7
Britton30 also suggested connecting the PC to the E4200.
>> Excellent suggestion
>> I'd like to know if blairk has tried a direct cable to the Comcast cable modem
>> before testing a device that will be replaced.
>> I undestand your thinking Gary - does Ethernet work with the other router?

>> I might be confused which is why there are question marks in Comcast ???? cable modem.
>> I don't think it's the E4200, I just don't know

Everything else should be put on the back burner for the moment.

I want to look up the WAN miniport error - it might be an easy thing to fix, or it might be a lot of trouble. These miniports don't have a driver, they're services.
Installing the Intel NIC driver might fix that, but wait - let me see what I can find.

So, I've painted the questions for you blairk in red.
If you could review my "What I think I know" and point out anything I got wrong, I'd appreciate it.
I also requested another SF diag report in post# 8 - please also do that while I'm researching error 651, WAN miniport

I'm not sure anything I had planned (update the Intel driver) will change, but I'm learning to slow down.

My System SpecsSystem Spec
24 Jan 2014   #12

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

Hmmm, WAN miniport error 651 is related to PPOE. This is odd to see with Comcast, unless you are a DSL subcriber. Are you connecting to Comcast via DSL (over a phone line) or through a coax cable to a wall jack?

Also please post your IP configuration info:

Open an Elevated Command Prompt
Tip   Tip
Standard keyboard shortcuts for Copy (Ctrl-C) and Paste (Ctrl-V) shortcuts do not work in Command Prompt.

Enabling the Quick Edit Mode in Command Prompt makes Copy and Paste operations easier.
See step 4 in Command Prompt - Copy to Clipboard to enable it.

Copy in Command Prompt: hightlight the text you want to copy, then press ENTER.
Paste in Command Prompt: right click with your mouse.

In the command prompt window type
ipconfig /all > c:\IPblairk.txt

Attach the IPout.txt file to a post.

My System SpecsSystem Spec
24 Jan 2014   #13

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

blairk: This post is just a note to myself and will be deleted after I read your answers.
>> You don't have to do anything in this post.

Note to self: raspppoe
My System SpecsSystem Spec

24 Jan 2014   #14

Windows 7 Ultimate x32

you asked:
"could you also post the version of the current Intel Network Connection?" SEE ATTACHED FILE devmgr-fig 4
"Britton30 also suggested connecting the PC to the E4200." NO. it is being used as a wireless router from the Comcast HS Co-Ax digital cable in, signal relayed (wirelessly upstairs) to the WUMC710 (used as a signal amplifier/enhancer) and then the WUMC710 is cabled to the Dell.
"I'd like to know if blairk has tried a direct cable to the Comcast cable modem" NO. the co-ax cable into the house is located downstairs from my work space/pc.
I also tried to collect the command prompt info no luck . see attached cmd-fig3.jpg
also attached (zip) the info you requested from the MGADiag ... I hope it is the info you need.
Thank YOU!!

USB internet connection works, Ethernet internet connection does not-cmd-fig-3.jpg

USB internet connection works, Ethernet internet connection does not-devmgr-fig-4.jpg

My System SpecsSystem Spec
24 Jan 2014   #15

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

Ok, thanks. devmgr-4 doesn't show me the version of the Intel NIC driver.
In devmgr, double click Intel Network Connection, select properties, then driver tab
- that should show the driver version. post a screen shot of the driver tab


Alright, I need a diagram of how you have the network.

Comcast coax goes to what?
from there it goes to the E4200
the WUMC710 is upstairs acting as a repeater
and the Dell connects to the WUMC710 across ethernet

If I got THAT right, then it would be difficult to connect to either the Comcast box or the E4200
Ok, this is going to take longer than I first thought - more pieces.

but it sounds as though it's a simple matter to reconfigure the two wireless devices.

Did the Dell use to talk directly to the E4200 Using the Linksys USB adapter?

About the ipconfig file - look on C:\ for IPblairk.txt
Attach that file to a post.

I'll look at it when I get back - have to run out for a bit.

Thansk blairk
My System SpecsSystem Spec

 USB internet connection works, Ethernet internet connection does not

Thread Tools

Similar help and support threads
Thread Forum
Ethernet connection to internet stops every night between 8pm & 1am
I have a strange problem that has me stumped, over the last month my ethernet connection to the internet drops every night between 8pm and 1pm, it either stops completely or works for a few seconds and then disconnects or I get a connection so slow that it's unusable. Other devices connected...
Network & Sharing
Internet Connection works but web applications are not. Needs help.
Hi there. Let me start by saying that I have a background in computer programming and so I understand most jargon, however I don't have much experience with computer hardware problems and networking, so I may not have tried some very simple things. I believe I've tried everything and I have thus...
Network & Sharing
Bridge internet connection over ethernet from wifi
My desktop is connected to a wifi network and I need to bridge to another via ethernet. I have started by selecting each network and I bridge the 2 connections, creating a bridge, but the other computer still doesn't have internet connection. Is this possible (I would think so) and if so, what...
Network & Sharing
No internet connection but Skype works
Hello, Two days ago my computer gave me a blue screen of death (not the first time). Ever since that restart my internet says I'm connected but nothing can access the internet (Except for skype), the fingerprint sensor also does not work anymore. I thought it may be a hardware issue but...
Browsers & Mail
no ethernet controller, no internet connection
HI, to start off, I have had windows 7 7100 on my computer for a while (internet was working), but then decided to have windows 7 7600 x64 now. But when i installed that and tried to activate it, I just get stuck at the "verifying pool data" screen. So I went and installed windows 7 7600 x32 but...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:36.
Twitter Facebook Google+