Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Ethernet Connection Lost (and Found?)

10 Nov 2009   #61
Chasm

Windows 7 Professional RTM
 
 

So.... previously I had tried disabling and killing my firewall and neither of those had worked. I guess there was some process or service in PC Tools Firewall that was persisting even if I disabled or closed it that was causing my issue. Uninstalled the firewall last night and my connection has remained alive with uTorrent running for 24 hours now.

I'm going to try installing a different firewall instead and see if the issue returns. I'd rather not use the built in firewall if possible.


My System SpecsSystem Spec
.
11 Nov 2009   #62
Shikiouji

Windows 7 32-bit RC, Build 7100
 
 

alright im 100% sure its win7 that's messing up my connection. if i somehow download anything at a high rate, it disconnects. i can't do multiple things that require bandwidth before it disconnects on me.

-i have azureus d/ling at over 500mps..if it peaks at all over 500, it d/c
-i play WoW and "attempt" to watch youtube videos, it d/c
-youtube + d/l anything else, d/c
- i think you get the idea =P

i know its win7 cuz i got myself a brand new router and i still have the same problem. also everyone else in the house are still connected to the internet while im d/c.
My System SpecsSystem Spec
11 Nov 2009   #63
scottyd

Windows 7 x64
 
 

Has anyone tried buying a new network card and throwing that in? I think I might do that if all else fails.
My System SpecsSystem Spec
.

11 Nov 2009   #64
kensiko

Win7 64 bits FR
 
 

I did.

No disconnect since. But you can't base your conclusions on that because I reinstalled Windows, so the software is a little bit different. Also, I saw a post of someone who has bought an Intel Ethernet card and still had the disconnections.
My System SpecsSystem Spec
12 Nov 2009   #65
scottyd

Windows 7 x64
 
 

Quote   Quote: Originally Posted by kensiko View Post
I did.

No disconnect since. But you can't base your conclusions on that because I reinstalled Windows, so the software is a little bit different. Also, I saw a post of someone who has bought an Intel Ethernet card and still had the disconnections.
What type of network card did you get? I was looking at a pci-e rosewell one that says it specifically works with windows 7.
My System SpecsSystem Spec
12 Nov 2009   #66
scifiguy

Windows 7 64bit
 
 

Did you try turning off the task offload as I described in my post? I'm curious if that works for others.
My System SpecsSystem Spec
12 Nov 2009   #67
davefr

 
 

Quote   Quote: Originally Posted by scottyd View Post
Has anyone tried buying a new network card and throwing that in? I think I might do that if all else fails.
Yes, and it made absolutely no difference. The NIC I bought was a D-Link model listed on MS's W7 compatability list.

My solution was changing routers. I still believe W7 has problems with ethernet/internet protocol with certain combinations of NIC's, routers, and ISP H/W.
My System SpecsSystem Spec
12 Nov 2009   #68
scottyd

Windows 7 x64
 
 

Quote   Quote: Originally Posted by scifiguy View Post
Did you try turning off the task offload as I described in my post? I'm curious if that works for others.
I don't even have a "task offload" option on my Marvell nic.
My System SpecsSystem Spec
13 Nov 2009   #69
Phasma

win 7
 
 

Mother board= GA-ex58-ud5
CPU=i7 940
Clean install with x64 bit

Problem & Solution
On most gigabyte boards the ethernet or network hardware is a Realteck RTL-8168d/8111d Family PCI ethernet NIC (NDIS 6.0). Well at least on my board it is. Once i updated win 7 using the update function i started to experience connectivity issues. Random drops with internet connection. It seems that when i did have it it would drop when i would really hammer on my up and downloads. ie internet, games, whatever.
Well i read alot of forums. Some say its the network adapter driver. Others say its a route file that makes Windows 7 loop to dead dns entries or such( forgive me i am not an expert in such technical issues).
But here it what i have found.
Windows 7 has ethernet drivers that it will install when you upgrade or clean install. SO it replaces your old working drivers. And since its still pretty new i figure companies have not worked out the bugs to the possible compatibility issues. WE all know they will but till then its frustrating with a constant lost internet connection.


Solution.
Go to control panel
Hardware and sound option (category view) System in Icon view.
Device manager.
then look up Network adapters.
Find the primary network adapter.
Right click properties.
Then update driver.
You should see the version number.
Install a version that is before this one that is currently installed.
IF you can find one on the net wonderful. I however used my old MOtherboard instalation CD.
I chose Have own disk . Browse. explore the cd ( open it up to find the exact folder with the drivers on there.)
Just update and your good.
Just restart and your good to go.
I have had no problems since then. Best to stick with a working driver than a new and improved one....
also make sure you dont have WIndows updates undo your handy work.

This is the simplist way and easiest way i could think of.
Btw i have reinstalled the drivers, clean system, Removed anti virus software, closed firewall etc.
Nothing worked but this did. Give it a spin and let me know.

My System SpecsSystem Spec
13 Nov 2009   #70
Xello

Windows 7 HP x64
 
 

I noticed a new Realtek driver was released in the past few weeks so i've installed that, if it doesn't do the trick i'll try installing a really old one from an old installation CD.
My System SpecsSystem Spec
Reply

 Ethernet Connection Lost (and Found?)




Thread Tools




Similar help and support threads
Thread Forum
Driver not found for unknown 'ethernet controller' in device manager.
My system speccy's should be in my profile bit, please let me know if you need more information. Thanks :)
Drivers
Lost Pwr During Defrag - FOUND folder not found
Last night was using Auslogics to defrag an external WD 1.5TB BU drive... 2 hours in we had a power loss...lights and TV went out and came back on. The laptop that was running the Auslogics had a batt, but the external drive lost power in the middle of the defrag process. Turned everything off for...
Performance & Maintenance
Ethernet controller driver on my Windows 7 Cyber Power pc not found.
After restoring my computer to its original state, my computer could not get on the internet. I looked at my devices and it said that my computer's Ethernet Controller, SM Bus Controller, Universal Serial Bus (USB) Controller, and Universal Serial Bus (USB) Controller, all of them, there drivers...
Drivers
Ethernet Driver Lost
Hi, Complicated story but after trying to install Windows 7 I couldn't get it to work so the only other disk I had was Windows XP Home. Installation went smoothly. Only thing is, I can't connect to the internet or my network because the ethernet driver was not regonized. A link to a site where you...
Drivers
Wireless network connection lost internet connection
Hi everyone, I work in an office where we have a main desktop computer which is connected to the internet via a Time Warner modem. The modem is connected by cable to a netgear wireless router, and up until today there have been no problems connecting to the internet from the laptops that use the...
Network & Sharing
Ethernet connection lost after standby
Hey all, I have Windows 7 RTM Pro x64 on my laptop, and have for the past couple of months now (before that it was beta/RC). I haven't been having any severe issues until recently. Since it is a laptop, and i carry it to 3-4 classes a day (using wifi), i almost always put it in standby....
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:21.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App