Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Ethernet Connection Lost (and Found?)

26 Oct 2009   #1

Windows 7 Ultimate x64
Ethernet Connection Lost (and Found?)

Let me start by saying that although I am new here to SevenForums, I have been a Windows 7 tester since the "pre-beta" bits were distributed at last year's PDC, and have been an active early adopter since the RTM versions were made available on MSDN earlier this summer.

Up until about a week ago, I had honestly not been experiencing any real headaches with the new OS as I upgraded 2 different 32-bit Vista machines and performed a clean install on my x64 machine at work without any issues whatsoever. However, my honeymoon with the Windows 7 upgrade experience ended when I performed an upgrade install to my x64 Vista machine about two weeks ago. The upgrade process went smoothly enough despite the large number of existing applications that were present on that PC; it took awhile to complete (~2 hrs), but everything seemed to be working fine afterwards...

...until I started noticing an annoying tendency for my network connection to drop whenever I was attempting to access music files stored on my home server, with sporadic drops also observed in Outlook and while browsing the web.

That is what eventually led me here, where I found a fairly lengthy thread on a topic entitled "Ethernet Connection Drop." I found a lot of good information and plenty of sage networking advice in this thread, but it also occurred to me that there seemed to be a very wide variety of users with different configuration scenarios that seemed to be experiencing a similarly broad variety of problems with their LAN/Internet connections. Folks are reporting problems and proposing solutions for everything from ISP's, routers and modems, network adapters and settings, and everything in between.

The general trends I observed on that thread were that this dropped connection problem could happen with practically any type of NIC, but seemed to occur more frequently for folks that have performed an upgrade install on a 64-bit Vista machine. Obviously there are just too many variables in play for there to be any sort of one-size-fits-all solution, and that thread has now grown so large that finding those useful nuggets of information that do exist there takes quite a bit of effort, can be easy to miss, and may not apply to your specific system configuration.

So, with a little nudge from Tews, I proposed that maybe a new thread was needed where users are encouraged to include some of the details of their particular systems and problems in the attempt make it a bit easier for folks with similar configurations to find information that might be more pertinent to them.

In the interest of building such a cross-reference, I am asking that posters please include at least the following information when discussing either their problems or suggested solutions to the dropped connection issues that seem to be occurring on many Windows 7 PC's.
  • Motherboard type and/or NIC chipset(s) having the problem
  • Wired or Wireless (or both)?
  • CPU Architecture (x86 or x64)
  • Upgrade or Clean install?
  • Driver details (i.e. manufacturer and version of driver experiencing connectivity issues)
  • Problem description (LAN? Internet? Frequency?)
  • Solutions or Suggestions
Let me demonstrate by using the specifics for the issues I encountered.
  • Motherboard/NIC: MSI P6N Diamond - nForce 680i SLI chipset
  • Wired or Wireless: dual wired gigabit connections (both fail)
  • CPU Architecture: x64
  • Upgrade or Clean Install: Upgrade from Vista x64 Ultimate to Win7 x64 Ultimate (MSDN RTM version)
  • Driver details: Microsoft default driver for nForce ethernet adapter
  • Problem description: Frequent loss of LAN connection when streaming media from home server (every 30 secs to 2 mins), sporadic drops also observed with email client and while browsing. Drops were isolated to this particular machine and did not interrupt connections on other PCs sharing the network (ruled out router and broadband modem).
  • Solutions or Suggestions: Downloaded and installed the latest nForce 680i SLI ethernet drivers for Win7 x64 (version 73.14, released Oct. 6, 2009) directly from nVidia support site. I did not install anything from the driver package other than the ethernet driver, rebooted and have not observed any connection drops in nearly a week. More details here.
Obviously your mileage may vary.

This is not meant to hijack the other thread, but if posters and respondents can try to provide/maintain some type of link to the specific configurations being discussed, maybe it will make it easier for those with similar systems to search this thread for related content.

Here is a blank template to assist you with formatting your replies:
  • Motherboard/NIC:
  • Wired or Wireless:
  • CPU Architecture:
  • Upgrade or Clean Install:
  • Driver details:
  • Problem description:
  • Solutions or Suggestions:
Hope this helps.

My System SpecsSystem Spec
26 Oct 2009   #2

64-bit Windows 8.1 Pro

This should be a sticky ... Lets see what happens!!
My System SpecsSystem Spec
26 Oct 2009   #3

Windows 7 Home Premium Retail

  • Motherboard/NIC: Asus P5Q Deluxe - Intel P45 Chipset - Marvell Yukon 88E8056 onboard NIC.
  • CPU Architecture: x64 (Core2Duo E8600)
  • Upgrade or Clean Install: Clean install (Windows 7 Home Premium x64)
  • Driver details: Marvell Yukon Windows 7 x64 driver from Marvell website (v11.22.3.3)
  • Problem description: Random dropping of LAN connection (yellow exclamation in task bar). Sometimes just once a day, sometimes many times. Multiple reboots sometimes needed to bring adapter back to life, troubleshooting option doesn't help. Can happen with light traffic from web browsings. Heavy traffic doesn't appear to trigger the problem.
  • Solutions or Suggestions: I've tried disabling power saver settings, disable IPv6 and QoS. I've just noticed that Microsoft are pushing out a slightly older version of the driver for my NIC as of typing this so I've just installed it, fingers crossed. :)
Update 1: Ok, since installing the latest driver offered over windows update, I've had another solid night without a LAN drop.... Will keep this updated!

Update 2: I've just lost connection to the LAN but think I've worked out what is happening (at least for me). It appears, when my router loses sync and I briefly lose my internet connection, the network card was disabling itself. Since I've installed the driver that was offered by windows update the other day, I see the yellow exclamation briefly whilst my router is resyncing but as soon as the connection is back the yellow mark goes and the adapter is back to life again and browsing resumes. Will keep updating as I discover more!

Update 3: Ok, deep disappointment! I was raiding in world of warcraft tonight and all of a sudden I get disconnected, normal yellow icon. Check with another machine that I was still connected to the internet and I was. Did the normal windows restart, the machine rebooted and the card was STILL disabled. This time did a shutdown, waited for the machine to completely power off, powered back on and the card came back this time. What a disappointment, I thought I was getting somewhere.... Funnily someone in the raid asked me if it was this specific problem that I was having and told me he'd had it and fixed it in RC1 and the final release with this command for his nforce onboard NIC. "netsh interface tcp set global rss=disabled". Needless to say it is my next option...

Update 4: As you can see below, Recieve-Side Scaling State is enabled.... not for long :).

C:\Windows\system32>netsh interface tcp show global
Querying active state...

TCP Global Parameters
Receive-Side Scaling State : enabled
Chimney Offload State : automatic
NetDMA State : enabled
Direct Cache Acess (DCA) : disabled
Receive Window Auto-Tuning Level : normal
Add-On Congestion Control Provider : none
ECN Capability : disabled
RFC 1323 Timestamps : disabled


Update 5: I'm really just starting to get sick of this problem now. A full day and half with no problems, gaming, large file transfers, all seems solid. Then just now, all of a sudden no network, 3 reboots later still no network. Reboot router, another PC reboot and this time it hung trying to initialise the network card, had to do a hard reset and this time the network card springs into life as if nothing happened....
At this point I've ran out of ideas and am considering a step back to XP.

Update 6: Just after writing Update 5, I lost connection AGAIN! I've had another play and if I power cycle the router with the PC in this state, the network adapter appears to spring back to life again?! The strange thing is, other machines on the network are still working and able to access to internet before I power cycle the router.... *pulls our hair*

Update 7: PROBLEM SOLVED! Ok, I'm convinced that it was other factors that tied in with this but I decided to take a look inside my router as I'd read something in a forum about Netgear DG834GT routers and bluging capacitors. Upon opening mine I found some very bulging capacitors indeed so I got out my spare router (even though against sky broadbands rules) and have been using that for the second day now and not a single problem at all. I've ordered parts to replace the capacitors in my netgear router. It will be interesting to see if that behaves with new parts fitted...
My System SpecsSystem Spec

26 Oct 2009   #4


Motherboard type and/or NIC chipset(s) having the problem
  • Gigaybyte i45, Realtek 8111 LAN (also have second Biostar i45 system w/Realtek 8111 LAN with same exact problem)
CPU Architecture (x86 or x64)
  • Intel QX9650 (X64) (both systems)
Upgrade or clean install?
  • Clean installs. Tried both W7 32 and 64
Driver details (i.e. manufacturer and version of driver experiencing connectivity issues)
  • Tried native MS drivers, tried latest Realtek W7 8111 drivers from their website, also tried Realtek Vista driver in W7's Vista compatability mode.
  • I also bought a D-Link DFE-530TX PCI add in ethernet card with the onboard LAN disabled. (same problem)
Problem description (LAN? Internet? Frequency?)
  • Internet browsing (Firefox and Explorer) starts out very responsive. After a few minutes I see an increase in server timeouts and dropped connection issues. It continues to degrade until I restart the system. (disabling ipv6, power management and uninstalling anti virus and firewall SW has no effect)
Solutions or Suggestions
  • Reverting back to Vista solves the problem
My System SpecsSystem Spec
26 Oct 2009   #5

Windows 7 x64

Motherboard type and/or NIC chipset(s) having the problem
Asus P5Q-E
Marvell Yukon 88E8001 / 8003 / 8010 PCI Gigabit Ethernet

CPU Architecture (x86 or x64)

Upgrade or clean install?
Clean install

Driver details (i.e. manufacturer and version of driver experiencing connectivity issues)
Was happening with default drivers installed on clean install (not sure of version #), upgraded to latest from Marvell site (, which did not help. Recently I upgraded to from Windows Update. Still testing.

Problem description (LAN? Internet? Frequency?)
Under high stress / bandwidth situations such as downloading off usenet at high speeds (2 MB/s +) my network cards will out of a sudden disappear and I will disconenct. The network tab of task manager does not show my network adapters after this happens. My memory usage spikes to 90-95% and I can't open any explorer Windows or device manager. Attemps to restart never happens and I am forced to hit the reset button. This has not happened under normal internet browsing, only when downloading.

I have disabled ipv6 and power save mode on both my Marvell network adapters.

Solutions or Suggestions
Might try the Marvell drivers which appeared in Windows Update recently. These seem to be newer than the ones on the Marvell site. Still looking to see if this helps at all.

I have heard from a friend that going out and buying a cheap $10 NIC solved his problem.

Update: drivers did not help. I was downloading at 2 MB/s and it happened. I had network connections open and device manager. I tried to disable the connection but it stopped responding. I could still move the mouse but that program stop responding. I ended up pressing the reset button.

Event Viewer is showing a bunch of these errors.

A timeout (30000 milliseconds) was reached while waiting for a transaction response from the WerSvc service.
The Diagnostic System Host service terminated with the following error:
Insufficient system resources exist to complete the requested service.
The server {06622D85-6856-4460-8DE1-A81921B41C4B} did not register with DCOM within the required timeout.
My System SpecsSystem Spec
26 Oct 2009   #6

Windows 7 Enterprise 64 Bit

Shortly after doing a clean install on a brand new PC part way through an MS Update my Internet connection was lost, my Network Adapter had stopped working, I found an error message saying this device cannot start, after some trial and error I found the problem - a driver update wasn't compatible, a driver Roll Back fixed it.
My System SpecsSystem Spec
27 Oct 2009   #7

Windows 7 Professional RTM

  • Motherboard/NIC: Asus P7P55D EVO - Intel P55 Chipset - Dual Gigabit Realtek 8112L / 8110SC onboard network adapters
  • CPU Architecture: x64 (Core i7 860)
  • Upgrade or Clean Install: Clean install (Windows 7 Professional x64 RTM)
  • Driver details: Both the Realtek Win7 64 bit 7.006 driver and the Realtek Vista 64 bit 6.227 driver, as well as an older version of the Win7 driver that came with the motherboard installation DVD
  • Problem description: Partial loss of network connection occurs after periods of transferring files (either to other machines or uploading on bittorrent). No visible indication of network failure. Currently open connections stay open (ex. AIM or if I've been seeding nonstop to a host since the problem occurred), but unable to make new connections. The only way to restore connectivity is a reboot.
  • Solutions or Suggestions: I've disabled power savings, IPv6, and changed every option in the driver config, with no success. The only way to avoid the problem is to not make large file transfers. Network connection stayed on for 3 days straight when I turned off bittorrent and refrained from transfering files to other computers, but otherwise I lose the connection 2-3 times per day. Transferring files to another computer will often cause the issue to occur immediately.
My System SpecsSystem Spec
27 Oct 2009   #8

Windows 7 Home Premium

  • Motherboard/NIC: Gigabyte X48-DS4 / Realtek RTL8168C(P)/8111C
  • CPU Architecture: x64 (Core2Duo E8400)
  • Upgrade or Clean Install: Clean install (Windows 7 Home Premium x64)
  • Driver details: Microsoft 26/02/2008 7.2.1127.2008 Rt64win7.sys
  • Problem description: Currently no problems reported however the "newer" windows update driver (dated 2007) DID NOT work
  • Solutions or Suggestions: Not touched anything it's a completely generic install. I did have to rollback the Windows update driver to the one originally shipping with Win7
My System SpecsSystem Spec
27 Oct 2009   #9

windows 7

Motherboard NIC: Asus P5NSLI nForce570 SLI/ Marvell Yukon 88E8001/8003/8010 Gigabit Ethernet Controller
CPU Architecture: x64
Clean install from Vista 32 bit
Driver details:
Problem description:
I've reset my router and modem several times to no luck. I keep troubleshooting under the network and sharing center and it keeps trying to identify the network. It will sit there and do that for about a minute and then it gives me an unidentified network. It then randomly gives me a ! or X sign either between the computer and network or between the network and Internet.
Every once and a while it will connect to the "home" network with some of the ! in between the computer and network or the network and Internet.
The recent refreshing I did for the connection shows my computer connected to the network, and the network connected to the Internet without any ! like it is now. When I try to open up the Internet it pretends that it's connecting saying that it's connecting to site 56.53.4565 (using that as an example) and it throws the ! back between the computer and network icons.
I typed in the address for facebook and on the tab it said welcome to facebook but yet it didn't connect. So I think it's trying but it just doesn't want to go. I reset the connection using the network diagnostics again and it put me back on the unidentified network with the ! or X between the unidentified network and the Internet.
My System SpecsSystem Spec
27 Oct 2009   #10

Windows 7 RC 7100

Motherboard NIC: Asus M2N32 SLi Deluxe (Wireless Edition), Dual NIC's

CPU Architecture:
AMD Athlon X2 6400+ x64 bit

Dual Boot: Vista 32 Partition D:, Windows 7 x64 partition C:
Clean Install on separate partition

Router: Linksys Wireless WRT110, currently not in Windows 7 list of supported (x64) Routers. 32 shows compatible... Go Here

Problem Lead up:
For several months I have been testing the waters with Windows 7, seeing if it was another Vista or a step back towards XP. (So far a little of both.) That said, for several months my Ethernet connection was fine, no issues at all to speak of. Then, see thread here for full details, my Ethernet connection just stopped working after a reboot. I thought perhaps it was a new driver, but nothing available in the Rollbacks. So I was just going to run a System Restore, but the only available date was that of the day it happened after the update.

Problem Description:
I CAN connect with my built-in Wireless connection, but my ethernet hard-wired connection just stopped working. Windows will not update the driver as I have tried using nForce drivers (I'm told I already have the best driver). I know this is not a media issue because I have an Xbox 360 connected to the same switch and it operates fine even after swapping cables. So I'm at a loss unless there are drivers that will update. Otherwise, I'm ready to do a clean install.
My System SpecsSystem Spec

 Ethernet Connection Lost (and Found?)

Thread Tools

Similar help and support threads
Thread Forum
lost ethernet connection in win7 pro
im running windows 7 pro on my main pc, windows 10 on laptop. i rebooted the pc and it installed windows updates. after it installed them and booted up i have no ethernet connection. thinking it was my virgin media hub i rebooted that to find i still have no ethernet connection. so i booted up my...
Network & Sharing
Lost Pwr During Defrag - FOUND folder not found
Last night was using Auslogics to defrag an external WD 1.5TB BU drive... 2 hours in we had a power loss...lights and TV went out and came back on. The laptop that was running the Auslogics had a batt, but the external drive lost power in the middle of the defrag process. Turned everything off for...
Performance & Maintenance
Ethernet Driver Lost
Hi, Complicated story but after trying to install Windows 7 I couldn't get it to work so the only other disk I had was Windows XP Home. Installation went smoothly. Only thing is, I can't connect to the internet or my network because the ethernet driver was not regonized. A link to a site where you...
Wireless network connection lost internet connection
Hi everyone, I work in an office where we have a main desktop computer which is connected to the internet via a Time Warner modem. The modem is connected by cable to a netgear wireless router, and up until today there have been no problems connecting to the internet from the laptops that use the...
Network & Sharing
Ethernet connection lost after standby
Hey all, I have Windows 7 RTM Pro x64 on my laptop, and have for the past couple of months now (before that it was beta/RC). I haven't been having any severe issues until recently. Since it is a laptop, and i carry it to 3-4 classes a day (using wifi), i almost always put it in standby....
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:41.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App