Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Please help with using Samba shared from a Linux host

28 Mar 2014   #1

Win7 64bit
Please help with using Samba shared from a Linux host

Dear friends,
please bear with my ignorance. I have to run a Windows 7 virtual machine under KVM on a Linux Ubuntu 12.10 64 bit host to run MS Office 2013.

I have printers defined on the Linux host and would like to have the Win7 guest to "see" them.

I have therefore setup a samba server on my Linux host for sharing both the printers and a directory. While the latter works great, I am not able to "see" the printers from within the Win7 guest.

Would any of you be so knowledgeable (and patient and kind :-)) to see if you can sort out which mistake I might be doing ?

Here follow info from a thread I posted on a Linux forum. Thank you so much in advance:

Dear friends,
I am trying to "see" the printers I have defined on an Ubuntu Linux IBM client from within a Windows 7 guest OS running under KVM virtualization via Samba protocol.
The setup of the samba server seems quite aok to me and from within the Win7 command line if I issue a net view command I see the following (slightly trimmed redundant entries:
C:\Users\IBM_ADMIN>net view \\
Shared resources at \\
Samba Server Version 3.6.6
Share name Type Used as Comment
Downloads Disk
itroml39 Print itroml39
itroml39.confidential Print itroml39.confidential
... snip ...
itroml78 Print itroml78
itroml78.confidential Print itroml78.confidential
itrotl37 Print itrotl37
itrotl37.confidential Print itrotl37.confidential
PostScript Print PostScript
shared_robert Disk Z: robert home
The command completed successfully.
Unfortunately when I go through "Devices and printers" -> Add a printer -> Add a network printer, Win7 never finds anything, nor the Computer->Network "method" finds anything (even though I do use a shared folder very well).
So I think it's the "browsing" thingie not working :-)
Is there a commandline net use command that might work ? I tried "net use \\\itrotl37" and similar, which issues a "Command completed succesfully" msg but the printer is not to be found anywhere.
Anyone know what I could try ? Thanks in advance. Attaching a couple of files which I hope will give you clues.
Here follows also an excerpt of my Linux samba config:
workgroup = LINUXKVM
server string = Samba Server Version %v
interfaces = lo virbr0
log file = /var/log/samba/log.%m
max log size = 50
security = user
load printers = yes
cups options = raw
comment = All Printers
browseable = yes
guest ok = no
writable = no
printable = yes
path = /tmp
#public = yes
# path = /var/spool/samba
#create mode = 0700
use client driver = yes
The virtual Win7 machine has a WIN7KVM hostname and belongs to a LINUXKVM workgroup.

My System SpecsSystem Spec
28 Mar 2014   #2

Windows 7 Ult, Windows 8.1 Pro,

Not completely sure on this as your set up is a bit different than normal.

For Samba share access Windows 7 requires some adjustments to the lanman server settings and the encryption might also be a problem.

The following link shows how to make these adjustments via the Local Security Policy.

Solved W2K3 Server can access W8 W8 computer cant see W2K server
My System SpecsSystem Spec
28 Mar 2014   #3

Win7 64bit

Thanks for trying to help but the instructions from the thread you mention on Win8 do not seem to work on Win7 (at least for a clueless newb like me).

Any pointers relevant to Win7 ?

Take care
My System SpecsSystem Spec

28 Mar 2014   #4

Windows 7 Ult, Windows 8.1 Pro,

Quote   Quote: Originally Posted by rjalex View Post
Thanks for trying to help but the instructions from the thread you mention on Win8 do not seem to work on Win7 (at least for a clueless newb like me).

Any pointers relevant to Win7 ?

Take care
Well Windows 7 has the same settings but if you don't have the Local Security Policy then you must be using Home Premium version.
My System SpecsSystem Spec

 Please help with using Samba shared from a Linux host

Thread Tools

Similar help and support threads
Thread Forum
Wireless win7 can't access wired linux samba share
I just setup a samba server on a linux box I have in another room. My laptop (Win 7 Home premium) is on wireless and can't access the share. In my living room I have a wireless router which sends internet wirelessly to my bedroom where my linux box is. That room has another wireless router which...
Network & Sharing
VirtualBox Shared folder-Win 7 Host & Win XP Guest
Dear All, I am using Win 7 SP1 (Host OS). I have installed Oracle VM VirtualBox v4.1.2 where Win XP SP3 is the guest OS. Please let me know how do i share a folder from my host OS which is visible and accessible from the guest OS (Win XP) in VirtualBox? In VirtualBox even though I have...
laptop cannot see linux server running samba on the same network
Hi, I'm setting up home media server. At least trying to... My home network looks like this: 2 laptops (ubuntu/windows7) and a home server (ubuntuServer + Samba). I've samba setup in a way to provide password-less access to share folders. I secured it by blocking all IPs but the range I...
Network & Sharing
BSOD when connected to Linux Samba share
I just built a new system and installed Windows 7. Everything went fine until I connected to a network share hosted by a Debian Linux box running Samba 3.4.2. I can see the share and it's contents but within 10 minutes Windows 7 will go down with a BSOD complaining about rdbss.sys. Has anyone...
BSOD Help and Support
Linux Samba fil sharing issue
Hi It seems that Seven doesn't like a lot file sharing with a linux file server using Samba. That was allready the case with Vista but samba get up to date, and some issues where fixed. Now I would know if some here have issues with Seven. If yes can you please give some details:...
Network & Sharing
problems about shared folder from samba(linux file serv
Hi, all I have a file server on linux box. It's used to work fine on Win xp. Now I have new Win 7 box on LAN. It seems works when I map a drive on one shared folder from file server. It didn't ask me user name password and automatically connect. While on XP at the first time connection XP will...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:11.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App