Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: "The dependancy service or group failed to start"

04 Apr 2014   #1

Windows 7 32Bit + 64Bit
"The dependancy service or group failed to start"


I have a laptop running Windows 7 64bit. It was working fine up until a week ago when it started to display "The dependency service or group failed to start" when I was trying to connect to a network. I have seen a lot of threads and tried a lot of things and nothing has worked. Also (not sure if this ties in) but I can't start the DHCP service "Error 5 access denied" will list what I have tried with that below as well.

NOTE: All commands and regedits were ran with elevated rights as Admin.

List of things I've tried and it hasn't worked:
  • sfc /scannow - tried 3 times with numerous restarts. Completes to 100% and says that no corrupted files were found.
  • Nestsh winsock reset & netsh int ip reset commands numerous times
  • Give full rights for "SERVICE" to the reg - HKLM/System/CurrentControlSet/services/Dhcp.
  • Also tried to start all the dependencies that the DHCP service relies on and they were all ready started.
Probably a few more things I've tried but can't remember. All of the above are steps that I have tried and nothing has worked. Can anyone help me with this?


My System SpecsSystem Spec
04 Apr 2014   #2

Windows 7 Ult, Windows 8.1 Pro,

Click Start, on search box, and then type devmgmt.msc press enter. From Device Manager, locate the Network Adapters, expand it. Do you see any ! on one of the network adaptors?

From the troublesome computer verify that all your network services are Started from Control Panel=> Admin Tools=> Services: or run box type services.msc to open Windows services.
• COM+ Event System (for WZC issues)
• Computer Browser
• DHCP Client
• DNS Client
• Network Connections
• Network Location Awareness
• Remote Procedure Call (RPC)
• Server
• TCP/IP Netbios helper
• Wireless Zero Configuration ( XP wireless configurations only)
• WLAN AutoConfig ( Vista wireless configurations only)
• Workstation

make sure they are all working and not set to disabled although it looks like you already checked that and were denied access to the DHCP service?

This problem is common but with many different solutions and can be a real PITA to fix depending on what caused it in the first place.

Have you tried using system restore?
My System SpecsSystem Spec
04 Apr 2014   #3

Windows 7 32Bit + 64Bit

Hi Chev,

Thanks for the reply. It was in the middle of a system restore (previous restores had failed) this one fixed the issues. Will mark as solved.

Thanks again.

My System SpecsSystem Spec

05 Apr 2014   #4

Windows 7 Ult, Windows 8.1 Pro,

It's nice to see system restore working as it should for a change. Glad you have fixed the issue.
My System SpecsSystem Spec

 "The dependancy service or group failed to start"

Thread Tools

Similar help and support threads
Thread Forum
"apple mobile device service failed to start"
I am unable to install iTunes on Windows 7 on a Dell Optiplex 780. It always errors out as "apple mobile device service failed to start" and then installation always rolls back. One result told me to remove all apple software on my computer, but I do not have any apple software installed, it always...
General Discussion
the dependency service or group failed to start
Hi, i am facing this problem for a couple of weeks :confused:. when i try to connect to the internet using wi-fi, it says limited access. on opening network and sharing center, under the "View your basic network information and set up connections" heading, it says "unknown", where it used to show...
Network & Sharing
"Home Group Listener" service won't start, error -2147023143
I am not able to start the "Home Group Listener" service, hence I can't use Home Group feature. I get this error message: I checked the System Event Log, I found this entry:
General Discussion
"The dependency service or group failed to start" after sys restore
So I installed SP1 on my netbook (Windows 7, 32bit) but it made my notification icons disappear, and the options to re-enable them was greyed out (aka here) so I did a roll back to before I installed SP1 and for some reason, after reinstalling my Custopack (this one if yer curious) - which I've...
Network & Sharing
"Can not start the dependency service or group"
I need help, because I canīt run anyone application Once time that I try to run any application, the system become in slow performance and few minutes later appear the fallowing dialog box: "Can not start the dependency service or group" This occur with all kind of application that I try to...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Đ Designer Media Ltd

All times are GMT -5. The time now is 14:38.
Twitter Facebook Google+