Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Custom Build with Win 7 not connecting to modem

17 Apr 2014   #1

Windows 7 Professional 32bit Service pack 1
Custom Build with Win 7 not connecting to modem

Greetings all,

I was on my computer last night and all was well until 3AM rolled around and the pop-up for Windows update appeared. I let the computer do it's thing and restart, installing the update. Afterward I could not connect to the internet and haven't been able to since. I'm sorry but I neglected to write down the number of the KB article. The only one sitting waiting to be updated now is KBB90830, the Malicious software removal tool.

This is a wireless connection on a custom build computer running Windows 7 Professional 32bit.
The wireless card is a TP-WDN4800.
Everything else in the house both wired and wireless is connecting to the modem fine.

I've tried the following:
- powercycling the modem (no change)
- powercycling the computer (no change)
- system restoring to a point before the update (failed)
- manually finding and removing the update and restarting (no change)

Clicking on available networks shows my modem in the lineup. Clicking on it starts an attempt to connect to it. It then states that it's connected to an Unidentified network set as Public with No network access. It shows the icons that indicate that it's connected to the modem but can't get out from the modem to a website.

I've then tried the following:
- checking Device Manager, states the wireless card is operating and drivers are updated
- disabling the TP link and then enabling it. (no change)
- uninstalling the TP link and restarting. (no change)
- inserting the disk that came with the TP link and attempting to reinstall drivers. (states they're already updated)
- getting into the modem from another computer shows my computer is not connected to the modem at all

Ipconfig /all shows the following:
Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : TP-LINK 450Mbps Wireless N Adapter
Physical Address. . . . . . . . . : C0-4A-00-1E-F7-BE
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::14b3:3258:4c94:6205%12(Preferred)
Autoconfiguration IPv4 Address. . :
Subnet Mask . . . . . . . . . . . :
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 281037312
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1A-BE-1C-65-C0-4A-00-1E-F7-BE

DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Attempting ipconfig /release and ipconfig /renew did nothing.

So the set up looks fine from every angle I've tried and yet I'm still getting the 169 ip address.
Attempting to set up a new connection also fails with the same icons and issues.

I need some new ideas to try and any help would be appreciated.

My System SpecsSystem Spec
17 Apr 2014   #2

Windows 7 Ult, Windows 8.1 Pro,

System restore is made to roll back your machine to before when the problematic updates were installed.

After that you can figure out which update caused the problem and right click to "hide the update" so it won't install again.

System Restore
My System SpecsSystem Spec
17 Apr 2014   #3

Windows 7 Pro-x64

I'm a little weak on network stuff but it doesn't look like your router is connected to your ISP. Confirm that they use DHCPv6 because you don't have a Default Gateway address and the DHCPv6 addresses look corrupt. You also might try running the network troubleshooter. It can fix quite a few problems. (Right click the network status icon in the lower right corner and select Troubleshoot Problems.)
My System SpecsSystem Spec


 Custom Build with Win 7 not connecting to modem

Thread Tools

Similar help and support threads
Thread Forum
no sound when connecting with usb modem
dear all, i have a problem on my windows vista ultimate 32 bit, when i connecting my ZTE MG880 (CDMA Modem) on my laptop especially at starting modem application, suddenly the sound becomes dead :cry: ... I use Compaq CQ40 322 TU... And what the problem ? Thank's
Sound & Audio
USB modem not connecting to internet
Hi There. Afew days ago i was trying to connect my laptop to my ps3. To do this i was changing setting etc but never got it to work anyway.. The next day i turn the computer on and can't connect to the internet. I think it was something to do with dns :sarc: I uninstalled and reinstalled my...
Network & Sharing
Modem Connecting Problem
I have a huawei modem. When I try to connect to modem by using it then I got a message "Failed to create a phone book entry". Then I search to internet about this problem. I found a solution by the deleting file named "rasphone.pbk" where located is c:\program...
Hardware & Devices
Connecting Modem to PC
At present, I have the following setup: Cable comes into the modem and goes to the router. The router then feeds my Vonage phone system and all my computers. The only computer that connects wireless is my wife's laptop, everything else is hard wired. 99% of the time this setup works...
Network & Sharing
E220 Modem not connecting win7
I've got a bit of a problem with this modem connecting 3G on a Toshiba I5(Bran New) SatillitePro for the BIG BOSS leaving at 5pm PLEASE if there is any one with a page where I can get some correct info on my issue Please Help asap... I've tried updating Firmware no success
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:44.
Twitter Facebook Google+