Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Network adaptor keeps going to 'unidentified network'

22 May 2014   #1

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
Network adaptor keeps going to 'unidentified network'

Hello Guys,

So my office PC keeps going to unidentified network and I have to disable and enable the network adapter for it to get an IP address and connect back to the network. I'm using a LAN connection not wireless by the way.

I have not seen this issue on any other computers/laptops on the network, only on this specific system so I'm thinking its not a problem with my DHCP or anything.

Any other information required please let me know and any help in fixing this would be greatly appreciated.

Thank you.

My System SpecsSystem Spec
22 May 2014   #2

Windows 7 Ultimate 64-bit, Windows 8.1 64-bit, Mac OS X 10.10, Linux Mint 17, Windows 10 Pro TP

I don't see it often but usually unplug the Ethernet cable, use Device Manager to Uninstall the NIC/Network Interface Card/adapter, reboot and let the computer find the NIC and install it. Sometimes it's necessary to get new/fresh drivers for the NIC.
My System SpecsSystem Spec
22 May 2014   #3

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1

Thank you for the response, will try this tomorrow and get back to you.
My System SpecsSystem Spec

27 Jun 2014   #4

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1

Did what you suggested, still the same thing. Sometimes the network troubleshooter would fix the problem other times I would have enable/disable the adaptor for it to get connected. Could it be the controller failing or just a driver problem?
My System SpecsSystem Spec
14 Jul 2014   #5

Windows 7 Ultimate x64

Similar problem happening to me
Came home Sunday to find my W7 Ultimate SP1 64b Gigabyte Ethernet connected desktop has lost the internet. Only changes would be Windows updates.
My Laptop, smart phone and tablet all connect ok but the PC says it has an "Unidentified Network". And, of course "No internet".
I've tried as many of the recommended actions as I can but the system keeps deleting or changing the IP address if I enter the Default gateway - ipconfig /all info shows DHCP off but the DHCP service is running.
Always comes back to "Unidentified Network".
Any advice welcome.

My System SpecsSystem Spec

 Network adaptor keeps going to 'unidentified network'

Thread Tools

Similar help and support threads
Thread Forum
Fresh install of Win7 *unidentified network/no network access*
I've freshly installed Windows 7 Enterprise 64 bit on my system that previously had Ubuntu installed, and prior to ubuntu had win7 ultimate installed. With the fresh install of win7, I receive an unidentified network/no network access issue. Heres a list of things ive tried: - reset the...
Network & Sharing
Unidentified Network - No Network Access - Win7 64bit
For some time now my internet would be fine for 1hour after booting up my computer and then the network would then fail to be recognized. I have followed multiple tutorials on the internet, with countless suggestions, where other people have had the same problem. Some seem to fix the problem for a...
Network & Sharing
USB Ethernet adaptor set as unidentified network, no internet access
Hi guys I have tried fixes from all over the Internet and nothing seems to have worked. It seems there is an error in the gateway settings, but I cannot figure out where I'm going wrong. Any help or suggestions would be much appreciated. I ran out of Ethernet connections on my wireless...
Network & Sharing
Unidentified Network - No Network Access, since downloading Windows 7
I had Windows Vista and everything was fine, today I decided to use my free Windows 7 upgrade and I can't connect through my router. It started when I downloaded Windows 7 and I went to connect and it showed my network it said "Unable to connect to "network"". Then after a little why, it didn't...
Network & Sharing
unidentified network - public network Windows 7 64bit
Hello all, I have tried all the similar solutions to my problem but non eworks. I have just installed WIndows 7 Home 64bit. Wireless works (slooooooow). The cable from my Billion router/modem is recognised but does not work. In network and sharing centre I can see Wireless as Home...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:14.
Twitter Facebook Google+