Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7: Can't change setting System Properties > network ID setting

22 May 2014   #1

Windows 7 Pro 64bit
Windows 7: Can't change setting System Properties > network ID setting

I am trying to add a refurbished HP system to my menagerie. It had Windows 7 Pro (64bit) installed when I got it. I went through the setup without any problems, created a user account for myself (Lewis), set the system name to TestPC and started installing and testing some software. Simple internet access (web page browsing) is working fine.

Today, I connected and external disk drive (from a Windows XP system) and I was able to successfully read anything on it. But when I attempted to delete a file, I was told I needed permission even though I am the administrator. I found some instructions at Microsoft for changing ownership of the files on the external drive, so I did that. It was then that I noticed the user name shown was Lewis(TestPC\Lewis) and I was still not able to delete files on the external drive.

Being primarily a Unix person, I have been fumbling around looking for something that would indicate why Windows felt the need to attach the system name to user names. In Computer>Properties>Computer name, domain and workgroup settings>System Properties>Computer Name>Network ID, I found a selection with the following description: "This computer is part of aa business network; I use it to connect to other computers at work". Since this is not true, I selected the other option and worked my way back out to restart the computer.

After the restart, that erroneous setting was still there. I have tried several more times to change it but they have all failed.

Any suggestions would be appreciated.

My System SpecsSystem Spec
22 May 2014   #2

Microsoft Community Contributor Award Recipient


Hi Lewis, welcome to the Seven Forums.

The \\DOMAIN_OR_PC_NAME\USERNAME combination is not erroneous, it's how Windows keeps track of users in your network (even if said network only has one Windows PC).

For Windows, when a computer does not belong to a domain, the PC name is used instead of a domain name. I am currently typing this using a laptop with name AGM-W8LAP02 (my own naming policy, my home network is called AGM and this is Windows 8 Laptop number 02). My complete username for this user profile I am currently using on this computer is \\AGM-W8LAP02\Kari. This combination \\DOMAIN_OR_PC_NAME\USERNAME does separate my user profile Kari on this computer from user profile Kari on other computers. User \\AGM-W8LAP02\Kari is not the same user than \\AGM-W7DESK01\Kari.

For Windows it's easier and more logical to use this naming policy even if your PC would be the only one in network. If you now add computers to your network which also contain user profile Lewis, Windows does not have to change the system to be able to separate users not only from other users on the same computer but also from same users on other computers.
My System SpecsSystem Spec
23 May 2014   #3

Windows 7 Pro 64bit

Kari - Thanks for the response. I understand the naming convention used to uniquely identify users. I thought Windows generally hide the addition of the system name from most user functions.

My problem is that when I take ownership of the files on the external drive, the \\SystemName\User is assigned as the owner but when I try to modify the files, I am told that I need to get permission from \\SystemName\User which I thought was me.

The other thing that muddies the water is the settings for the computer that indicates that windows thinks it is in a business domain, and all attempts to change that generate no error messages but do not change anything.
My System SpecsSystem Spec

23 May 2014   #4

Microsoft Community Contributor Award Recipient


I assume I get a lot of negative feedback from senior geeks after saying this, but here it goes: I do not understand why a user should need to take ownership of a file or a folder. I am a quite experienced user, both private and profesionally, and last time I can remember taking ownership of something was with Windows 2000 over 10 years ago. When computer and network are properly set up, there should be no need for this. Exceptions might exist but for me that is a useless, never needed procedure.

Since that Windows 2000 I mentioned above, I have reinstalled, transferred user files and folders, done backups, copied files between Internet, various cloud services and my networked computers, never needing to take ownership of anything. But, as I said, it's over ten years I have needed to manually change ownership of a file or a folder.

That being said, here's an excellent tutorial about taking ownership: Tutorial: Take Ownership - Allow or Prevent Users and Groups To.

Now about your business domain issue:

Windows 7 kind of always thinks it belongs to a domain. When no real domain exists, Windows considers the workgroup it belongs being a domain. This really even if your workgroup, your network only has one PC.

Within that workgroup, each PC can set network location as the user wishes. Available selections are Home, Work and Public. Basically, the Home and Work are the same, they both allow sharing between computers in same workgroup. For your Windows it's the same if it uses Home or Work network location,.
Windows 7: Can't change setting System Properties > network ID setting-2014-05-23_21h37_51.png

My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
what windows setting do I need to change?
A while back I was trying to get Lotus 1-2-3 (its from 1998, the final release) to always start on monitor number 2 of my multimonitor setup. I tried out the program ultramon and made some changes with it but could not get it to do what I wanted, didn't really like the program, TRIED to reverse...
General Discussion
Can't change setting System Properties > network ID setting
I'm trying to set up a Synology NAS for my home network, however I can only access via the Synology utility and through a browser using the internal IP address. It does not otherwise appear on my network; I can't ping it, map drives to it by any method, etc. Googling suggests that this problem...
Network & Sharing
Cannot change System icons setting
So i installed windows 8 transformation pack, and then window update to service pack 1 now my volumn network action center etc cannot be accessed. Sorry for crappy grammar, typing this from an ipad as i am currently restoring back. Uh, i tried the solution of group policy editing and got a...
General Discussion
Can't change Windows Update setting
I just did a clean installation of Windows 7 Home Premium 32-bit on my Fujitsu Lifebook U820. I am signed on with an account that has administrative permissions, but when I go to Windows Update and try to change the settings, the dialog tells me "Some settings are managed by your system...
Windows Updates & Activation
Properties Setting
Hey anyone knows how to set this to "General tab ? (Default Tab)" I want to check on the disk space and now it gave me a sharing tab as default ...(General Tab)
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:07.
Twitter Facebook