Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: No internet on desktop ethernet, but 2 others OK wireless

30 Jun 2014   #1

Windows 7 home premium 64 bit
No internet on desktop ethernet, but 2 others OK wireless

I have an HP desktop WIN 7(64) connected to an ARRIS Cable Modem via Ethernet.

A few days ago, I installed a couple of Microft “critical updates.” After the second one installed and rebooted, most of my desktop icons were missing, the rest were rearranged, and the desktop background was black rather than the simple blue. Also, it'd changed the desktop from my classic pattern back to the pattern that came on the original installation. So I did a system restore, and that brought things back to where they were, but I could no longer connect to the internet. I also have a laptop and iPad which were still able to connect to the network just fine.

I ran the complete HP diagnostics and everything was OK. I ran a startup repair and nothing there. The green Ethernet light on the front of the Modem is flashing green. On the back, the Ethernet cable has 2 lights: the upper is flashing orange, the lower is red. When I click on the signal strength icon in the systray, it says “Not connected; no connections available.” I opened the Network and Sharing Center, but nothing on there gets me back on the internet. Time-Warner says that the signal to the box is good.

I read through many of the problems similar to this on the forum, but none of them seemed to duplicate this problem. The closest seemed to be ones about reinstalling the ethernet drivers. If I have them, I don't know where they are, as I have no installation disks for the computer (that I can find).
Here are what I think must be the applicable readings from the Device Manager:
Network Adapters:
-Qualcomm Atheros 802.11 a/b/g/n Dualband Wireless Network Module
General Tab: This device is working properly
Advanced Tab:
--AdHoc 11n: Disable
--Dynamic MIMO Power Save: Disable
--Network Address: Not Present
Resources Tab: Conflicting device list: No Conflicts
-Realtek PCIe GBE Family Controller
General Tab: Windows cannot load the device driver for this hardware. The driver may be
corrupted or missing (Code 39).
Advanced Tab:
--Auto Disable Gigabit: Disabled
--Jumbo Frame: Disabled
--Network Address: Not Present
--Shutdown Wake-On-Lan: Disabled
Resources Tab: This device isn't using any resources because it has a problem.

Anything you can do to help would be greatly appreciated. I really don't want to have to wipe out all my files and start from scratch via a system recovery operation, even though I do have my data files backed up. Reloading all the programs would take more time than I may have left in this lifetime.

My System SpecsSystem Spec
01 Jul 2014   #2

Windows 7 64-bit SP1 (VM)


I would suggest trying to reinstall your Ethernet driver.

In your case you don't necessarily have to have the disk that came with your computer to re-install the driver.
The drivers can usually be found on your computer's manufacturer website.

To find your computer model, you can either look under your laptop or look on your desktop computer box for information given by the manufacturer. Another way of doing this is typing "dxdiag" in start menu search box. When you open dxdiag you will see information about your computer, your System Manufacture and your System Model.

Using this information search up the manufacture's website. (e.g Laptops, LCD Televisions, Projectors, Medical Imaging & More - Toshiba America Inc) then go to computers then support. You should see an option for downloadable drivers. Using the infomation you found eariler about your computer model, find your computer model then download your ethernet driver. If you are unsure about which driver to download, go to device manager in control panel. Under network adapters you should see your installed driver, download this one.

Once you are sure you have selected the appropriate driver. Uninstall your existing netwrok driver by right clicking on it in device manager. Once you have uninstalled it, run the installer of your downloaded driver.

If you are still unsure of what driver to download, tell me your computer's manufacture and system model and I will find the correct driver for you to download.

Good luck! .

P.S I would lean more towards fixing the Realtek PCIe GBE Family Controller driver first as it looks like this is why the problem is occurring.
My System SpecsSystem Spec
02 Jul 2014   #3

Windows 7 home premium 64 bit

ellellell1: I don't care what those other people say about your replies, but so far as I'm concerned, you're worth your weight in gold!!! :0)
I went to the HP website as you said, and the Realtek was the only one they listed, so did what they said: problem solved!
Since you're a POWER USER, I assume that means you can solve a lot of different problems. If so, I have 3 others that I need help for. It's probably not proper to discuss them in this forum, but if you'd be willing to tackle them, I could post them on the proper forums so you can try them, too. Thanks much. AL
My System SpecsSystem Spec

03 Jul 2014   #4

Windows 7 64-bit SP1 (VM)

Awesome Job ECKJR! Great to hear your problem has been solved.
Thank you very much for your kind comments and you are very welcome .

I would be happy to help your others computer problems.
It would be great if they could create an account on Seven Forums themselves so that they can receive help directly from others too .

My System SpecsSystem Spec
03 Jul 2014   #5

Windows 7 home premium 64 bit

I posted one problem in the Browsers and Mail Forum. Title is "WLM configuration bad, won't load contacts". Your thoughts in that Forum would be greatly appreciated!
My System SpecsSystem Spec

 No internet on desktop ethernet, but 2 others OK wireless

Thread Tools

Similar help and support threads
Thread Forum
Desktop connects to wireless network, but not to Internet
I have a Dell XPS 8300 (running Windows 7 Home Premium) that has lost Internet access. It was fine until yesterday. It shows that it's connected to my home wireless network, but cannot acces the Internet. All our other computers (desktops, laptops & iPad - all running different OS) are able to...
Network & Sharing
Internet sharing a Verizon Wireless USB modem and an Ethernet network
We have three 64 bit Window 7 machines on an Ethernet wireless/wired router (ASUS WL-520GC). Worked great… one of the three computers hosts a USB printer and shares with no problems (via a HomeGroup). We had a broadband power line modem on the same Ethernet network connection and all three...
Network & Sharing
Internet acces through ethernet but not wireless
<<THE SOLUTION>> Microsoft couldn't get me the latest drivers for my wireless network card so even if the drivers turned up as up to date in device manager that wasn't the case. That resulted in no wpa support so when I removed the security or connected via ethernet it worked. If you have this...
Network & Sharing
No internet access with ethernet, but wireless works
Firstly: Hello sevenforums! It seems there are many others with this problem, but none of the solutions seem to work for me, yet. I have a Motorola sb 5101 cable modem connected to a nameless 10/100mbps Ethernet switch, and then a PC connected with an ethernet cable to the switch and an Apple...
Network & Sharing
ethernet cable screwed up wireless internet?
Hi all, I am running an IBM T60P. with Windows 7. a Cisco Router "linksys E3000" My wireless has been running fine for the last few years. (win xp and win 7) Today I wanted to try something (I knew it wouldn't work but figured what the hell" I plugged in an ethernet cable and hooked it up...
Network & Sharing
Ethernet=No Internet But Wireless Works Fine
I'm sure this has been asked 1000 times but I cannot seem to find my exact issue anywhere. Hopefully this helps myself and anyone who runs into this issue. To start, I have Windows 7 Professional 64bit. Everything worked 100% fine with absolutly no issue and then.... I moved. Now we have Fios...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 14:12.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App