Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Some apps unable to access the Internet

15 Sep 2014   #1

Win 7 Professional 32-bit SP1
Some apps unable to access the Internet

Hello all, from a newly-joined member of the Forum. I hope someone can help me resolve a problem that's driving me slightly beserk!

A few weeks ago I did a completely fresh installation of a (fully licensed) version of 32-bit Win7 Pro on a Dell OptiPlex 780 platform, to replace the version of Vista that was originally installed on the machine. The machine has a 1Gbps wired connection to my ADSL router, a Billion 7800N - my ISP is Demon (now part of Vodafone).

The Win7 installation on the OptiPlex 780 proceeded pretty smoothly and after installing the Dell system-specific video, network and sound drivers I soon had the system up and running as I wanted it, and all seemed well, so I proceeded to install various apps including my preferred firewall (Comodo) and anti-virus (Avast!), followed by Firefox which I much prefer to IE.

During the course of installing various other apps I wanted to install Adobe Reader and Flash Player so I downloaded the installer 'stubs' and set the online installers running, but subsequently nothing at all happened - no further download activity, no error messages, nothing whatsoever even after leaving the system to its own devices for a few tens of minutes, and at no time did the Comodo firewall generate any alerts to indicate that a program was trying to get through the firewall and access the Internet. In the end I had to resort to downloading (using Firefox) and running the offline installers for the Adobe apps.

In the last couple of days I've found that when I instruct the Macrium Reflect backup and imaging software I've installed on the OptiPlex 780 to check the Macrium website for updates, the program just hangs without any indication of errors, and eventually I have to kill the app. Again, the Comodo firewall doesn't raise any alerts about the app trying to access the Internet.

I've also just tried to launch IE 11 and found that it just sits there, with the activity indicator spinning and displaying a status message that says "Waiting for a response from <website>..."

I'm able to use Firefox (32.0.1) on the OptiPlex 780 to browse the Internet without any problems whatsoever, and telnet from the 780 works entirely correctly not only to other machines on my 192.168.x.x LAN but also to addresses on the Internet, so the basic network connectivity is there and working, but for some reason IE 11 and the various other apps don't seem to be able to communicate with the Internet.

I've now uninstalled the Comodo firewall and Avast! anti-virus from the OptiPlex 780 and have reverted to using the Win7 firewall and MSE, to no effect - IE 11 and the Macrium Reflect updater still don't seem to be able to access the Internet.

I've tried using various netshell reset commands (int ip and winsock), as suggested on this forum for similar problems, but again these have made no difference.

IE 11 on another Win7 machine - a Dell Vostro laptop with a wireless connection to my router - works absolutely fine so there's nothing configured on the router that might be blocking the accesses from some of the apps on the 780 machine to the Internet.

Although I rarely need to use IE 11, it's a real bind not having it and various other apps, especially the Adobe installers/updaters and the Macrium Reflect updater, able to access the Internet but I'm at a complete loss to know what to try next to overcome the problem! It seems to me that something somewhere is blocking these apps' accesses to the Internet but I don't know where to look - temporarily disabling the Win7 firewall doesn't make any difference so it's not that that's doing the blocking!

Has anyone else experienced a similar problem and found a solution??!! I really don't want to have to reinstall the entire O/S and all the apps just to overcome the problem.

Thanks in advance


My System SpecsSystem Spec
15 Sep 2014   #2
Microsoft MVP

Windows 7 Ult. x64

Martin - I've asked Rayda to have a look at this for you.

In the meantime, please gather some information as described here:
Basic Requirements Before Posting your Networking Thread
My System SpecsSystem Spec
15 Sep 2014   #3

Win 7 Professional 32-bit SP1

Hello, thanks for the prompt reply to my posting and also thanks for passing it on to Rayda.

I thought I'd already covered most of the 'basic requirements' in my original posting, but here in addition is the output obtained when I ran 'ipconfig /all':

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\Martin G0HDB>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : G0HDB-DELL780
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : G0HDB_home

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . : G0HDB_home
Description . . . . . . . . . . . : Intel(R) 82567LM-3 Gigabit Network Connection
Physical Address. . . . . . . . . : 00-25-64-B7-35-15
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . :
Subnet Mask . . . . . . . . . . . :
Lease Obtained. . . . . . . . . . : Sun 14 September 2014 16:36:45
Lease Expires . . . . . . . . . . : Tue 16 September 2014 04:36:45
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . :
DNS Servers . . . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.G0HDB_home:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : G0HDB_home
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fb:a6:237b:3f57:fed5(Preferred)
Link-local IPv6 Address . . . . . : fe80::a6:237b:3f57:fed5%13(Preferred)
Default Gateway . . . . . . . . . : ::
NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Users\Martin G0HDB>

I forgot to mention in my original posting that the DHCP server on my Billion 7800N router is configured to use 'fixed-host' MAC binding so that all the clients, both wired and wireless, on the 192.168.x.x network get pre-defined 'static' IP addresses assigned to them.

I also forgot to mention that I've run full MSE and Malwarebytes scans on the machine and that they didn't reveal any 'nasties'.

I hope this additional information will prove helpful, and thanks again for taking an interest in my problem!

My System SpecsSystem Spec

15 Sep 2014   #4

Win7 & Win8 64bit

Hi there Martin,

Got a message from Golden to assist you and thanks for providing us additional info.

Have you checked the IE 11 proxy setting, make sure that it's not using any proxy at all? You may reset it by following this guide.
We can try changing the DNS to Public by using the Google DNS servers if you have not done this yet.
DNS Servers . . . . . . . . . . . :
IE 11 can be buggy sometimes, although those sites that you're trying to access works in another computer. At work, we use different versions of IE, also Chrome and FF as other sites won't work using one particular browser.

If assigning Public DNS didn't cure your issue, you may downgrade the IE 11 to the previous versions if you wish. One thing you'll have to be aware of..... set your Windows Updates on not to automatically download but.... you may choose what you wanted to download then install.

Hope this helps and we'll appreciate another update.

My System SpecsSystem Spec
15 Sep 2014   #5

Win 7 Professional 32-bit SP1

Hello Ray, many thanks for your input - here's an update on what I've just tried.

Firstly, something else I forgot to mention in the earlier posts was that I had tried flushing the DNS cache (ipconfig /flushdns), with no effect.

I've just tried setting the IPv4 properties to use my ISP's DNS servers ( preferred and alternate), again with no effect - neither IE 11 nor the Macrium Reflect updater work - so I've gone back to getting the DNS server address automatically, ie. from the router.

I've done a full reset on IE 11 and there are definitely no proxies configured, and it still sits waiting for a response from the URL it's trying to connect to, so that's not the source of the problem.

It seems to me that the problem I've got isn't at the network link layer but it's more at the session layer or higher - there's something somewhere that's preventing certain apps, not only IE 11 and the Macrium Reflect updater but also the Adobe online installers, from being able to connect to and communicate correctly with the distant hosts even though other apps, including Firefox and the puTTY telnet client, exactly just as they should. However, I have no idea where to start looking for where such session-layer problems might reside or how to overcome them!

Keep the suggestions coming!

My System SpecsSystem Spec
15 Sep 2014   #6

Win7 & Win8 64bit

I would still give a try using Google's DNS servers and not your ISPs, it won't hurt.
I've just tried setting the IPv4 properties to use my ISP's DNS servers ( preferred and alternate)
Also, will you also consider to downgrade to IE10?
My System SpecsSystem Spec
15 Sep 2014   #7

Win 7 Professional 32-bit SP1

Hello again Ray, I've just tried using the Google DNS servers ( and and it made no difference whatsoever - neither IE 11 nor the Macrium Reflect updater seem to be able to connect to the Internet.

I would happily use IE 10, but as I said in my original post I only very infrequently need to use IE at all so the version isn't a major issue - in fact I would probably prefer an even older version!

What matters much more to me is the inability of installers and updaters such as the ones for the Adobe Reader and Flash Player apps and Macrium Reflect to connect to the appropriate distant hosts - that will be a significant issue, especially with regard to ensuring that updates can be downloaded and installed as and when they're released.

I've just run the CCleaner app and done a registry scan; it didn't find anything that needed cleaning up. Interestingly, when I told the app to check for updates it did so immediately and reported back that I already have the latest version, so whatever's blocking the accesses from IE 11 and Macrium Reflect to the Internet doesn't seem to have afflicted the CCleaner app.

My System SpecsSystem Spec
15 Sep 2014   #8

Win7 & Win8 64bit

Thanks for giving that a try Martin.

Do you have the latest Windows Updates? or, can you try doing manual WU?

Have you also tried uninstalling IE 11 then reinstall it?

Another experiment - See if it makes any difference if you're booted on Safe Made with Networking (restart your computer, continue tapping F8 then select this option).
My System SpecsSystem Spec
15 Sep 2014   #9

Windows 7 Pro 32

Don't know if Comodo has a specific uninstall tool. Normal uninstalls does not always work. I've seen strange problems because of this. Check your network properties for a firewall driver:

And you could enable logging for Windows Firewall, then start the programs that have connection problems and check out the logs.
Enable or Disable the Windows Firewall Log
My System SpecsSystem Spec
16 Sep 2014   #10

Win 7 Professional 32-bit SP1

Hello again Ray, and hello for the first time Tookeri. Thanks to you both for your ongoing interest in my problems. Herewith an update on what I've tried recently, but firstly to answer Ray's questions:

1. Yes, my installation of Win7 Pro is fully up to date.

2. Yes, I've tried uninstalling IE 11, through Add/remove Windows components, and then re-installing it - this had no effect in that a fresh install of IE 11 behaved in the same way as an earlier one.

3. Yes, I've tried Safe mode with networking again to no effect - IE 11 and the updater(s) still didn't connect to the Internet.

Tookeri's reference to the Comodo uninstaller has reminded me that I did have issues uninstalling the firewall a couple of days ago - I think I used the Revo Uninstaller app to try to get rid of the Comodo installation. If I recall correctly, Revo firstly initiated Comodo's own uninstaller which ran but then seemed to hang without completing successfully so eventually I had to revert to killing off the apps and processes using Task Manager.

Also, I did find a Comodo firewall driver in the network properties - it presumably got left there when the uninstall failed to complete fully - so I got rid of that.

I have enabled Windows firewall logging as suggested by Tookeri but for some reason the system won't let me open the logfile even though I'm logged in with administrator privileges - I haven't pursued that fully yet.

This morning I've tried (several times!) re-installing several versions of the Comodo firewall, including one that's several months old and much 'lighter in weight', in the hope that a fresh installation perhaps followed by a successful uninstall would sort out the problems but unfortunately none of the attempted installations has gone through to completion - the files seem to get unpacked and written but eventually the installer hangs at a message about activating the installation - I guess it's trying to call home to Comodo and not getting through. Then, when I try to cancel the installation it juts sits there again doing nothing and after many minutes I have to kill it off using Task Manager - most frustrating and annoying!!!

I've also found that although neither Revo Uninstaller nor the Windows Programs and Features tool show Comodo as being installed, the uninstaller in CCleaner does include it in the list of installed apps. However, when I try to uninstall it via CCleaner it fails.

Even though a CCleaner scan of the registry doesn't report any issues I've fired up 'regedit' and done a search for references to Comodo - there's quite a few left in there so I might try just deleting each and every reference in the registry to Comodo to see if that makes any difference.

I might also try installing a different firewall - several years ago I used the free version of ZoneAlarm and was generally happy with it but changed to Comodo because it was reviewed as being 'better' so I might see if ZA will install correctly and cure the problems.

If my registry cleaning and/or the installation of ZA don't help then it looks like I'm going to have to completely zap the existing Win7 installation and start again from scratch, which will be a bind and quite time-consuming but quite cathartic in a way! If I have to resort to that, then as soon as I've got a clean installation of Win7 Pro with all the Dell-specific drivers plus a few essential apps installed (but not the Comodo firewall!) I'll take an image of it so that I can easily and quickly get back to that point in the event of future hassles.

It's worth remembering that I've had the problem of IE 11 and the various installers/updaters apparently not connecting to the Internet both with and without the Comodo firewall installed, so the problem has existed for much of the time since I did the completely-clean Win7 installation in early August - the Comodo firewall was one of the first apps I installed after the O/S and although, as far as I can recall, it seemed to install correctly I'm beginning to wonder if something odd did happen at that time that resulted in, for example, the Adobe online installers not working when I first tried to use them.

Watch this space...

My System SpecsSystem Spec

 Some apps unable to access the Internet

Thread Tools

Similar help and support threads
Thread Forum
Connected to wifi network but unable to access internet
Hello guys! I have bought this asus-x200ca-kx219d laptop and installed genuine windows 7 in it. Am able to connect to the wifi network in our hostel but unable to access internet. There is that yellow triangle thing on the signal. It keeps saying "unidentified network no internet access. I have...
Network & Sharing
Unable to access internet site in command prompt.
Hi All, I am facing a strange situation in one my windows 7 PC. The PC is under corporate network as well as corporate control. So all the access are restricted. I am trying to access this below internet site, in various ways; such as browser and command prompt(application). URL :...
Network & Sharing
VMware Player 4.0 - unable to access internet
VMware Player 4.0 installed easily under Win 7 Home. Win XP Pro also installed easily but won't allow internet access. Err msg suggests DNS error or server problem (altho i tried several different websites). Since i'm a newbie to VMware is there: (1) a simple fix ? (2) a checklist i can...
unable to access radio shows on the Internet
OS Windows 7, anti-virus is Avast, Broadband for Internet. Windows 7 updates are current. I used to listen to two radio shows via their programs website. All of a sudden I can't connect to the audio. I can connect with a radio station to listen to the programs, but since I subscribe to the...
Browsers & Mail
Internet shows connected but unable to access Internet
A warning in advance: this is going to be a fairly long post. I don't know a ton about troubleshooting but I'm not computer illiterate and I've tried quite an array of tests while trying to fix things on my own. First of all my laptop is an: HP Presario V6000(GB115AV) I'm running windows 7, I...
Network & Sharing
Unable to access internet
I just upgraded from Win Vista Ultimate to Win 7 Enterprise on a Dell Latitude XT. After the upgrade, I can connect to the network wirelessly and in the Network and Sharing center, it shows that I have full connectivity to the internet. However, I can't connect to anything outside of our office....
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:29.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App