Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cannot connect to the Internet. Diagnostic Policy Service not start.

03 Oct 2014   #11

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1

Quote   Quote: Originally Posted by Kaktussoft View Post
Quote   Quote: Originally Posted by Flashphan View Post
First time posting. Running an Asus Notebook U50F Series with Windows 7 Home Premium, 64 bit, 2 Gig processor w/ 4 GB RAM.

I lost the ability to connect to my wireless router or to connect via an Ethernet cable connected to the router. Other devices can connect wirelessly and hard wired so not a router issue. Traveling and have the same experience with a different router and network.

Getting error message when attempting to use Windows Troubleshooter:
"Windows could not start the Diagnostic Policy Service on Local Computer
Error 5: Access is denied"

Unable to pull an IP address nor release or renew via an ipconfig command prompt.

What should I be doing? Thanks
Run regedit and browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\DPS
screenshot please
screenshot please
screenshot please

Right click on the first key, click permissions. click Advanced. Now make screenshot
Do the same for the other 2 registry keys.
most likeliy this was not correct (wrong permissions).

My System SpecsSystem Spec
09 Oct 2015   #12

Windows 7

Thank you so much! It worked
My System SpecsSystem Spec
03 Feb 2016   #13

NOTHING works but this.....

After trying EVERYTHING on the net to fix this Error 5 Diagnostic Policy Service and try to get it to start, I gave up and UPGRADED Vista to Windows 7. Even that, by itself did not do it, but I believe it uncovered the true problem.

To get this working, I believe in Vista, (not verified since I upgraded to W7), you MUST disable .Net FrameWork 3.5 in the "Turn Windows features on or off", reboot and then either install .Net FrameWork 4.5 or fix .Net FrameWork 3.5 Reboot. Then try network diagnostics again, and if necessary, turn on the DPS service. I will bet you this will really solve this problem. If you verify, in Vista, please reply to this post so that I will know.

If your Vista system previously had NO internet connection (may or may not connect but not work in the browser) then this was fixed for me under Vista by:
opening an elevated command box and executing these two commands:

net localgroup Administrators /add networkservice
net localgroup Administrators /add localservice

also, just in case, clear your winsock with:

netsh winsock reset

netsh winsock reset catalog

netsh int ip reset reset.log

Then rebooting.

I believe all this is caused by some sort of virus or program modifying (and thus breaking) this function in the Vista registry.

Good Luck.
My System SpecsSystem Spec


 Cannot connect to the Internet. Diagnostic Policy Service not start.

Thread Tools

Similar help and support threads
Thread Forum
Can't run Diagnostic Policy Service because of Error 5
This started happening when I accidentally turned off my computer whilst it was booting. I have tried sfc /scannow, I have done the CMD thing (net localgroup Administrator) and have tried manually starting the service, to no avail. Here is a screenshot of what I think appears to be the...
Performance & Maintenance
Diagnostics policy service won't start - Connected, but no internet
For some reason my laptop does not connect to my wireless network. It says I have "limited access." I tried troubleshooting as administrator and it says diagnostics policy service will not start. All other gadgets in the home work. I have tried so many methods to fix this and I just cannot find any...
Network & Sharing
Unable to connect to Internet-diagnostic policy service off
Background: several weeks ago laptop stopped connecting with internet. Troubleshooter said that the Diagnostic Policy Service was off. Went to admin>services> diagnostic Policy service, no joy, already set in automatic. (Error 5) At the time the laptop stopped connecting the free microsoft...
Network & Sharing
Unable to connect to internet; diagnostic policy service not running?
Hey everyone, if anyone could provide any information on this issue, i'd greatly appreciate it. My mom's laptop is detecting that our wireless internet connection is active, but it won't actually connect to the internet. When we troubleshoot the issue, it says that our diagnostic policy service...
Network & Sharing
Diagnostic Policy Service cannot be started
I've searched the forum but most error text is different. Mine is simple.. It says I've tried multiple things however I cant get it fixed.. I tried system restore but system restore took 4 days and SURPRISINGLY, the restore failed.. I am planning to do system image restore.. Any help will...
General Discussion
Cannot start diagnostic policy service
i tried to diagnose my internet connection, and it informed me that the diagnostic policy service was not running. so i went over to services.msc right clicked the diagnostic policy service and got the following error: im at loss |:
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:46.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App