Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: RPC Unavailable

11 Nov 2014   #1

MS DOS 6.21, Win 2K, Win XP & Windows 7
RPC Unavailable

I've had a laptop running Windows XP networked to a PC running Windows 7 for a year or more. I've never been able to get the network completely functional. But up until this morning I was always able to send files from the laptop to the printer connected to the PC.

This morning, however, when I tried to print a file from my laptop I got a dialogue box asking for a password. But I have no password on the Win 7 computer. And I've never had to enter one before.

So as a troubleshooting step I tried to print a file directly from the Win 7 computer, but I got an error message saying the "RPC" is unavailable.

I looked at the RPC in "My Computer" (which of course Win 7 had hidden
and I had to play hide and seek to find) it showed the RPC as "started."

I'd be grateful for some help trying to get the network back to the way it was (sort of) working before this morning, so that I can resume printing from my laptop.

Will in Seattle
a.k.a. "Clueless"

My System SpecsSystem Spec
11 Nov 2014   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1

The dialogue shows (most likely) much more info. does it display/ask for a username? Does it display a sharename?
Best thing to do is.... make a screenshot and post it.
My System SpecsSystem Spec
12 Nov 2014   #3

MS DOS 6.21, Win 2K, Win XP & Windows 7
PC mysteriously lost from network

Quote   Quote: Originally Posted by Kaktussoft View Post
The dialogue shows (most likely) much more info. does it display/ask for a username? Does it display a sharename?
Best thing to do is.... make a screenshot and post it.
Hi Kaktussoft!

Before we go any further, I need to update you on a change in the problem. The "RPC unavailable" error cleared itself up without any help from me. So I'm again able to print from the PC directly to the printer which is plugged into the PC running Windows 7.

That leaves the problem of trying to figure out how to restore the connection between the networked laptop running Windows XP and the printer connected to the PC running Windows 7.

(I have to confess that yesterday while trying to solve this problem on my own I fiddled around with usernames and passwords, to see if I could come up with combination that might solve the problem. But I was clearly out of my depth. So I may have made the problem worse by messing around while not really having any idea what I was doing).

So, here's a recap of the problem as it stands now:
1. I used to be able to send files from my networked laptop (XP) to the printer connected to my PC (Win 7) without having to enter a user name or a password. I would just click "print", and then I would hear the whirring sound of the printer in the next room where the PC is installed.

2. Then, yesterday, for the first time, when I clicked "Print" on the laptop, I got an error message in the printer queue. Here's a screen shot of what that error looked like ( I just repeated the operation in order to get a screen shot):
RPC Unavailable-printer-queue-error-message.jpg

3. I suspected that I got the printing error because of a problem with the network connection between the laptop and the PC, so I went to Windows Explorer on the laptop, and under networking I clicked on the PC. That's when this box popped up (BTW, the PC's name is "Bob," the name of the previous owner):
RPC Unavailable-connect-bob-blank-prompt-box.jpg

That's another thing that never used to happen. Prior to yesterday morning, from the laptop I was able to just click on the PC under Windows Explorer Networking, and I could see nearly all the files on the PC. (I could even open them and edit them on the laptop, but I was blocked from saving the edited files back to the PC. I would have to save them to the laptop, then go to the PC and manually copy them over from the laptop). So I had a partially functional but awkward network.

But now I've lost two functions of that network:
1. The ability to print from the laptop to the printer connected to the PC

2. The ability access files on the PC from the laptop
I have no recollection of having changed any settings prior to yesterday morning that would account for my being blocked from printing and accessing files from the laptop (But then I'm suffering from worsening memory problems due to aging and side effects of medications).

I should also mention that both computers are hand-me-downs that had Windows already installed by the previous owners. So I have no idea how either of them is configured.

Will in Seattle
a.k.a. "Clueless"

My System SpecsSystem Spec

17 Nov 2014   #4

MS DOS 6.21, Win 2K, Win XP & Windows 7

Hi again! I'd sure be grateful for some help in figuring out how to restore network access to my little laptop. The odd thing is that I can access the laptop's files from my PC without any problems, no password required. But going the other way, i.e., trying to access the PC from the laptop, I get that danged box asking for a "User name" and "Password." I never had to enter that before, so I haven't a clue what to type in.

I'm disabled by chronic illnesses that make it difficult to sit upright at my PC, so I need to be able to work from bed using the laptop.
My System SpecsSystem Spec
22 Nov 2014   #5

MS DOS 6.21, Win 2K, Win XP & Windows 7

Yesterday I managed to solve the printing problem (thanks to the help of my doctor who prescribed a cocktail of meds to counteract the pain, fatigue and brain fog, which had been preventing me from sitting up at my PC for the last year or more).

I hunted around a while and after following a bunch of false leads and dead ends I came across this:

Start>Settings>Control Panel>Networking and Sharing Center>Password protected sharing:

RPC Unavailable-turn-off-password-protected-sharing.jpg

Somehow or other, the password protected sharing feature had turned itself on in the background. I haven't a clue how that happened, but it was simple enough to just check the other radio button. Then I went to the laptop at my daybed in the other room and tried to send a file to the printer which is connected to the PC, and voilą! Problem solved!

So that gets me back to the state I was in before the printer went to la-la-land, to wit: my network between my PC running Win7 and the laptop running XP Home is still broken:

From the laptop I'm able to open and edit files from the PC, but when I try to save them back to the PC I get an error message saying:

"You do not have access to the folder '\\Bob\Desktop on Bob'. See your administrator for access to this folder."

I'd be grateful to anyone reading this if you could take a look at my other thread where that problem is still up in the air:
Win 7/XP network: "You do not have access to the folder...."
Will in Seattle
a.k.a. "Clueless"

My System SpecsSystem Spec

 RPC Unavailable

Thread Tools

Similar help and support threads
Thread Forum
503 Service Unavailable
Hi there, I have been getting this message using IE and Chrome. It happens most often when I right-click and chose New Tab on a link within a website. Refresh usually has no effect. I wonder what your thoughts are. Thanks, Paul.
Browsers & Mail
Hotmail Unavailable.
Microsoft reports that "The Service is unavailable." I have tried to access my Hotmail account in FF and IE9, no success. Anyone else having this problem, or is it just the UK? Or even just me?
Browsers & Mail
WIN7 SP1 - unavailable?
Hi I have been putting off updating to SP1. Religiously did not tick it when I did any important or optional updates. Ran WINVER today. I am on Version 6.1 Build 7600. SP1 is NOT showing up as an important or optional update anymore. I have NOT hidden it. Is it no longer available?
Windows Updates & Activation
<Quote> is currently unavailable
When opening the Desktop in Windows Explorer I get the following error along with my data: " is currently unavailable. Screenshot attached. Suggestions welcome.
General Discussion
internet tv is currently unavailable
I search this forum and on the net, just can't find an answer. I have a new pc running win 7 pro. for the first couple of weeks internet tv worked fine. I am in the USA. Now I get a screen that says: " Internet tv is currently unavialbe. please try again later an error occured loading...
Media Center

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:55.
Twitter Facebook Google+