Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Error: Windows cannot set up a homegroup on this computer

26 Nov 2014   #1

Win 7 Ultimate 32bit
Error: Windows cannot set up a homegroup on this computer

Ok folks, been researching this issue for quite a while now and am having now luck.

Win 7 Ultimate, 32bit. SP1

I simply cannot not get a HomeGroup to be created on my main system. These are the steps I have gone through:

1. Deleted all files from the following directory: C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking
2. Verified that Discovery is enabled: Enable or disable network discovery - Windows Help
3. Verified the following services are running (from:
DNS Client service started and on automatic
SSDP Discovery service started and on automatic
UPnP Device Host service started and on automatic
Function Discovery Resource Publication service started and on automatic
4. Tried to run the "fix it" executable (from: Why can't I create a homegroup?) - but got an error that it has either expired or the name was changed and therefore won't run. Must be out of date/expired because I didn't change the name.
5. Verified the additional services outlined at the bottom of the link in #4 are started/enabled.

My system reads "Home Network" and "HomeGroup: Ready To Create" - when I click "ready to create" it brings up the "Create a HomeGroup" window that allows me to select what I want to share (ie: Pictures, Music, Videos, Documents, Printers). I click next and get the error: Windows cannot set up a homegroup on this computer.

At my wits end here. The closest I got to getting a home group was with my mother's computer, which is Windows 7 Home Edition (and technically not allowed to 'create' a homegroup). I was somehow able to add a password to her HomeGroup and after doing that my computer would allow me to join her HomeGroup.

At that point, I forced her system to leave the HomeGroup...and forced all other systems on my home network to leave their HomeGroups and then I powered off all those system. On my main system I forced it to leave her HomeGroup - verified all the steps above #1 thru #5 and rebooted. The system came up clean, with internet connection working, indicating I was not a part of HomeGroup and giving the option to Create which time I did (yet again), and again got the above error.

(FYI - I forced her system and all my other systems off of her HomeGroup (or whatever group they were a part of - because she doesn't life here and will be taking her system with her when she leaves for the holidays).

Currently, the ONLY system on in my house is my main computer and it won't let me create the HomeGroup from my main system.

Desp for help here...pulling my hair out.

My System SpecsSystem Spec
26 Nov 2014   #2
Not Myself

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

No way of knowing if this will assist, only that it did for me: Installed a new computer and transferred programs and files from the old machine to the new one. Homegroup from the older computer was transferred to the new one.

I then tried several ways to get my computer to recognize the HG on the new machine, none of which worked, getting errors such as yours. I then deleted the old, transferred, Homegroup from the new computer, whereupon I was able to create a new homegroup on both computers.

I suspect that this problem was caused by my failure to perform the magic incantation that starts Phol ende uuodan uuorun zi holza, "Phol and Wodan were riding to the wood". (That is from the Second Merseburg Charm, with which, of course, you are quite familiar.)
My System SpecsSystem Spec
26 Nov 2014   #3

Win 7 Ultimate 32bit

Not Myself,

Thanks for the additional spell. I did try a few of my own and now yours...all with no luck. At this point looking for something more technical and concrete - but thanks for the input.
My System SpecsSystem Spec


 Error: Windows cannot set up a homegroup on this computer

Thread Tools

Similar help and support threads
Thread Forum
This computer can't connect to a homegroup. Homegroup is not ready yet
This homegroup issue is giving me a headache. I've been trying to fix it for a day and a half now on this website and others. I have a PC connected via Ethernet cable and a laptop connected wirelessly. I am trying to join a homegroup I created today on the laptop. However, I previously (years...
Network & Sharing
Windows cannot set up a homegroup on this computer - no error code
Hi guys, So sometime within the last month or so I noticed my laptop was starting to act funny when trying to access files over the homegroup on my desktop--it was asking me for my credentials every time I restarted the computer, and wouldn't remember them even when I checked the box. As best I...
Network & Sharing
Unable to join homegroup, homegroup creating computer is no more
The computer that originally created the homegroup on my network is no more. It seems that because of this that my new computer is unavailable to join the homegroup that already exists. Other computers that were part of the homegroup before the "host" computer died are still part of the homegroup...
Network & Sharing
Leave Windows 7 Homegroup, Cannot leave homegroup from broken computer
HI everyone, We finally have all computers in the house running widows 7 and would like to set up a homegroup. The problem is a homegroup was set up a few years ago on a laptop, and that laptop is no longer functioning (fried motherboard) as I understand the only way to delete the homegroup is...
Network & Sharing
Homegroup encountered an error / This computer cannot join a homegroup
I get a "Homegroup encountered an error" message when I try to join my laptop and desktop to a homegroup. It does not matter which one sets it up and which one tries to join. It errors in either direction. I have tried leaving and creating, no use. The desktop is wired to a Belkin 300N router and...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:30.
Twitter Facebook Google+