Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Local Area Connection doesn'thave a valid IP configuation

01 Dec 2014   #21

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Quote   Quote: Originally Posted by roybman View Post
To be honest, I'm not sure what the Marvel Link Aggregation Protocol and Marvel VLAN Protocol are. They were added when I updated the driver. That said, they were not there when the issue started. I updated the driver, they appeared upon that update, and I still had the same issue.
Updated WHAT driver, after which they appeared?

Here's a relatively extreme experiment you might try, assuming you have the ability to take a quick "system image" backup from the problem machine, of your C-partition and "system reserved" partition to an external USB 3.0 drive (say which you're already currently using for your own regular backups on some machine in your home LAN) using Macrium Reflect Free, and also have a usable Win7 installation DVD and valid license product key. It'll only take 5-10 minutes to take the backup, and less than another hour to do a Win7 reinstall from scratch.

Then see if the newly installed Win7 can properly connect to your router and get to the Internet. You don't even need to do the Windows updates yet to test out the theory.

If you still can't get to the Internet or see the router or get an IP address, then there's probably some hardware explanation.

If however you now CAN get to the Internet and get an IP address from the router, well it's clearly some software problem in your old system. Don't know what, but sometimes starting from scratch is the only way to resolve these mysteries. Sometimes the OS needs a fresh install every few years, to get past anomalies like this which are software-based.

Worst case, your PC is currently unusable since it needs to get to the Internet to be usable for your mother. You can easily restore the "system image" with Macrium Reflect (erasing that experimental Win7 you just quickly tried) and you're back to where you started... no harm, no foul, and no better off.

The fact that you've tried the built-in Realtek PCIe NIC as well as the add-on card NIC and they both have failed identically, well my guess is that this is pointing to a true Windows-based corruption (or other software we're not aware of) of some kind that is responsible, and which unless we can find it, fix it, or uninstall it, we'll never resolve it.

Won't take you much time to try a fresh reinstall of Win7 from scratch if you have the tools, just to see if the problem disappears or remains. Seems like we're now at that extreme point.

My System SpecsSystem Spec
01 Dec 2014   #22

Windows 7

To answer your last question, they appeared after updating the driver for the Realtek NIC.
Thanks for the input. I agree, I've hit the wall on this. I'll post after I've had a chance to reinstall Win7.
My System SpecsSystem Spec
04 Dec 2014   #23

Windows 7

Just as a final update, reinstalling the OS resolve the issue. I'll never know what specifically went wrong, but at least it's fixed. Thanks again for your help.
My System SpecsSystem Spec

04 Dec 2014   #24

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Quote   Quote: Originally Posted by roybman View Post
Just as a final update, reinstalling the OS resolve the issue. I'll never know what specifically went wrong, but at least it's fixed.
Well, you emerged victorious! And that's what's important.

Sometimes the "detritus" in an operational system accumulates over time to where it just begins to act strangely and inexplicably, and can just never be overcome no matter how smart we are. We all know it's bound to be caused by some kind of corruption to the Registry, or maybe some malware or virus that crept in over time that we never noticed, or some junk that got installed along with some vendor product we installed and foolishly forgot to take the "custom install" path to un-check all the garbage which otherwise would get installed, etc.

Whatever the history and explanation, at some point there simply seems to be no actual "fix" or "solution", other than to reinstall Windows from scratch and then reinstall all of your vendor software and customizations. Or, maybe go back to a "gold" backup you took in order to save 3-4 days of installation from scratch.

With WinXP that time frame was very commonly 6 months to a year, before it just got slower and slower and nothing we could do could fix it. With Win7 that time frame really has increased, and it's not really unusual to go 1-2 years between self-justifying a full reinstall from scratch.

But sometimes it's clearly called for, or at least worth the experiment to see if the mysterious problems all magically disappear as they almost always do (unless you've actually been chasing a hardware problem). In your current story, that appears to be what was required.

Anyway, glad you finally got this all sorted out... even if it took the extreme solution of a reinstall of Windows.
My System SpecsSystem Spec

 Local Area Connection doesn'thave a valid IP configuation

Thread Tools

Similar help and support threads
Thread Forum
Local Area Connection doesn't have a valid IP configuration
I get the error "Local Area Connection" doesn't have a valid IP configuration in Windows 7.This is my desktop computer and is a direct connect to my broadband modem. All of my wireless connections are working. I have had Comcast out and there is no problem with the modem. This started on Jan 3, 16....
Network & Sharing
WHYY!!! local area connection doesn't have a valid
So I had recently had Internet service installed at my house and had to return everything because of this issue. I had an emachine e528 running on Windows 7 64 bit. After installation I had changed the name of my network and the next night it all cut out. I've been searching and searching and came...
Network & Sharing
local area connection doesn't have a valid ip configuration
I have re-install the network adapters,it is work but when I reboot the computer , it can not access the network what should i do?
Network & Sharing
Local Area Connection doesn't have valid IP configuration
Guys, I really need your help. I got a new laptop a couple days ago. It was for work so I brought it to the office. We have an open network in the office, you just need to plug into it with a regular cable. We've had it for years and it always worked. Not this time. When I'd first plugged it,...
Network & Sharing
Local Area Connection doesn't have a valid IP
one day about 2 weeks ago, my net stopped working just randomly. I get the error 'Local Area Connection doesn't have a valid IP' when i try to use the router, and some 'unidentified network' shows up, i cannot connect to it. I reset everything and unplugged everything but couldnt get it to...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:05.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App