Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 100mbs speed limit on a Gigabit network to a iSCSI SAN.

23 Dec 2014   #1

windows 7 Ultimate 64bit
100mbs speed limit on a Gigabit network to a iSCSI SAN.

Hi Guys,

I haven't been on this forum until now.

I have a Equallogic PS400 SAN, connected to a Powerconnect 6248 gigbit switch. Everything runs FINE on 2k8 server, Windows 2012r2 and VMware ESXi 5.1.

I created a iSCSI target for my wifes new pc which is based on a Gigbabyte MB, Gigabyte-970a-ud3, with a AMD FX-6100 hexacore CPU 4.2 Ghz , 16gGB DDR3 ram. Boot disks are a pair of SSD 240GB drives striped for even more speed.

Local storage is 4 2TB WD sata3( 6gbs) disks in a stripe for speed. I added a PCIe expansion card for a extra pair of 2TB disks (software striped) also SataIII (6gbs sec)
The network is a quad port Intel vt-100 server class nic. I have NO latency or retransmits on the network, Flow control is on and set up per Equallogic best practices.

There is 2.7 TB of movie ISO's on the 2TB stripe i want to move off to an iSCSI 6TB volume on my san.

Got it?

Here is the kicker , I can easlily move the data from the 2TB stripe to the 8TB stripe using robocopy, teracopy , etc. and it hauls butt and i get 120MB/ sec internal to internal SATA.
Theorectically (and in practice as i have a 2k8 server and 2012 server) i should be able to get 125MBs/ sec on my iSCSI san. I can never get anything more than 12.5MBs / Sec to the iSCSI target, the network transfer maxes out at 100mbs period. No matter what I do , the max network transfer of copying files is 100mbs and 12.5MBs from the windows 7 box. All of my other systems easily get the 100MBs /sec . I read that the issue is a QOS issue with Windows 7 (all of them) I'm running Windows 7 Ultimate 64 bit. I can run IOmeter on the nics to the iscsi target and easily get the 250mbs I would expect. Whenever I try to copy data from either internal stripe to the iSCSI target , it Max's out @ 100mbs and 12.5MBs .

From looking into it more it sounds like a QOS issue with Windows 7 network speed limit. I setup a QOS policy to allow iSCSI port 3260 to have a limit of 600gbs. Still no change , 100mbs / 12.5MBs..

Any ideas?

Thanks in advance


My System SpecsSystem Spec
24 Dec 2014   #2

windows 7 Ultimate 64bit

Can one of the mods move this to the performance thread. Its not a network or sharing issue.Its a performance QOS issue.
My System SpecsSystem Spec
21 Jan 2016   #3

7 ultimate 64-bit

I'm having this same issue, I've ghosted a windows 7 64-bit install from a drive to an ISCSI lun. Works perfectly except that actual disk access never goes above 100mbit/s on Gigabit link. Were you able to find any solution?
My System SpecsSystem Spec


 100mbs speed limit on a Gigabit network to a iSCSI SAN.

Thread Tools

Similar help and support threads
Thread Forum
Low ethernet speed on Gigabit-capable network cards
I recently bought a Belkin 2m cat5e crossover cable to connect my desktop to my D530 laptop, in the hopes that it would be a faster way for me to directly transfer data between the two. The desktop's ethernet card is a Realtek PCIe FE Family Controller (model no. RTL8167), and the D530's is a...
Network & Sharing
Can't get gigabit speed in Win7
I have a GA-X58A-UD3R motherboard connected to a netgear gigabit switch. When I boot into Ubuntu 14.04 the switch light turns green. In windows 7 it's yellow and looking into network connections it says 100 megs not 1000. I think it used to be green before I installed Oracle Virtual box but I'm...
Network & Sharing
Gigabit port speed
Hi all, I have a 100/25 Mbps fiber optic connection with a Technicolor TG784n v3 router and I'm having problems with the speed on the Gigabit port. When I turn the computer off or restart it the speed drops to 50 Mbps. If I connect the PC to one of the other 100 Mbps ports the speed returns to...
Network & Sharing
Gigabit Network Speed Question
I have a desktop workstation with an intel xeon 2.53ghz and 4gb of ddr3 ram, it has a broadcom netxtreme 57xx gigabit controller, and i have an Iomega home media drive, also a gigabit switch. I have my computer connected to the switch and the NAS to the switch as well, all using CAT6 cable....
Network & Sharing
Gigabit nic stuck at 100mbps in Gigabit network.
Cannot get gigabit performance out of Nics in Win 7.. Locked 100 mbps. My motherboard is an Evga 590 Sli Am2 motherboard, with dual gigabit nics. Having established that there is really no benefit to using both nics at the same time in another post, I am now posting because it seems I am only...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:08.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App