Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Media Streaming no longer working after printer drivers were removed

26 Dec 2014   #1

Windows 10 Pro
Media Streaming no longer working after printer drivers were removed

Hello forum users,

I tried to be as precise in the title as possible.

I've got a bit of an issue here and normally I wouldn't bother the forum with my questions unless its something I just can not figure out on my own. Google search hasn't been much help on the issue either.

First off I'll just explain what the problem is. A couple of days ago I got a used HP printer from a friend of mine and I installed the HP drivers package from the website. Thinking this was better than just using the CD to manually install the drivers from Device Manager. Well it turned out that the downloaded drivers were not good. Way to many extra processes running just to provide seemingly unnecessary functions. Such as ink level checking, device stage actions, the built in printer touch functions and auto updating nonsense, just to name a few. So I removed it with Revo uninstaller using the advanced scan and it took out the software and found 1000's of registry entries.

Unfortunately I didn't think to backup the registry or make a system restore point. There are no system restore points and the damage to the registry seems unfixable, or rather I simply don't know what was damaged or where to look for the right options to restore "WMPNetworkSVC".

At first nothing seemed wrong, the system boots up and runs fine but the one main problem I have noticed is that I can no longer stream video to my Win 7 x64 laptop. Homegroup works and I can see the system on either side. So the problem is only with the media streaming options. On the laptop when I check that option in WMP it shows a list of systems and options that can be changed to show which PC's are allowed or denied access, but on the problematic desktop WMP options it only shows a notification area with a button telling me to turn on media streaming.

Which I have tried to do unsuccessfully over and over again after trying things like SFC /scan now, attempted to start the service but it just says, "The Windows Media Player Network Sharing Service service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs"

Which is not helpful at all, its supposed to be running and is set for Automatic Delayed startup in the properties. Research on the topic says its something to do with DCOM or UPnP. UPnP's service is enabled and the service is running, which leads me to think this is a direct consequence of the unknown changes that were made to the registry by Revo when it was removing the HP garbage. It must have took out useful keys/values related to WMPnSS thinking it was part of HP's wireless printing.

I have since reviewed and fixed all but these two error messages in the Event Viewer. Perhaps this will help a more knowledgeable person figure out where to guide me as the info they provide is to vague to be of any use to me on its own.

Copy/Paste below:

Event 219, Kernel-PnP

General: The driver \Driver\WUDFRd failed to load for the device USB\VID_05AC&PID_1294\e28ea1a908db57498f58e67a5f7a37a2dfb9b287.

Event 14332, Windows Media Player Network Sharing Service

General: Service 'WMPNetworkSvc' did not start correctly because CoCreateInstance(CLSID_UPnPDeviceFinder) encountered error '0x8002801d'. Verify that the UPnPHost service is running and that the UPnPHost component of Windows is installed properly.

The first entry Event 219 I think is from the system not being configured by the HP software for the printers wireless connection. I don't have to have this and don't mind if it remains attached by it wire. It's one reason I got rid of the HP software and ended up using the CD to update the drivers from Device Manager the second round. The printer works now by the way without the HP BS software via its wire.

The second Event 14332 seems to be the issue behind why media streaming refuses to enable when I command it to. The only dependency that is shown to be necessary for WMPNss to run in services is simply called HTTP. Which is a "system component" and I do not know how to tell if its installed correctly or if its even running. I assume it is as I am using the PC to type this up on. There was an event related to DCOM but using another threads instructions I was able to use Component Services to fix that event. Still media steaming won't enable and neither will the WMPNss.

What am I missing or doing wrong? Are there any options to manually modify the registry or manually reinstall/repair the UPnPHost service or to reinstall the UPnPHost components. I checked Windows features but no such feature appears to exist.

If more information is necessary just let me know what you need, thank you.

My System SpecsSystem Spec
28 Dec 2014   #2

Windows 10 Pro

Well based on the lack of replies I have clearly destroyed the media streaming function, thanks anyway.
My System SpecsSystem Spec
04 Feb 2015   #3

Windows 10 Pro

Lesson learned, there ultimately was not an easy fix for my particular problem. A reinstall of Windows was necessary to fix the issue.

To anyone who reads this, I'm simply answering my own thread in case other individuals out there do something similar. If you use Revo Uninstaller don't be a fool like I was and not allow Revo to make a registry backup and system restore point. HP Drivers apparently integrate into Windows in a very fundamental way. When I forced removed them with Revo and the program cleared literally 1000's of registry entries it damaged core windows files. SFC was unable to restore them and doing a repair install was to messy. It leaves behind the old Windows folder and lots of write protected things from the corrupted install. So while that may be fine with some users, for me it was an unacceptable patch repair.

The particulars of the problem was that the Windows Firewall system files were damaged or corrupted due to the missing registry keys no longer pointing to the correct files. Even if the files were still present Windows was not able to use them anymore. This had an impact on all programs needing to be allowed to open a port through the firewall, and destroyed Windows 7's Media Streaming options. It wouldn't even turn on.

Anyway that's all I have to say about this topic, the matter is now closed as far as I am concerned.
My System SpecsSystem Spec


 Media Streaming no longer working after printer drivers were removed

Thread Tools

Similar help and support threads
Thread Forum
Media Streaming Using Windows Media Player - Turn On or Off
How to Turn On or Off Media Streaming using Windows Media Player in Windows 7 Media streaming (media sharing) allows you to send your music, pictures, and videos to other computers and devices on your same home or work network. If you have a home network, you can use Windows Media Player (WMP)...
Windows Media player no longer streaming
Hi, I had windows media player set up to be able to stream content(e.g. videos, music, picture etc) from my PC to my T-box. I havnt use this feature in a while and I went to use it last night but my tbox can not pick up my PC. When I go to windows media setting I go: Stream > Turn on media...
Music, Pictures & Video
Printer no longer working on my wirless network
I have been using my Acer aspire 5532 laptop with windows 7 and printing from my hp photosmart all in one c5180 printer via my netgear WGR 614v9 wireless router connected to my desktop with windows xp installed on it just fine for well over a year now. I recently built and replaced my old desktop...
Hardware & Devices
Canon MP530 printer stopped working, no drivers?
About three hours ago I tried printing from Word to my Canon MP530, which has been working just fine since I switched from XP to Win7 in mid-December. I got an error saying that there were no drivers installed. I tried the Windows Update method to reinstall them - that failed. I went to Canon's...
Both WMP and Media Centre no longer working
I posted this in the Music, Pictures & Video forum, but no reply there so thought I'd try here. Edition 2 posts
Media Center

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:20.
Twitter Facebook Google+