Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Diagnostic Policy Service not working

28 Jan 2015   #1

Windows 7 Home Premium 64 Bit
Diagnostic Policy Service not working

Hello All

I am looking for help with a problem I am having with my laptop Dell Inspiron 1545 O/S Windows 7 Home Pemium. It has stopped connecting to the internet through the house wireless router although all other devices in the house can connect. If I try to run troubleshooter I cannot and get a message that the Diagnostic Policy Service is not working.

I have tried to follow answers I have found through Google but without any success. I cannot even restore to an earlier point as the restore fails.

Any advice would be very much appreciated.

My System SpecsSystem Spec
29 Jan 2015   #2

Windows 7 Pro 32bit


Try to hit FN + F2 : just in case you forgot this troubleshooting.
My System SpecsSystem Spec
03 Feb 2015   #3

Win 7 32 bit

You can start the service by doing the following:

a. Click on the "Start" button.
b. Enter "services.msc" in the "Search Programs and Files" box.
c. Right click the Diagnostics Policy Services and click "Start" on the context menu.
My System SpecsSystem Spec


 Diagnostic Policy Service not working

Thread Tools

Similar help and support threads
Thread Forum
Windows Diagnostic Service Policy is not running
Hi as the title above says I am having trouble with the windows diagnostic service policy not running. When trying to fix it using troubleshooting it does not do anything. I have set all 3 diagnostics to automatic as some threads have suggested however when I try to enable the diagnostic service...
General Discussion
Diagnostic Policy Service. Access denied - pls help
Running around in circles for hours trying to resolve this issue. Message is Event ID: 7023 The Diagnostic Policy Service service terminated with the following error: Access is denied. This problem is NOT about accessing the internet, as I am here on the forum posting this. It's about other...
General Discussion
Can't run Diagnostic Policy Service because of Error 5
This started happening when I accidentally turned off my computer whilst it was booting. I have tried sfc /scannow, I have done the CMD thing (net localgroup Administrator) and have tried manually starting the service, to no avail. Here is a screenshot of what I think appears to be the...
Performance & Maintenance
Diagnostic Policy Service cannot be started
I've searched the forum but most error text is different. Mine is simple.. It says I've tried multiple things however I cant get it fixed.. I tried system restore but system restore took 4 days and SURPRISINGLY, the restore failed.. I am planning to do system image restore.. Any help will...
General Discussion
Cannot start diagnostic policy service
i tried to diagnose my internet connection, and it informed me that the diagnostic policy service was not running. so i went over to services.msc right clicked the diagnostic policy service and got the following error: im at loss |:
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:45.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App