Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: FTP in windows explorer works but I can't open files (Windows 7 x64)

31 Mar 2015   #1

Windows 7 ultimate 64bit
FTP in windows explorer works but I can't open files (Windows 7 x64)


I hope I'm putting this in the correct forum.

I have been trying to find out why I am not able to open any ftp files in windows explorer using win 7 x64

I can successfully open an ftp site in w/explorer and browse the folders without any problems, however, I don't get any previews (eg. jpg files) and if I double click on any file that should have an association like a jpg nothing happens (although a short hourglass / activity wheel appears). I have to manually copy the file or drag it out onto a local folder to be able to do this.

I don't remember this kind of restriction the last time I did it although that was some time ago and perhaps on XP but can anyone shed some light on what might be wrong here? I have no such problems via an ftp client but would like to get this quick method working for convenience.

One clue / difference is when I right click > properties on a file, I will get a single 'general' tab that lists filetype, location,size and modified and then a permissions box immediately below with 6 check boxes.
This seems to prove to me that the explorer is not acting as an explorer as it should but is in some other mode. But as I say I can copy files out and into the window.

Just to eliminate a few thing: I have tried this with numerous ftp sites. I have had no such problems when logging in via an explorer app on my Android device.

Any clues would be a great help.

My System SpecsSystem Spec
02 Apr 2015   #2

Windows 7 Ultimate x64

That's the way FTP protocol works, basically. It just allows to list files and upload/download, plus a bunch of extra fuctions, but that's all. It doesn't supports most of the features of normal filesystems that allow to do what you want.

For examples, for previewing JPGs, that would mean that it must download every single file (without user consent) to generate those nasty thumbnails. This could be a potential enormous waste of bandwidth and as such is not supported.

"Opening" a file has also no meaning in a FTP server. What actually clients do there is to download files to a temporary location and open those with local programs. This is what your Android client must be doing.
As for why Explorer doesn't do this? I would begin checking file associations to see if that one works well locally at least.

However, normally, I would suggest a serious FTP client, as Explorer is really poor in this aspect.
My System SpecsSystem Spec

 FTP in windows explorer works but I can't open files (Windows 7 x64)

Thread Tools

Similar help and support threads
Thread Forum
Security Message when trying to open JPG files in Windows Explorer
Firstly apologies if I have posted this query in the wrong section. I am running Windows 7 Home Premium and totally out of the blue I am now faced with a Security Warning every time I try to open a JPG file from within Windows Explorer. Having tried a number of experiments I have noted the...
Windows Explorer closing down whenever I open any files in My Document
Hi all, I'm desperately looking for some help with regards to a Windows Explorer problem. As in the title, Windows Explorer closes down all the time when opening pictures, music or anything in My Docs. I have restored to factory settings from the partition on the HDD and fully updated. The...
Files won't launch from Windows Explorer, but will open within program
I am running Windows Professional 7, and using XP compatiblity mode for most of my programs. It has worked well for 2 years, but all of a sudden I can't double-click to open files from Windows Explorer. I can open the file from the program itself, by using "File->Open", but not from Explorer...
Very slow to open files from windows explorer - ok within application
Sometimes if I open a file by double clicking it in windows explorer, it will sit doing nothing (and that explorer window is then tied up) for a few minutes! Then the file opens normally in the correct application. But opening the application first, and getting it from the file open menu, or...
Performance & Maintenance
Lost abilty to open files with windows explorer
Something weird is going malware or virus according to ESET and Malwarebytes. Windows 7- I have lost the ability to open 'vanilla' file folders with explorer I have also lost the ability to search in the start box..this was posted but was not resolved although thread show it was....anyone...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:55.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App