Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Internet Connection Issue

08 Nov 2009   #1

Windows 7 Professional 64bit
Internet Connection and/or Router issue


This is my first post so thanks for having me!

I recently installed Windows 7 Professional 64bit on my computer. It was running Vista Home Premium. I usually stay away from upgrade discs and always try to purchase the full verison but I purchased the Win7 Upgrade for $30 through a student discount. I couldnt pass up that price.

Anyway, everthing has been great except for one little quirk. When I start up my computer and the desktop loads I do not get an internet connection. If I open IE it tries to open my home page for a long time, then finally gives the Diagnose Conneciton Problems button. If I click on the network icon by the clock in the system tray it will give me one network which is the house icon but it will say "no internet" in blue. Below that is another network with the park bench icon which also says "no internet".

Now, with it in this state I can still click on Start then Network and browse files on my other pc connected to the same router. So, my home network and file sharing is set up and working correctly. The problem is only with my internet connection.

Here is what I have noticed, though. I can go to the device manager, disable my network card, re-enable it, wait a couple of seconds, and then my internet connection is flawless. When I click on the network icon in the system tray it just shows connected to Network with internet access and the home icon. No park bench or second network listed at all. But, the next time I reboot or if I shut down and start up again I have to disable and re-enable the NIC before the internet works.

I did not have this problem in Vista.

Here is what I have done to troubleshoot...
First things first... I updated the drivers for the network card, which by the way, is an integrated Marvell Yukon 88E056 on an Asus P6T Delux motherboard. This particular motherboard has two of those on it which leads me to my next troubleshooting step.

I went to the bios and disabled the extra ethernet port on the board so now device manager only shows one. Same issue. I tried alternating ethernet ports.. disabling the other and re-enabling the first one I disabled in bios. Both ports do the same thing.

I tried updating all of the drivers available from Asus for Windows 7 for this board including chipset and BIOS. I then tried removing the ethernet card totally using command prompt and installing it's drivers manually through command prompt. The driver removal and install worked but the issue presists.

Heres the weird part... As a last resort I tried eleminating the router as a possible cause. I plugged my DSL modem straight into the ethernet port. I rebooted 10 times to test it. The problem goes away when I take the router out of the equasion. The router I am using is a Netgear WGR614 v6. Nothing changed on the router between upgrading from Vista to W7. My other Vista pc and my XP laptop on wifi neither have any issues with internet connections. So, I tried switching ports on the router, power cycling the router and I tried resetting the router to factory settings and reconfiguring it.

I am out of ideas...


My System SpecsSystem Spec
08 Nov 2009   #2

Windows 7 64bit

I have the same mobo and had no problems until i set up my router, I updated the firmware on my router and have no problems since.
My System SpecsSystem Spec
08 Nov 2009   #3

Windows 7 Professional 64bit
router firmware

Thanks for the reply! I didn't think about the router firmware so..

I went to the router config page. Stored a backup copy of my settings. Updated the firmware from Netgear's site. Restored the backup copy of my settings, power cycled the router, rebooted the computer and had the same issue. I had to disable, re-enable the network adapter to get connected to the internet...
My System SpecsSystem Spec

08 Nov 2009   #4


If possible try a different router. There's some strange incompatability between W7 and some routers.
My System SpecsSystem Spec
08 Nov 2009   #5

Windows 7 Professional 64bit

ok.. i went down to the local electronics retailer and picked up a Linksys WRT54GS2 and the issue is the same.

I borrowed my neighbor's Belkin something-or-another and the issue is the same...

So, now I know its not my router thats the problem.. its any router. DSL modem by itself is flawless. put a router between the modem and the w7 box and the problem appears...

So, that means its got to be something with the integrated network adapter and/or a win7 problem in general with this network adapter?

Next logical step would be to try another network adapter, right? Well check my system specs.. youll see Ive got two BFG vid cards. They are covering all my expansion slots. I suppose I could try to find a USB network adapter or a USB WIFI adapter..?

Thing is, I shouldnt have to replace my nic just cause I upgraded to 7. From troubleshooting I think we have narrowed it down to something with the nic/s and/or win7 ..drivers possibly..? The integrated nics work fine under winVista. There must be a fix for this somewhere.
My System SpecsSystem Spec
08 Nov 2009   #6

Windows 7 Professional 64bit
more troubleshooting

Thank you all so far for the suggestions and help.

I have gone back to my original router. I read in these forums of someone having the same exact problem. His fix was to reserve an IP for the w7 box in the router config. I did so... reserving for my w7 box. The issue continues. I dont know what else to try.
My System SpecsSystem Spec
08 Nov 2009   #7

Windows 7 Home Ultimate 64-Bit, Ubuntu 10.04 Lucid Lynx, Windows XP


I'd like to suggest taking a look at your Network adapter. Start -> dev manager -> network adapter. Double click, open her up and then under "advanced", take a look at "Link Speed & Duplex".

If this is set to auto-negotiation, try re-setting it to 10 or 100mbps Full Duplex, re-start your computer and see if the problem persists.

For whatever reason, auto-negotiation features in some network cards poor. Also, if you haven't, undo the reserved ip (static) that you set up for you Win7 box before you change this network card setting.

Good luck!

My System SpecsSystem Spec
08 Nov 2009   #8

Windows 7 Home Ultimate 64-Bit, Ubuntu 10.04 Lucid Lynx, Windows XP

btw: this is a wired connection, right? I've assumed a wired connection in my suggestion above.
My System SpecsSystem Spec
09 Nov 2009   #9

Windows 7 Professional 64bit

You are brilliant, my friend. I removed all the reserved IPs from my router config. Then I went to device manager and opened the network card. I went to advanced then clicked Speed & Duplex and first I set it to 100mbps Full Duplex, hit ok and reboot. The issue was still there. So then I tried 10mbps Full Duplex. I have rebooted 10 times and every time the internet works right away without doing anything in device manager.

You fixed it, eduede! Thanks a million!

Just for my own curiosity... what the heck was happening there? Can you give a quick and dirty explanation what the Speed & Duplex setting does and why auto-negotiate was causing a problem? I love to soak up knowledge any chance I get.

Thanks again to all who responded and helped me with this issue!

oh, and yes it is a wired connection. :)
My System SpecsSystem Spec
09 Nov 2009   #10

Windows 7 Home Ultimate 64-Bit, Ubuntu 10.04 Lucid Lynx, Windows XP

Here is a link to the wiki article on Duplex.

At 10mbs Full Duplex, you've set your switch to communicate up and down stream of your router simultaneously at 10mbs. The reasons why it was necessary in your case to lower the rate of Duplex is unclear. You might want to check the Duplex settings in your router.

Another questions might be: how far (in terms of cable length) are you from the router and again how far is the router from the cable jack. The longer the cable, the harder it is to move data.

That's all I've got for you. The rest is beyond me. A network architect would know.

My System SpecsSystem Spec

 Internet Connection Issue

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 Internet Connection Issue
I am currently using the wifi on my computer, but it randomly disconnects and does not register any internet connection at all. I then click the trouble shooting button which fixes the issue, but only for a couple minutes or so before the issue repeats. In the trouble shooting window, I keep...
Network & Sharing
Just another internet connection issue
So I'm hooked up using an ethernet to my router/modem (using the 2-in-1 'Super Hub' provided by Virgin) and Windows is telling me that I have Internet Access, and sometimes that's true, but throughout the week it's been volatile a lot with hours on end not being able to access the internet on both...
Network & Sharing
Another issue with Internet connection.
Hello. I had been having earlier problems, but after a full sustem restore, I had finally got my system up and running.. except for the fact that the Internet connection had the classic Windows 'i' Icon. I have been having this problem for days after the malware removal. I had already tried...
Network & Sharing
Mysterious internet connection issue
Okay, I've had this issue for a while and I'm going to try and explain everything I can recall about it, but please feel free to request any relevant information that I may have missed out. The issue is the following: At some point for some reason, my PC loses the ability to establish NEW...
Network & Sharing
Internet Connection Issue
This is probably a trivial problem and easily solved so I am sorry for troubling people here with it but it is driving me to distraction. I recently moved house and changed internet service providers (from Orange to BT, for those familiar with the UK). Setting up my new homehub (the modem...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:19.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App