Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Rdp not working after windows update

08 May 2015   #1

Windows 7 Ultimate x64
Rdp not working after windows update

I recently performed all the windows updates and now rdp will not open. The error says

Could not load the Remote Desktop Service ActiveX control. Make sure mstscax.dll is in the path.

I confirmed the extension is in there. I uninstalled an update that was possibly to blame. I replaced the file with a known good one.

Haven't found a solution yet, been looking for days. I could really use some help.

My System SpecsSystem Spec
09 May 2015   #2

Windows 7 Ultimate x64

I'm running windows 7 ultimate x64. I also tried uninstalling and reinstalling the update that installs rdp 8.0 and it finished successfully. Also tried sfc and that did not fix it. Also tried the windows sur tool to no avail.
My System SpecsSystem Spec

 Rdp not working after windows update

Thread Tools

Similar help and support threads
Thread Forum
windows 7 update not working
windows 7 ultimate 64bit with service pack 1. windows 7 update not working it has a red x against it when I try to update I get the message (windows update encountered an unknown error code 800F900.) It has worked well before. I have tried system restore done several scans in safe mode. used...
Windows Updates & Activation
Windows Update not working
Please see link to previous history in WGA forum -- downloaded and installed new HDD raid drivers suggested by Noel Paton. Windows update still not working. Was unable to download or install SURT. Got error message 0xc8000222 attempting to install. ...
Windows Updates & Activation
Windows Update is not working
I have tried restarting the Windows Update Service using the services.msc method and using the command prompt with administrator rights to fix the problem. I have even restarted the service and restarted my computer multiple times and it still doesn't work. Attached is my CBS file and a file using...
Windows Updates & Activation
Windows Update isn't working right?
Recently I restored Win 7 to factory default and now, even though I have Win update automatically, it says: Downloading 51 updates (0 KB total, 0% complete)
Windows Updates & Activation
Internet not working, windows update, ping, DNS, etc. working fine
Hello, I've got a Dell laptop here that isn't functioning properly. I can't get this to work for the life of me! I am currently using this laptop with a different hard drive, it's the install on the SSD that doesn't work. I know that the quick fix would be to simply reload windows, but I don't...
Network & Sharing
Windows Update is not working/Update Readiness Tool won't install
Win 7 64 Windows Update not working (post migration), nor is Windows Update Readiness tool installing. I have renamed catroot and stopped services, nothing working. I just migrated HD to a hybrid solid state (Seagate Momentus). I had this problem both with Acronis 2009 and Acronis 2013, and...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:25.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App