Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Marvell network interface won't connect to network.

01 Jun 2015   #1

Win 7 x64
Marvell network interface won't connect to network.

Running ultimate x64. The motherboard I am using has two built-in NICs. The Marvell interface won't connect to the network. Sometimes it will get labeled 'unknown network' and get a 169.***.***.*** address. Sometimes it will actually get assigned an IP in the network but it can't reach the router or the internet. There have been times when the 'network and sharing center' briefly showed 'internet' access when the cable is first plugged in but then it goes back to just connected to network. However, it still can't reach the router or the internet. Looking at Wireshark there seems to be communication with the interface. A couple of differences I noticed between the working interface and this one is that is working are these Wireshark lines (working NIC is, NOT working NIC is, router is

Working NIC
301    33.042435000    BROWSER    243    Host Announcement TOWER, Workstation, Server, NT Workstation, Potential Browser
302    33.096788000    BROWSER    252    Local Master Announcement RT-N66R, Workstation, Server, Print Queue Server, Xenix Server, NT Workstation, NT Server, Master Browser, Domain Master Browser, DFS server
303    33.099335000    BROWSER    250    Domain/Workgroup Announcement HOMEOFFICE, NT Workstation, Domain Enum
NON-Working NIC
286    21.008517000    BROWSER    230    Browser Election Request
663    60.000148000    BROWSER    243    Local Master Announcement TOWER, Workstation, Server, NT Workstation, Potential Browser, Master Browser
889    92.542556000    BROWSER    248    Domain/Workgroup Announcement HOMEOFFICE, NT Workstation, Domain Enum
It looks like when the Marvell is connected the computer is trying to be the 'master' in the network instead of the router.

Are there some areas in the registry that could be corrupted? Is it possible to try the 32-bit version of the Marvell driver? If so, how? If this is hardware damage would I be getting the kind of communication I'm getting? Please help?

My System SpecsSystem Spec
02 Jun 2015   #2

Win 7 x64

Well I found out I am a victim of using 4 gigs of ram screwing up the network card. Has anyone ever found a workaround for this issue?
My System SpecsSystem Spec

 Marvell network interface won't connect to network.

Thread Tools

Similar help and support threads
Thread Forum
Cannot connect to Network drive. (Enter network password)
My network contains: 10 PCs and laptops running (Windows7 & Windows8). 2 network printers 1 Network Drive (WD Mybook Live Duo) Workgroup environment Here everything is fine. But one of the windows 8 laptop cannot access network folder. It prompt username and password. whenever I am trying...
Network & Sharing
Network Meter not displaying Network Interface
This gadget was working before but recently the network interface isn't displaying my networks in the dropdown list. I've tried uninstalling/reinstalling the gadget and tried that Reset Gadget thing that was on this forum as well. I also tried another network meter gadget but got the same result. ...
No network interface, DP43BF, new system
Hello (first post!), I've been building a new system in my spare time. I put in the specs when I registered. Bought the motherboard in March, other parts later on. People suggested Intel had goofy bus enumeration on this board (for no reason at all?), so Linux won't see the PCI slots. They...
Network & Sharing
Win 7. Cannot connect to a network, no active network, but I'm online!
Hello, first post and hope that I might be able to get help here for a problem that is driving me crazy. Many thanks for taking the time to read below... I wish to connect to my Homegroup. Win 7 says that I cannot as my location must be set to "Home". So I follow the link "What is a network...
Network & Sharing
Marvell network adapter just disappears
I'm using a Marvell Yukon 88E8053 Gigabit adapter. When I installed 7 and logged in for the first time, my ethernet did not work. I had to use a USB drive to get drivers to install it. So, I get it installed and working and then I add the PC to my domain, log in with a domain user and it cant even...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:52.
Twitter Facebook Google+