Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Admin cannot edit in a network shared folder

27 Jun 2015   #1

PC - Windows 7 Pro x64/Laptop Windows 7 Pro x32
Admin cannot edit in a network shared folder

Hi to All;

This is my first post here although I have visited many times to look for answers to various problems.

I was about to prepare a simple sharing exercise for a class I teach and had to think twice about the exercise as I encountered a curious thing.
Basically, I have a Win 7 installed in a VM with network enabled and connected. I have three accounts on this installation, testAdmin (Administrators), testAC (member of Guests) and an account testEmp which is a member of a group I created called Employees. Logged in as testAdmin I created a folder in C: called MyShare and copied a sample picture in it. Then I shared the folder through Advanced sharing and added the relevant groups under Share permissions giving the Administrators full control, Guests: deny read and Employees: Read only allowed.

Then I logged off as testAdmin and logged on using both other accounts to check the settings. I browsed to the Network folder under Windows Explorer and everything worked as expected. When I logged on as testAdmin again and tried to access the same folder under Network, therefore //Wini7VM/MyShare, I could open the sample picture but could not edit it. I also could not delete the picture.

What is curious is that if I obviously opened the folder as a local folder in C: using testAdmin I could edit, add or change things without problems.

I also experimented with folder security to give the same rights to the various users as I did under Advanced sharing but the same results were obtained.

It is a little curiosity I wish to find an answer to if some good soul can help. Thank you.

My System SpecsSystem Spec
27 Jun 2015   #2

Windows 7 Ultimate x64 SP1

Ok, after some Googling and some experimentation in VirtualBox I guess I have solved it. May still need some more cracking but looks promising for now :)

It is about UAC (Group Policy setting - User Account Control: Run all administrators in Admin Approval Mode - set to disable).

You can read about it here -

1- Change Local Security Policy and restart
2- Make sure your shared folder is not in a user profile, further complicates with NTFS permissions. I shared in root of C.
3- Remove Everyone, add your groups and assign the share permissions

I didn't try the Guest account. You can't browse to the shares without credentials anyway. At least with Everyone removed (includes Guest).

I will try with Home Premium now, as it doesn't have gpedit.msc by default(?).


Also I find it easier to browse from my Host PC, rather then logging on and off with Guest OS. If you close Windows Explorer and run in cmd: net use * /d
then you will reset the connections and will be asked credentials again without re-logging. Sometimes you have to wait some seconds to make it work though.
My System SpecsSystem Spec
27 Jun 2015   #3

Windows 7 Ultimate x64 SP1

Oh well, I guess I won't bother with Home Premium as it doesn't allow Local Users and Groups or Group Policy.
My System SpecsSystem Spec

28 Jun 2015   #4

PC - Windows 7 Pro x64/Laptop Windows 7 Pro x32

Thanks for the help.

Everything worked after the necessary changes where made.
My System SpecsSystem Spec

 Admin cannot edit in a network shared folder

Thread Tools

Similar help and support threads
Thread Forum
Network permissions for a folder inside already shared folder?
Hello, I'd like to edit network permissions for one of the folders inside a shared folder. I don't want to specifically share that folder on it's own, I like that it belongs inside existing shared folder already. I've disabled Share Wizard, and I can only edit it's settings if I share it on it's...
Network & Sharing
No permissions on shared network drive folder
Hi, Very long story short, I am the new IT Engineer at a small business and I had the task to delete a shared network drive folder. Sounds easy right. Well, some of the sub folders don't have permissions on and I get the "The requested security information is either unavailable or can't be...
Network & Sharing
How do I change shared network folder icons
Hello and thanks for reading! We have a multimedia production department, and I'm thinking on a system to mark the "ready for backup" folders. We create one folder for every project (and we can find all related documents, images, etc inside). We can't change the folder name to mark it...
Network & Sharing
Unable to map to a shared network folder Windows 7
I have a Windows 7 Pro Desktop PC and a Windows 7 Home Edition Laptop. I would like to map a drive on the Laptop to a shared folder on the Desktop. In the Network portion of the Laptop it sees the Desktop PC name and under the PC name it shows the Users folder and under that it shows my...
Network & Sharing
Shared Folder over network problem...
So, there's this problem that I've had for about 2 days now, and for the life of me I can't even seem to think or find out what the problem is, even after hours of Googling the topic. It'd be great if someone where to enlighten me on this small but frustrating problem. :D Here are some attached...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:04.
Twitter Facebook Google+